Issue Booting Zorin OS 17 USB on Macbook AirUnable to Boot Zorin OS 17 USB on Mac

Hi Zorin OS Community,

I'm encountering difficulty booting the Zorin OS 17 USB installer on my Macbook Air. I've confirmed the SHA256 checksum matches the one on the official website, ensuring the image's integrity.

Details:

  • Mac model: Macbook Air
  • Current OS: Zorin 16.3 Core
  • USB creation tool: BalenaEtcher
  • Checksum verification: Confirmed

Despite recreating the USB and trying different ports, the Zorin OS USB doesn't appear in the boot options. Oddly, I can successfully boot from a Pop!_OS USB on the same Mac.

Any guidance or suggestions from the community would be greatly appreciated.

Thank you.

For Mackbooks using GnuLinux, I have learned that rEFInd boot manager does a better job handling GnuLinux Operating Systems:
https://www.rodsbooks.com/refind/

2 Likes

Hello,
I had the same issue: Bootable usb key for Zorin 17 Beta not working on Mac
The solution for me was to use unetbootin instead of BalenaEtcher.
I hope this helps.

3 Likes

Thanks to the guidance provided. I successfully created a USB installer using Unetbootin, and the installation process went smoothly.

I truly appreciate the community's willingness to assist fellow users.

2 Likes

I'm having a similar issue since buying Zorin 17. I've used BalenaEtcher and no matter what I do the USB with Zorin on it is never recognized by my Mac when I boot. All the other boot creator software out there won't run against my level of Mac which is on Monterey - I've tried. The only problem I'm having with this theory about Etcher is that as an experiment I downloaded LinuxMint and created a USB boot with BalenaEtcher and that USB boot works fine, its immediately recognized when I boot up, but never recognized when I boot with the Zorin USB. So its not BalenaEtcher that's the inherent problem. Interesting note about this is the Etcher created the Zorin USB as a Master Boot partition map, but when Etcher created my Min USB it created it as MSDOS Fat.

I'm out of ideas and getting frustrated, because I purchased the Pro and wonder how I can get my money back. If I had just done Core I could move on and just go to Mint, but I'm in and swimming in the deep end. So far Zorin hasn't responded to my request for help, so I'm kind of out of ideas. Thoughts?

1 Like

This is definitely not a program for beginners. This program can only scare them.

Not sure I understand the reply

Unetbootin is probably the worst program I have ever dealt with. Massacre.
It's a pity that Zorin team doesn't do anything to improve the .iso

Ah got ya. Yeah, I'm going through a lot of documentation to try and figure out how to get around this, but that doesn't make my first attempt at Zorin a pleasurable one. I ran Mint for quite awhile with no problems, but wanted to try Zorin. I hoping I can figure this out quickly, because I don't want to spend days just to boot a USB.

Have you tried Ventoy? It is very easy to install and to use.
Just install Ventoy to a USB stick, then drag and drop your .iso onto the the USB stick and boot from it. Ventoy handles the rest.

I may catch heat for this but... I consider Apple Mac/MacBook users in general to not be beginners.
That being said, rEFInd is pretty easy but looks very daunting when you look at the page for it. I agree that it is not ideal; but it is a solution and computing is a very big place.
Apple actually prohibits users from installing another O.S. on Macs. They consider the hardware to be proprietary even if you did pay an arm and a leg for it.
Most Mac users go into it knowing full well that they will have to perform some work-arounds that Windows users wouldn't need.

I believe the issue seems to be specifically Zorin17 with BalenaEtcher.
Like for Mint, I could also create a USB boot for Zorin16 and BalenaEtcher without issues.
Have you tried looking for older version of the softwares compatible with Monterey? For example, you can download older version of Unetbootin here: Releases · unetbootin/unetbootin · GitHub
This is the annoying bit with MacOS, if you are not on the latest versions you quickly can't update anything...

There are other iso usb writer programs out there - Rufus is one, and there are others - found with little searching in the software repositories. I have used several - all with good results - so there is that. BalenaEtcher can glitch - esp. in a Win environment.

They are coming from Mac OS, not Windows, which is one of the main issues here. If it were windows, it would be easier as more options are available to create a bootable usb.