Issue of Ownership with the internal hard disk partition


I am a new user of Zorin OS. I have two partitions on my machine. One for Zorin OS and other for my files (Partition D). I didn't have any write or other permission on my Partition D. So, I changed it to "Create and delete files" through "Properties". But within a few minutes, all the permissions are taken off and now when I get to my partition and check the properties, option to change the permission is disabled, and it says "YOU ARE NOT THE OWNER, SO YOU CANNOT CHANGE THESE PERMISSIONS". Also,the path to the partition is changed to "file:///mnt/a9d058e3-c98d-49ba-80b5-51a2fb3537b8". Earlier it was "/media/raaghu/Partition D".

Please find the screenshots of both the permission error and my disk section for the reference.

I tried a lot in google and youtube but couldn't solve it. Your help matters a lot.

Thanks in advance.

Screenshot from 2021-07-26 12-08-33

Please open a terminal and input the following.
Replace "$USER" with the actual username you log in with:

sudo chown $USER:$USER '/media/$USER/dev/sda3'

For example, if raaghu is your username, it would look like (and you can just copy and paste this if it is...)

sudo chown raaghu:raaghu '/media/raaghu/dev/sda3'

That should get you squared away.


Thanks for this lighting response!!

I tried it but it says no such file or directory.

Please refer to the screenshot attached.


What is the terminal output of




Please refer to the screenshot.

Ok, try

sudo mount -o remount,uid=1000,gid=1000,rw /dev/sda3



We are really cycling through the mount commands... I wonder if the drive was just not mounted in the first place... :expressionless:

mount -o rw /dev/sda3 /mnt

sudo chown raaghu:raaghu '/media/raaghu/dev/sda3'

I am really sorry for that :frowning_face:

Initially it was mounted. When I changed the permission everything started messing up.

I am totally a newbie to Linux. So, please bear with me :frowning_face:


I am also sorry; I am in the habit of using sudo -i so when I type a command for others, I sometimes forget to include sudo (bad habit):

sudo mount -o rw /dev/sda3 /mnt

I may give a lightning fast response, but I am a little slow :smiley:

Hey not a prob :slight_smile: It is great that you are helping me out :relaxed:

Don't worry I am the slowest :stuck_out_tongue:

By the way, it looks like this step worked! Please check.


1 Like

Looks good- can you test if you have full access on that drive?
If not, run the sudo chown raaghu:raaghu '/media/raaghu/dev/sda3' again...

No access yet i guess.


Let's see lsblk again and see what that says...



Well, it is referring to it as /mnt/a9d058e3-c98d-49ba-80b5-51a2fb3537b8, so let's try doing what it wants us to do...

sudo chown raaghu:raaghu '/mnt/a9d058e3-c98d-49ba-80b5-51a2fb3537b8/raaghu/dev/sda3'

I didn't work I guess.


Am I too sleep dep for the helpdesk right now....

sudo chown raaghu:raaghu '/mnt/a9d058e3-c98d-49ba-80b5-51a2fb3537b8/dev/sda3'

Please don't mind!


Maybe I am too hung up on thinking of the /dev/sda3...

sudo chown raaghu:raaghu '/mnt/a9d058e3-c98d-49ba-80b5-51a2fb3537b'