Issue with waking up laptop from suspend mode on Zorin OS 16.2 - Need help

Hello everyone,

I need assistance with a persistent issue I'm facing on my HUAWEI MateBook D16 (RLEF-XX) laptop running Zorin OS 16.2. When the laptop goes into suspend mode (either by closing the lid or after a period of inactivity), it fails to wake up properly.


  • After entering suspend mode, the capslock and numlock lights indicate the laptop is powered on.
  • However, pressing keys or the power button doesn't wake up the laptop.
  • The screen remains blank, and no input is accepted.
  • To resolve this, I have to force shutdown by holding down the power button and then power it up again.

System Information:

Hardware: HUAWEI MateBook D16 (RLEF-XX)
OS: Zorin OS 16.2
Processor: 12th Gen Intel® Core™ i5-12450H × 12
Graphics: Mesa Intel® Graphics (ADL GT2)
Memory: 16GB
Disk Capacity: 512.1GB

Additional Information:

  • The issue persists in Ubuntu 22.04, 23.04, Manjaro, Fedora..
  • Notably, this problem doesn't occur when running Windows on the same laptop.


  • Once i was in Ubuntu 22.10 and this problem was not there. i thought this problem doesn't occuring because of 6.2 kernel. so i installed Ubuntu 22.04 and installed 6.2 kernel, but the problem still happens

If anyone has encountered and resolved a similar issue or has insights on how to fix this problem specifically on Zorin OS 16.2, your help would be greatly appreciated.
Please let me know if you need any further details to assist with debugging.

Thank you for your valuable support!

Gday @niamotullah ,

Are you running "Dual boot"?
If so disable "Fast startup". in windows.
Disable Fast Startup
You can also disable "Fast boot" in BIOS.

Further info:

1 Like

Link you gave says to disable fastboot/fast-startup from Windows and BIOS but i couldn't found such option there.
But there's a option in BIOS to disable Secure-boot, already disabled that one.


Seems strange, What Windows OS are your running?
Also from HUAWEI site: Here
I found a second one also indicating to disable fast startup? Here

To check if your fast startup is disabled, we need to enable "Hibernation".
Enter into Windows, open Command prompt/shell as admin,

powercfg /hibernate on

Then hit:


Now return to the power settings & 1st note if "Fast startup" is disabled or enabled?
(i wish to know if while in "Hibernation off" it had "Fast startup" disabled?)

You should now be able to disable fast startup & uncheck hibernation.
We don't want fast startup or hibernation enabled.


Kind of had same issue, so i just took it to service center and their service engineer said its made to run Windows not this one. Sorry we can't help you.

But another engineer said to disable hibernation and luckily my issue was solved :slight_smile: .

Have you take it you HUAWEI service center? Better do that there will be someone there that can help you.

1 Like

There's no Huawei official service center in our country.
So, I've tried disabling hibernation, issue haven't solved yet.

Can you please provide some details about which OS you're running now, what have you did and how?

Can you please try:

sudo apt install linux-oem-20.04d

Reboot and test.

Just tried sudo apt install linux-oem-20.04d but still the problem exists.

  • here's the hw-probe of my laptop, that might be helpful to find the issue:

It looks like you may need a later kernel.

Let's try the tuxinvader one...

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

Reboot and test suspend...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.