Issues in setting up hibernation on lvm encrypted disk

I followed this guide to setup hibernate option in zorin OS.

When I installed Zorin OS, I used LVM encryption, meaning my swap partition resides in an encrypted part of the disk.
It also means I had to go a different route/guide to resize the swap partition, but that worked out without problems as well.

Here's some info, on what my disk setup looks like:

$ lsblk
nvme0n1              259:0    0 953,9G  0 disk  
├─nvme0n1p1          259:1    0   512M  0 part  /boot/efi
├─nvme0n1p2          259:2    0   1,4G  0 part  /boot
└─nvme0n1p3          259:3    0   952G  0 part  
  └─nvme0n1p3_crypt  253:0    0 951,9G  0 crypt 
    ├─vgzorin-root   253:1    0 898,4G  0 lvm   /
    └─vgzorin-swap_1 253:2    0    33G  0 lvm   [SWAP]

And also here, to verify swap space:

$ free
              total        used        free      shared  buff/cache   available
Mem:       16178476     3170040     7967356     1133364     5041080    11537092
Swap:      34553852           0    34553852

I am running version 16.2 of Zorin OS.

However, I am still unable to use hibernation, after doing that setup.
When running sudo systemctl hibernate I get:
Failed to hibernate system via logind: Sleep verb "hibernate" not supported

I also tried installing hibernate and pm-utils, so that I can try and use sudo pm-hibernate and sudo hibernate, but they also don't work:

$ sudo hibernate
hibernate:Warning: Tuxonice binary signature file not found.
sudo pm-hibernate 

There also doesn't seem to be anything happening when using the hibernate option enabled when installing the gnome-extension simpler-off-menu and enabling the option there.

Additionally, I also configured the following files, as described in the various guides:

But for now I won't post the contents of those files, as it seems not relevant to the problem at hand, since I'm not even getting to the point, where my system goes into hibernation.

I'm at a loss at this point, and I don't know what's going wrong.
I would like to know how I can make hibernate work and also generally, how I can configure Zorin OS to show the option of Hibernate, as it currently is not there.

Furthermore, I have read some comments on the internet claiming security risks for hibernation, but I couldn't find specifics about that. In my opinion, it doesn't feel insecure, given the swap-partitions resides in an encrypted disk. But maybe I am unaware of other security risks, so any hints about that would be great too.

I specifically NEED and WANT to use hibernation, because using suspend just isn't working out for me, due to slight drainage of battery.
When I use hibernate, I simply want the system to be off and when I turn it on again, I want to be back to the programs I had opened at that point.

Any advice or response would be greatly appreciated.

Kind regards


This is more of a clarifying comment than an answer. The text of the error is arguably a bug in of itself:

hibernate:Warning: Tuxonice binary signature file not found.

Here the programmer has attempted to warn users that a file seems to missing. But the programmer has left out an essential piece of data, specifically the name of that file.

The program itself must know, so it's not like the error message couldn't say something like:

hibernate:Warning: Tuxonice binary signature file "/foo/bar/baz123" not found.

Can you launch Disks, and show the properties of the swap Partition?

Should show something like this
Screenshot from 2023-04-26 17-55-52

Oh one other thing I just remembered.

Secure Boot can cause the error
Failed to hibernate system via logind: Sleep verb "hibernate" not supported

if enabled try booting without secure boot and running

sudo systemctl hibernate


First, here are the screenshots:

I will try the cmd without secure-boot, but the reason I kept it activated is due to the fact, that I still have a Windows 11 backup for switching back, in case my attempt to switch to Linux succumbs to the problems inherited by that change.

I always thought secure-boot is part of disk-encryption things, but Linux taught me otherwise.

I guess I'll uninstall those two packages then, since they don't appear to be necessary. I was confused as to why I would need an additional package for those actions anyhow.

Secure-Boot is part of Windows Security - to simplify it, the uefi and windows compare security keys to ensure they are paired and authorized to boot, but part of this are universal keys for installs and oobe - Microsoft gave Ubuntu REHL and a few other Major vendors Keys as well

It worked! Thank you, seems to be solved with disabling secure-boot.

It takes quite a bit to properly go into hibernate, but worth the energy saving for me.

After disabling, the option to use hibernate in zorin power settings also appeared.

Its kinda stupid IMHO as secure prevents certain ACPI functions from working in UEFI as the handshake is different from windows even though Zorin has a legit key from ubuntu, its well stupid how it works LOL but the windows install reserves certain functions in the uefi and prevents them from working right.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.