Issues trying to install Zorin OS Pro

Hello, i'm new on this forum and fairly inexperienced with linux based OS's.

Ive bought the Zorin OS 16 yesterday morning and since then i've been trying to install it on my machine with no success.

I came across a few errors while trying to boot the USB Stick containing the OS and tried multiple solutions, the further i got was past the install selection screen (where you can choose normal installation, Nvidia and such), right after it i would get a black screen with errors.

I hope someone can help me, my computer specs will be listed below and also some of the errors and solutions i've tested.

These are the specifications listed on my motherboard's BIOS. The GPU i'm using is a GTX 1080 and the drive i want to install to is a 960 GB SSD.

For most of my attempts, either the MOBO wouldn't see the USB stick connected or when i would try to boot it, it would quickly get back to the BIOS Menu.
For the rest of them, i would get stuck after selecting to install with NVidia Graphics.

Here are some of the errors i've encountered so far:

It's hard to tell what got me there and what didn't help since i've been changing bios configs and other stuff for a long time now. But at some point during this process i took pictures of some of my motherboard configurations. Here are they:

Now i'll list everything i've tried so far, but keep in mind i cannot the exactly which one helped or not. I also don't know if i've tried every combination below, but i've been pulling my hairs out since yesterday.

Ihave tried to create the bootable USB stick with several different software, including Rufus, YUMI, unetbootin and BalenaEtcher.

I have tried two USB sticks from two separate brands.

I've tried NTFS and FAT for both USB Sticks.

I tried two copies of the ISO, downloaded from Windows and Linux.

I changed every possible bios setting that could relate to the problem and tried to install with many possible configurations.

I tried to set an Administrator password on the bios to check if any hidden options would show up.

I reseted the Bios severel times to default settings to start again.

I uptated the bios to the most recent one.

I have no idea what could be stopping me from installing it. I've had problems with linux based OSs in the past bu never before even installing/booting it ;(

If anyone could help, it would be really apreciated!

Can you verify the checksum?

Scroll to the bottom of: Download - Zorin OS

For the sgx issue you can follow this post

It looks like the same bios in that thread. Hope you have better luck to install Zorin.
Read that thread for all info.

Vmx in bios is disabled. It is virtual machine? Your bios is little near what working on ASRock. Then options are in boot management key. If uefi not working there then change for Legacy.

1 Like

CSM isn't was faster boot but not recognize boot from USB pendrive? Can you show help on CSM in bios? In ASRock was if enabled not booting from USB.:slightly_smiling_face:
Suffice it to say that if your PC is fairly new and came with Windows pre-installed, CSM would've been disabled by default . You don't need to enable it. It's only needed if you must install an older OS that doesn't support UEFI.

If you comming to BIOS at boot then computer can not find bootable drive. I always use Rufus to flash the usb. Make sure that the BIOS is set for uefi and the partition scheme is GPT in Rufus. When you boot the computer hold the F key for boot option. On mine is F8, but on your could be different -Google it. See it your computer find any bootable drive.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.