Issues with Sound on Pro 16

Hello

Installed Zorin 16 Pro and had no issues with sound originally. Using a 2021 Dell XPS 17 9710. Everything was working fine after install. And then had an emergency and needed to plug the laptop to power and at the time my only option was a docking station. Plugged it in and when the battery capacity was at full I removed the USB-C from the laptop and that's when I lost sound. at first sound in settings was showing dummy output I think. I tried some troubleshooting steps from this site:

However, this did not help. I can plug in a USB-C headphone and that ends up working, however, I am getting no sound from the laptop speakers.

Hoping there's a way to reset the sound configuration back to default.

What's crazy is that I also have an XPS 15 running Zorin core 16 Beta and that has no issues reverting back to the default sound output device, so not sure what is going on with the XPS 17.

Any help provided is appreciated.

1 Like

Can you run pavucontol (If needed, you can install with sudo apt install pavucontrol) and then hit the third tab over Output Devices...
What is listed there?

1 Like

wow that was fast give me a few to get that done.

1 Like

1 Like

Wow, thanks for the detail. In Pavucontrol, it shows output USB Line Out. Are you using standard jack speakers normally? Or at they USB speakers?

So I'm at the office, I am plugged into the correct docking station for this laptop. This is why you're seeing the additional USB items, I also have a Headset connected to the dock which is also working on Zorin. Now If I disconnect it defaults to this HDMI-NVIDIA for whatever reason and not the default sound output which I believe is the device 1.

Hope this isn't going to require a reinstall of Zorin OS 16 Pro :frowning:

Next to that output - where it says Nvidia- there is an icon on the upper right shows a Lock.
Does clicking that Lock Icon Unlock the drop down menu?
From there, can you access the down arrow on the drop down and select the onboard sound card?

adding screenshot, so clicking lock icon only gives me option for left and right speaker on the HDMI Output, Doesn't give me option for any other sound device.

Ok what about the last tab - Configuration - Built-In audio - drop downmenu?

On the configuration tab I am only seeing HDMI option and Off, I can take a screenshot if needed.

So my question again becomes, is there a way to reset audio to default or what it was before it all got changed?

1 Like

Yes, you can remove any audio config files stored in your home directory ~/.config and reinit pulseaudio:

rm -f ~/.config/pulse/*

sudo killall pulseaudio

I assume that requires a reboot and sudo before the rm command?

No, neither should be necessary.
The first command is run from your Home Directory IN your home directory.
The second kills pulseaudio's processes which cause it to automatically reinitialize all processes.

So followed steps (rebooted for good measure), you provided however sound settings only show HDMI as the default and only option. still no sound out of speakers, but there is sound when I plug a USB headphone to laptop. Unless you have another suggestion I may be forced to reinstall. I think I read somewhere that I should consider uninstalling both Alsa and Pulse and reinstall, Thoughts on that ?

It is worth trying...
I am aware of it... But... Personally I usually do not recommend it. Pulse and audio have, in the past, conflicted with each other and it is best to use One Or The Other. Not both.
That being said- I am no Guru. I could be wrong. If you are thinking of reinstalling, then really the risk of trying pulse/alsa together out is worth it.

what does Zorin default to? Is it Alsa or Pulseaudio?

This one.

ok tried it by itself and it was more of the same. Think we've exhausted it all. Will just reinstall Zorin tonight and not repeat the mistake of plugging XPS to incorrect docking station

1 Like