Issues with Sound on Pro 16

Just providing an update, running 16 Core and basically live environment shows dummy output, not sure why. Providing a screenshot. I get the same in pro.

Will try a different distro temporarily to check on sound issues just to see if issue is related hardware specs on this laptop specifically.

1 Like

You could also install Alsamixer to check the audio settings.
sudo apt install alsa-utils

Then open Alsamixer in terminal.
alsamixer

This is how mine looks like:

OMG, Alsamixer is like returning back to the DOS days, only not as cool lol. I remember back in the 90's, we gamers had to always load up the sound configs for games, which used DOS to set them. This was before games got smarter and did it for you.

You'd basically see a config drop down for your sound card, weather its sound blaster 16, or some other sound card. Then you would also have your graphics drop down for Voodoo or some other graphics.

Gosh those were simple times lol.


Remember this FrenchPress?

I will admit nothing so that you cannot guess my age :rofl:

LMAO :joy:, I never ask a lady her age. But I would guess were about the same age +- a few years. Honestly, I like talking about the past when it comes to technology. Like I've said before, experiencing past technology, gave us appreciation for modern tech.

So after trying 3 different distros, one from arch, one from Ubuntu,

and one from Debian, all returned the same issue. No sound, so no driver for the sound device. Providing a screenshot from Windows 10 setup to show you hardware and some driver info. Perhaps someone will be able to provide some solution to this driver issue. Again this is an XPS 17 9710. 2021 model.

Seems to be a known issue. I assume updating the kernel could fix, but not sure which mainline kernel will address this issue.

Seems like I'll have to wait for kernel 5.11.0-32 before this might end up working :frowning:

1 Like

I think @Aravisian could give you an advise for manually upgrading kernel.

So updated to the new kernel 5.11.0-34 today on Dell XPS 9710 and basically got more of the same. Sound issues have not improved. Tried to start PaVu control to try and switch to the correct output device, however, the correct output is not listed. Not sure what else can be done. Any advice on this is appreciated. Someone please save me from windows hell :frowning:

Thanks

Since you have purchased Zorin 16 Pro, you can ask for help from developers for installation problem. Send a reply message to the email you have received when you bought Zorin 16 Pro.

ok thanks will do.

1 Like

33 posts were split to a new topic: Dell XPS 13-9343 Sound troubels Z OS 16 Plus assorted debris

Just a gentle reminder the title of this thread is: "Issues with Sound on Pro 16" :wink:

@Masterpier (if you are still following this) Can you run Alsamixer from terminal and post a screenshot.

Sure just giving an update, updated to kernel 5.11.0-36 today and no change still getting dummy output adding screenshot per request of alsamixer

Aravisian recommend's trying out the new 5.14 kernel, but you can't get it from the Zorin repo. So, you have to download it from Github I assume. He says the 5.14 kernel might fix issues, so try that.

But always backup a system before trying a new kernel. Yes you can always revert back to an earlier kernel, but just incase, please backup the drive first.

so I would love to move to 5.14 however don't think it will work with Vmware Workstation.

I think you are referring to a different member. I had not recommended any Unsigned Kernel.

The recommendation I have made is to Modify /etc/modprobe.d/alsa-base.conf and blacklist.

OK so I've tried it all, kernel 5.14.6 and I've run commands Aravisian recommended, and after reboot still getting dummy output.