Keyboard and mouse not working

keyboard,mouse(right click and scroll only),even virtual keyboard not working on zorin 16 pro.

first it started with one user on my pc, my brother wasn't able to login in his account i had to reset his user. then it started happening to mine user i tried sudo apt-get install xserver-xorg-input-all
but this didn't work.
even on the grub i cannot move up or down
my keyboard works good i checked it on my android ,etc.
whenever i am googling or doing some thing else,at start keyboard works well then suddenly when i press
's'-settings open up
'g'-search bar opens
'k'- virtual keyboard opens up
but in the settings the command is 'ctrl+s' for setting and 'ctrl+k' for virtual keyboard.

then i tried typing with virtual keyboard, but even on that when i press 's' setting opens up and etc. it just acts the same.

and i don't like to say it but zorin has the worst customer support i ever saw.
they never reply to emails, they don't even bother about your complains. they just started a forum on which people answer each other's queries. i am like "we have quora and reddit for that, don't we?"
someone help me please!! :pray:

The cause of this sounds like power management.

CTRL ALT T to enter terminal.

xset -dpms

This is intriguing as it suggests that a user configuration is causing the conflict.
Can you try renaming your ~/.config directory on all affected user accounts. You can rename it to something like .config-bkp or .config-broken... It is just a back up of all your configurations in a directory that the system will ignore.
Once that is done, reboot the computer (Which will revert all user configurations to default) and test if mouse and keyboard remain affected.

emphasized text

No error was shown but nothing happened it is still the same !!

Man!! I am so stressed I guess I am exiting linux

I changed the name of every .config file
But still nothing happened!!
Please someone guide me!!:pray::pray::pray::pray:
How can I operate without keyboard and mouse ?

But mouse and keyboard are the same.
They worked for a bit in the start but then the same thing happened again.

To pinpoint the cause of the issue, you could boot into a live session from the installer USB to see if the problem persists.

As for the direct support from Zorin group, it consists of only 2 people. Sometime the reply can take a long time. I remember I had to wait for about one week with my support request last time. But they will reply you eventually.

Fine i will try that.

I emailed them almost 2 months ago but still didn't get any reply.

That sounds a bit too long.
Did you send a message as a reply to that email you received when you bought Zorin 16 Pro?

No, I went to the site and just saw the email and gave them a message

That explains why.
This kind of mail links are hit and miss.
You should reply to the email they sent to you when you made a purchase.

While I understand your frustration I think there is a misunderstanding.
I never go to Reddit and I even do not know what Quora is.

We are no way associated with Zorin group but a group of like minded people who appreciate Zorin OS and trying to give some help to Zorin group which (as I have already said) consists of only 2 people.

Yes!! The problem still persists with the live usb.

Then you should ask a direct help from Zorins.
Pro version includes the installation support :slight_smile:

As I have already wrote, send a message as a reply to the email from them :email:

yeah!! i guess that's the only option left
i kinda opened my keyboard and checked it to see if there was some internal problem or not. i didn't touch anything(since, i don't know anything about keyboard hardware). and then i powered on my pc and it works fine.

i don't know how or why?(tho i would love to know he reason) but it works.

still i guess i should write to zorin for future references.

btw thank you everyone for replying and joining the thread. will let you know if some problem occurs

1 Like

Reminds me of an old time when people knocked a side of TV to make it work :tv:

But anyway, it is a good news that you managed to make it work :slight_smile:
Please select your own answer as "solution" and tick the :ballot_box_with_check: to mark the thread as solved.

You were in conversation with @FrenchPress, she has a magic brush that sometimes does the trick :wink:

Since your keyboard is working, does that also apply to your mouse?

1 Like

Yes my keyboard,mouse and even virtual keyboard works good.
I don't get it how my keyboard and my virtual keyboard both be affected, unless and until this was a software issue? And if this was a software issue how can it be resolved by me opening the keyboard?

I did nothing for the mouse but still it works, why?

1 Like

The only thing I can think of is did you unplug then reconnect your mouse or keyboard?

Can we also assume you can reboot and then still have use of your mouse and keyboard. If true, don't get over concerned by "why", just enjoy your ZorinOS.