Keyboard backlight not working HP EliteBook

I just installed Zorin OS onto an HP EliteBook. I've been able to figure out how to get the volume up/down and screen brightness/dimming f keys to work, and even got the numlock working....but cannot figure out how to get the backlight for the keyboard working. I'm a newbie, figuring things out as I go. I have researched and researched this and cannot find anything that has helped. Any help in newbie terms would be so appreciated!

I'll also add that right now, the f key that was for the keyboard backlight, when pressed, brings up a "find on page" bar at the bottom of the window.

Any of these help?
https://forum.zorin.com/search?context=topic&context_id=15246&q=Backlight%20in:title&skip_context=true

Also helps if you can provide links/descriptions of the methods you tried because then we know what not to recommend.

I tried xset led in the terminal according to some instructions I came across on a different site; that did not work or make any changes. The only thing I could find on this forum of similar experience was on an ASUS and it did not help me. The link you provided me just gives me this thread here that I created; I was not able to find anything else on the forum.

I am guessing you have tried tapping the F5 or F11 key?

Some say it is F4 or F9...

See if this link works better. Search results for 'Backlight in:title' - Zorin Forum
Basically, use the Search feature and paste Backlight in:title in it to search only in titles. 2 of the 5 results are:
How to Enable Keyboard Backlight Function Key Combinations (Zorin 15.3)
&
Keyboard backlight not working

There are two others I’ll not listing. They’re unsolved but may have useful info for you.

Yeah, i've tried them all. None of them are getting the keyboard backlight to work. So strange because I put Zorin onto a much older HP laptop yesterday and all of the f keys worked right out of the box, seamlessly. Was hoping for the same on this much newer machine, but no dice!

The first link takes me to just this thread. The other one I did see earlier, but it references and ASUS machine and i'm unsure if i will mess anything up by putting all of that into my terminal.

The first link leads to the Search Results. It lists Many Threads, not just this one.

If the links aren’t working for you, have you tried using the Search feature as I suggested?

It lists asus but since it interacts with acpi interface, which is part of the kernel, it should not hurt your system. If it doesn't work you can always remove the files to reverse what is done.

I will give it a shot. The list of steps is intimidating for someone without a lot of experience with the terminal, like me. But i'm willing to give it a try!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.