Keyboard inputs periodically missing/lagging/repeating

Hi all! The short version: I've been trying to breathe new life into my old HP Envy 15 laptop and its old Windows OS was running extremely slow, so I decided to start tinkering with various Linux distros to try and make it into a mobile workstation. I am not interested in running games on it or doing anything fancy, it just needs to be able to connect to the internet and run my notetaking app of choice (Joplin, if it matters).

I recently got around to trying Zorin and loved it, but there's one problem: the keyboard inputs are borked. Every so often I will be typing and the keystroke will either be ignored entirely, lag for a few seconds before spitting out a few letters, or repeat endlessly until I press another key. This happens regardless of the app I'm using - it's most obvious in documents, but I will occasionally find that my browser is trying to repeatedly load a page as if I were holding down enter.

Here is what I've tried so far:

  • Updating Zorin completely (version is 16.1 with all available updates installed)
  • Swapping the USB ports (the keyboard that I use is plugged into a hub, it's currently plugged directly into the PC)
  • Slow/sticky keys are disabled
  • Using an older kernel (5.13.0--52-generic) as mentioned in another topic on this forum but that didn't affect anything
  • Tried checking the syslog around when an episode starts, I haven't done this long enough to notice a real pattern yet but did notice that at least a couple of times that happened there was this message:

Activating service name='org.freedesktop.thumbnails.Thumbnailer1' requested by ':1.22' (uid=1000 pid=1270 comm="Thunar --daemon " label="unconfined")

I have no idea what this means, it's basically arcane sorcery to me.

  • Monitoring the CPU and RAM usage indicates that they're both operating below maximum capacity

Some other bits:

  • This didn't happen when I tried out Zorin on a Live USB. I tried it for a couple of days and it never stuttered once.
  • This has happened on every Linux distro I've installed onto the HDD, and on two different PCs (the other is a Dell laptop). Again, this doesn't happen on any Live USB version of any distro.
  • I have NOT updated the BIOS. I understand that this can sometimes fix this issue, but Zorin is the only OS on this PC (so, not dual boot Windows to update it easily), plus as mentioned it happens on a different model laptop anyway.

Any ideas about what's going on and what I could do would be great - I would hate to have to write off this laptop entirely or, worse, have to try going back to Windows. Thank you.

Even in Windows on a Hp Netbook I experienced issues if the touch pad had not been disabled. Can you disable the touchpad and see if that improves things?

You mentioned a Thunar message, which suggests you are using Zorin Lite, is that correct? Thunar is xfce's default File Manager. You mention use of a hub. Sometimes these too can create issues even in Windows. When I was working we had some 4 port usb hubs that got replaced with 8-port D-link usb hub which worked better.

Sorry for the delay, sometimes it takes a while for the symptoms to manifest, so I wanted to go for a day or so to be sure.

I tried disabling the touchpad; when that didn't work, I moved on to plugging the keyboard directly into the laptop. This seems to have worked for now - I managed to work for the entirety of today without an episode.

Also: yes, I'm using Zorin Lite. Are there issues with Thunar? I'm reasonably familiar with computers in general but Linux is almost entirely brand-new to me.

I appreciate the help, by the way; this first exposure has been pretty disheartening, though I think that has less to do with Linux itself and more to do with my more techie friends presenting it as the solution to all problems ever, and "easy to use" is a relative term, haha.

You just need to remember that hardware generally was designed for 'that other OS' and not GNU/Linux!

Have you tried an external keyboard rather than an internal?

5 Likes

Sad but true! I'll add "Linux-specific hardware" to my list of things to look into on my Linux journey, too.

2 Likes

External is the only kind of keyboard that I use for this one - this particular laptop's old and janky and its built-in keyboard doesn't work properly, so until I can get a replacement part I've just attached it to a TV and have been using it when I need to work in the living room.