Kyocera FS-1220MFP

I bought a new MFD Kyocera printer scanner last year (Kyocera FS-1220MFP). Turns out it isn't recognised by Linux, Kyocera have no Linux driver, and even Vuescan can't work with it. So I either need to sell it on, and buy a new one, or switch to Windows every time I want to print or scan. Ouch.

I just want to check - is there any other option I haven't considered? Thanks!

Hey Karl

I never heard of that brand before. I think Linux has support for all the popular well known brands. You really want to be looking at HP printers or Epson printers, they have the highest level of support.

Some people report older Brothers working in Linux, but modern Brother printers do not. There is also Canon printers and Lexmark printers as well. Again, I just named off the well known name brands of printers.

I don't think your going to find support for no-name brand like Kyocera. Like I said, never heard of it, I don't think Linux has either lol. If you want my advice, I'd sell that Kyocera, and get something that is well known.

You can Google specific brands to look up Linux support on BTW.


1 Like

Thanks, I'll see if I can sell it then. I have an unopened toner cartridge (they normally cost £60) so that may help!

I have a list of possible replacement printer scanners somewhere. Brother did feature in many recommendations, but maybe they were older models, as you say.

I do not know if this older package applies to your machine or not:
https://kyoceradrivers.cc/driver-software-for-kyocera-fs-2100dn-kx/

Or if this discussion thread will be any help:
https://forums.linuxmint.com/viewtopic.php?t=280986

3 Likes

There is a scanner driver here:
http://greenlight.kyocera.co.uk/index/products/download_centre.false.driver.FS1220MFP._.EN.html#

No printer driver listed there.

2 Likes

I think I found it :slight_smile:

No, that site is looping itself :(.

I could only find this page:
https://driverscollection.com/?file_cid=4685330799621c5deb5b47feeca

And as @zabadabadoo said, there is only scanner driver for Linux :frowning:

3 Likes

Kyocera is a Japanese company.

The company locates in Kyoto.
Kyoto + Ceramic = Kyocera

2 Likes

Well, suddenly I like it now. If its Japanese, I like it. I am a simple person, what can I say? :grin:

2 Likes

Unfortunately their Linux support is non-existent.
I checked all related pages in Japanese but no dice :frowning:
https://www.kyoceradocumentsolutions.co.jp/download/situations.html

2 Likes

If you plan to replace the printer in future, you might want to ask recommended printers in the forum.
I personally recommend HP or Brother. Both have a very good Linux support.

2 Likes

The driver for scanning is on the Kyocera UK Page here:

For the Printing side use the driver available in Zorin - FS1200:

I extracted the .zip file in my downloads folder and inside of that are the following:

If you haven't installed Gdebi package manager using Synaptic Package Manager (install from Software channel), launch Gdebi and then point the file to open the

kyocera-sane_1.1.0228_amd64.deb

image

Hopefully you should now be able to scan!

If not you might need to install the 'xsane' package via Synaptic Package Manager as it states it is a SANE scanner driver:

3 Likes

This reminds me of the close enough driver I used to use for my HP P1005. It is now included in OS but before that I used P1006, which worked without a hitch.

2 Likes

I had the same issue when I had a Canon i-865 Pixma printer - solution? I looked at what printers the ink cartridges would work in and at the time I chose Canon 8800 - worked perfectly!
Currently my Canon all-in-one TS-8151 works with the TS8000 series printer (all linux distributions apart from the Arch-based Artix distribution that doesn't even list Canon in any of its distros!)

3 Likes

You are absolutely right!
HP P1005 and P1006 use the same cartridge.

2 Likes

I've update my original reply with more information on the Kyocera package - hopefully it will work. When I was working, we had a Kyocera MFD device (can't remember the model number) but at the time I was running Zorin 12 on an off-line (not officially networked) Samsung Notebook and was able to connect it to the network and print to the Kyocera but I did have some teething issues to make sure it was printing to the correct tray!

3 Likes

Wow. It is impressive.
Do you think you can create a tutorial with this?
I am sure it will be quite beneficial to anyone having an driver issue with Kyocera printer in Linux.

2 Likes

world using GIF

I think we can all relate to teething issues.

2 Likes

How do I get to that list of drivers? I tried searching for "printers" and "drivers" in the start menu but none led to a list like that.

I'm not sure if I have that (I haven't manually added it), but if I double click on the deb file it does install. However, it doesn't add any extra loadable software, and "Document scanner" from the start menu still can't find a scanner.

Printers -> Addition a Printer Setting.
Select cups-brf:/

1 Like