LAN Ethernet no device in eth0 settings?

On terminal I have 1Gbps full duplex. Can i speed up internet?
Fiber internet I have. This is what i have from terminal.


With this commands device no exist.
billy@Zorin-16-Pro:~$ sudo ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available

Find some webside here Linux Kernel Driver DataBase: CONFIG_ALX: Qualcomm Atheros AR816x/AR817x support
but I wondering if this is newest drivers from this side or only some information about this LAN Ethernet. I am connected with switch.

What is the output of

dmesg |grep eth0

billy@Zorin-16-Pro:~$ dmesg |grep eth0
[ 2.665829] alx 0000:04:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [d8:cb:8a:70:06:f6]
[ 2.914632] alx 0000:04:00.0 enp4s0: renamed from eth0
[ 2451.943647] alx 0000:04:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [d8:cb:8a:70:06:f6]
[ 2451.945609] alx 0000:04:00.0 enp4s0: renamed from eth0
[ 2837.785582] alx 0000:04:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [d8:cb:8a:70:06:f6]
[ 2837.787214] alx 0000:04:00.0 enp4s0: renamed from eth0

I think i need see something like a that.
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Current message level: 0x000060e4 (24804)
link ifup rx_err tx_err hw wol
Link detected: no

There's the trouble.

Please see this well written guide to resolve the issue:

Did you check
/etc/sysconfig/network-script/ifcfg-eth0
or /etc/udev/rules.d/70-persistent-net.rules ?

both are empty.
I checked writing sudo nano /etc/sysconfig/network-script/ifcfg-eth0 and
sudo nano /etc/udev/rules.d/70-persistent-net.rules

1 Like

Honestly, I am stumbling forward into unfamiliar territory, here.
Let me try researching this issue for a while.

this link up what i put give some information. The E2200 series is supported with Linux kernel 3.10 and higher.

So I understand i need put driver inside kernel.
http://manpages.ubuntu.com/manpages/focal/man4/alc.4freebsd.html

Drivers generally are contained or patched within the kernel by the team that manages the Linux Kernel. It is possible to patch the kernel yourself... but that can get messy.
What about trying a different kernel? And yes, this can include an older kernel as much as a newer one.

The Linux kernel is a Tool Of Applicability, not of "latest is greatest." What matters most with the kernel is that it Applies Best to your system- not that it has a high number on it.

Ok but why I cannot see settings for eth0 if they are correct. I understand newest drivers are for newer technology. Example on webside this ethernet card I cannot find any older drivers only for new operating system if we talking about drivers. I also choose Zorin because I don't want any win10,11 etc. Sometimes gaming on w7.

1 Like

Just for clarification, "switch" means something like this?

1 Like

yes that is correct full duplex 1000Gbps I have and then connected with a router.

I just run this command on my system:
[ 1.519735] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 30:5a:3a:76:37:10
[ 1.519738] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[ 1.519768] e1000e 0000:00:19.0 eth0: MAC: 10, PHY: 11, PBA No: FFFFFF-0FF
[ 1.705233] e1000e 0000:00:19.0 eno1: renamed from eth0
[10360.441286] r8152 4-2.4:1.0 eth0: v1.11.11
[10360.479488] r8152 4-2.4:1.0 enx00e04c68c9e0: renamed from eth0

I also have this "renamed from" in the output but without any ill effects.

1 Like

my is diffrent like you see up on photo prntscreen.
and this two are empty /etc/sysconfig/network-script/ifcfg-eth0
or /etc/udev/rules.d/70-persistent-net.rules

So, I may have been barkin up the wrong tree.

Cant you check your settings eth0?