Laptop does not detect the external monitor using the hdmi port

Hey guys
complete newbie to Linux here
just installed Zorin OS 16 pro on my laptop on dual boot.
While installing i was able to have the display as an extension on my external monitor, post installation, it seems that i cant connect to the external monitor any more.

any help would be appreciated.

Can you please post the output of

sudo lshw -C video

let's see what graphics card and drivers you have.

Hi
Thanks for getting back, please see the output below
*-display UNCLAIMED
description: VGA compatible controller
product: TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list
configuration: latency=0
resources: memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4080000-a40fffff
*-display
description: VGA compatible controller
product: UHD Graphics 630 (Mobile)
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:152 memory:a2000000-a2ffffff memory:b0000000-bfffffff ioport:5000(size=64) memory:c0000-dffff

Can you move to the app menu and search for Software & Updates
launch the application, then navigate to the Additional Drivers tab.

It should search for drivers - once it has finished, ensure you have Nvidia 510 (Proprietary). Select that driver, then select Apply chnagesLog out and in after closing outSoftware & Updates` and test...

I really wonder why zorin has so much issues with nvidia drivers while pop os and other distors does not have this.

I see alot issues here with 515 driver while pop os has zero issues with that driver in the past 3 months. I use 525 driver now for almost 2 weeks with zero issues.

Maybe a idea that zorin should prehaps use the drivers from system76 ?

Every users experiences can vary. Aside from the initial 520 driver, I have had zero problems.
Sometimes, other users do.

But the Nvidia Drivers used in Zorin OS are the exact same drivers as used by POP_OS.
And the kernel loading is the same - both are also based on Ubuntu...

It may be that users on this forum are a bit more comfortable approaching with issues so we hear of it more readily.

tried that, still does not seem to have fixed the issue
I am going to try and use some other drivers and test it

Will let you know the results.

One more thing, in the about section i can see that the graphics description points to
Mesa Intel® UHD Graphics 630 (CFL GT2)
Can this be a reason?

I am guessing right now

Often, there are two graphics cards - the built in Intel graphics on the motherboard (Integrated) and the AMD or Nvidia inserted Graphics card (Dedicated.)

Tried few of those drivers , none of them seems to work.

You must reboot between changing drivers.

yep, did that everytime i changed it

Can you check if the HDMI cable is directional? Many are. Try turning it around.

so the same cable was working fine, while i was installing Zorin OS.
I could see the installation happening on my external monitor,
Once the installation was done, it stopped working.

Let's try:

sudo nano /etc/default/grub

Arrow key down to the line ending with "quiet splash"
And edit in the nomodeset parameter:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Tap ctrl+x to exit the nano editor, then the y key to say yes to save, then the enter key to save current configuration.
Now, you must run

sudo update-grub

reboot and test.

In your Nvidia server settings PRIME profiles, which one is selected? In order for the Nvidia graphics card to process the graphics, you will have to set the PRIME profile to Nvidia on-demand or Nvidia (Performance Mode). If Intel (Power Savings Mode) is chosen, it won't matter what you plug into the HDMI port since that port is only accessed by the Nvidia card.

During installation the Nvidia card was in use.

1 Like

did not work,
followed the steps as mentioned

hey harvey
i opened my nvidia setting and unfortunately its a blank space, there are no profiles, or any kind of setting to play around with.

Then you have the wrong driver for the graphics card loaded. Try changing to one of the other Nvidia drivers (try the 510) and remove the nomodeset (think that loads nouveou (or however you spell it) driver) from grub. Remember to update-grub.

Is it ? Because pop os does not recommend installing the driver by hand duo different dependency or something like that.

I also still wonder how pop os or zorin os (or any other distro) implement those nvidia drivers on their system to get installed without getting into tty. When i install the nvidia driver by hand i need to blacklist the nouveau driver and then install the nvidia driver.

I still wonder how this process works

There can be different processes such as using DKMS... Installing manually will not attach with DKMS.