Laptop going black screen and not booting

Hello, i installed zorin a couple of days ago from a bootable usb. the installation went fine untill i had to restart my laptop, when i restarted my laptop, the zorin logo and the dell logo popped up and nothing happened for a while, after sometime it went black screen. like not even that very dim black that happens in windows, just completely black. i force shutdown it and went to "Advance options for zorin" chose recovery mode and booted into normal mode. i thought it worked fine but it didn't, the brightness wouldn't go down, it doesn't recognise my integrated intel hd graphics card, i tried installing the drivers but that didn't work either. I'm planning to switching to ubuntu but that's a maybe. is there a way i can fix the problems i have or do i switch to ubuntu.

Any help would be appreciated. thanks

Your graphic driver or the zorin os desktop may be malfunctioning.

Use this guide to reach the terminal,

then, for NVIDIA graphic Card.

Upon pressing ctrl+alt+f5, the tty does not open up for me

Can you please try ctrl=alt+F3 to enter tty and remember (or write down) that you can use ctrl+alt+F7 to exit the tty.

Hi, have you tried a memory test yet? That might solve it, but I'm not sure.