Laptop keyboard unresponsive

I have a HP laptop and at the start of every login screen the whole keyboard doesn't want to work until I fiddle with buttons

I try fn+F1-F9 and sometimes right click on the password prompt and keep tapping Esc until it blinks then I'm able to imput a password

It has always done this on all Linux distributions I can't even get a try open as the whole thing is unresponsive usually works after a few minutes of doing the mentioned process above

It would be nice to get my keyboard working without me having to fiddle with it on every boot

Does fiddling actually make a difference or is it that the drivers need time to initialize?
Have you installed

sudo apt install xserver-xorg-input-all

Not home at the moment but as soon as I get home I will have a look using the apt list xorg command to see if it's installed and install if needed

I don't think that it's the drivers but it is a possibility as I'm not ruling anything out.

The annoying thing is that it randomly started one day however I've never dropped it could be a bug in a package as fedora used to always give me xorg-x11-drv-intel error on each boot in

Could also be latest kernel. Could try rolling it back and see if it improves.

Had the same problem on first boot of Linux Mint normal iso not the HWE keernel with 5.13. The normal iso uses 5.4 kernel if I remember correctly

1 Like

What is the exact make and model of the HP notebook?

I have lost my exact documentation on what model but my dmidecode output has HP Laptop 15s-fq2xxx with the family being 103C_5335KV HP Notebook

I found a bug report on this and the only suggestion is the following workaround: Add the Boot Parameter i8042.dumbkbd=1

sudo nano /etc/default/grub

Arrow key to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the parameter to make it look exactly like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.dumbkbd=1"
Tap ctrl+x to exit, then y to say yes to save, then enter key.
The terminal will revert to normal. Now run

sudo update-grub

Reboot and test...

Source:

I will test in the morning when I get the chance as I have to sleep :sleeping: for work unfortunately.

It would probably mess with my current config of me having it as =show so I can select my login kernel at least on my linux mint laptop (same model) however it might work for my Zorin OS build where picking the kernel isn't needed as it's just my production machine for podcast recording and editing.

I marked your post as a solution as it does work however I feel it is the drivers in the kernel just haven't 'loaded' yet as it seems aboout the same timeframe in the keyboard being responsive and it seems to affect newer HP laptop models only

Just for kicks and grins... have you tried

sudo apt install xserver-xorg-input-all

If it give you any trouble, just remove it...

Yeah it's already installed and latest version :laughing:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.