Laptop won't turn on after installing and restarting Zorin 16

I have a brand new (1 month), Dell AMD Ryzen i7 ,AMD Radeon graphics , touchscreen, 1T laptop I disabled secure boot and fast boot before I tried to install Zorin 16. I chose the erase disk option since I do not like or want Win 11. After I restarted the installation my laptop will not turn on when I press the power button. It's a fingerprint button which was not activated in Win 11. I'm at loss at how to deal with this. Power is going to the laptop I know this for when I plug my DVD player to it. I installed Zorin from a DVD.

Had this issue with an i9 intel laptop, it would not power on until i switched to a docking station usb-c connection.

I do have a mini usb-c dock because there is no port for an ethernet cable on the computer. The dock is minimal with only 3 usb ports on it but it worked fine before I installed Zorin.

I forgot to say my computer is a Dell Inspiron 15 5515 with 16 GB of RAM. I have to do more research about usb-c docking stations. Masterpier tell me what you know about docking stations. Some are better than others, why?

Can you try holding the power button down, while the Charger is disconnected. Hold the power button down for a good thirty seconds or so.
Another option is to do the same - but with the battery disconnected.
Once any capacitors have had time to discharge, connect the power, then press the power button and see if it powers on.
This may be a kernel issue - if the above works, we can try a different kernel.

1 Like

Hi Aravisian,
I tried the 30+ second thing and nothing. I'll have to get the proper size Philips screwdriver to be able to take the back off of laptop. What I have are too big and I don't want to strip the tiny screws which are tightly embedded. I'm wondering if I could hook up the computer to my other computer (which I'm using now) and be able to get into it from here and if so what kind of cable would I need? Or am I jus dreamin?

Do you mean to access data on the drive?

Looking around the net on this issue, I also found this:

I have not yet finished reading it to see if it has more pointers. But it does suggest there is an issue with more than just your computer... One user mentioned similar problem on Fedora, which is not Ubuntu-based.

1 Like

Thanx I'll check it out and get back to you.


Like you initially suggested it may be a kernel problem according to that thread. I'll try draining my battery as suggested and see if that works and if it does I'll change kernels. In the meantime I'll procure the proper tool to take the back off of my laptop... just in case...

The right tool for the job is essential. :wink:

Sadly, I have no idea which kernel to try. I would normally start with the 5.8 LTS, but given yours looks like a much newer model computer... I would try the 5.18, instead.
You can use the TuxInvader Repository to nab that in order to make your life much easier.

1 Like

Thanx again! I don't know how long it will take for the battery to drain but I'll keep you posted for what I try after that. I'm just grateful for having other computers to work from. But I really really like the new one and want to get it to work again. I will take your advice about the the kernels.

What's interesting is that I have Zorin 16 on an Acer Ryzen 5 installed from the same dvd I used on the Dell Ryzen 7. The Acer R5 replaced Win 10 without a hitch and I also have Manjaro dual booting with it. It must be Dell and that particular model of computer and maybe Win 11 that screw it up. I'm speculating here. Still waiting for the battery on Dell machine to drain.

I wonder if attempting a Zorin OS reinstall may be quicker... if that was a fresh install.

1 Like

How could I do that if the computer won't turn on?

Oh yeah... :neutral_face:

Might look over here while waiting...

1 Like

If worst gets to worse I'll contact Dell because this seems to be a common problem with this particular model of Inspiron. Enough people have contacted them where they had to do something. They changed a few main boards to no avail. One guy sent the computer back for a refund. However, a few people found that changing the kernel worked. So I'll try that if I can get it to turn on again. I can be patient. Like I said earlier I have this computer to work from, my Acer . Funny over all the years using Acer I have never run into anything close to this. Any problems that cropped up were easy enough to deal with once I looked it up online. Hopefully that's the case with this too.

1 Like


I'll check out that link. Thanx!!!!

Dell is known for generally good Linux support.

I have run Zorin OS on many Acers and never had any trouble. Did on Dell.
Go figure...

1 Like

You will need a standard dock, i have a few from Dell. Flying so can't remember model number. Will send when i land and can verify. Actually let me check Dell website. Dell Universal Dock - D6000S

My first desktop was a Dell. Very reliable. My first real laptop was Dell as well and good also. That was years ago. Since then I've used Acer and have a MacBook Air. Apple is worse than Microsoft as being proprietary. With both they always own and control your computer no matter how much you paid for it. I'm eventually going to put Linux on my Mac but have to know what I'm doing cause I am not confident enough yet to do it.

1 Like