Lenovo ThinkPad x61 Dual Boot Installation Option Missing

Hello eveyone,

I'm a Linux newbie here. Never really did much in the past after dual booting other distros maybe 10-15 years ago. So, I plan to really start with Linux using ZorinOS 16 as Win11 won't officially work on any of my computers manufactured from 2008-2015.

I wanted to install ZorinOS 16 dual booting with Win10(21H1), but, the option to do so is not listed. My HDD is an original 150GB with ~6GB original Vista recovery, and the 2nd partion fully utilized for Win10. There's no other partitions or unallocated one.

I disabled FastBoot under Advanced Power Settings (Lids Actions) in Win10. My laptop is too old to have UEFI or SecureBoot, and only has TPM 1.2. I tried both Core and Pro iso from official Zorin's website as I gladly paid to help the Zorin cause.

My Dell XPS 13-9343 allowed me to dual boot install easily though.

What am I missing here on my Lenovo x61?

1 Like

This guide may be of some help for the Ubiquity Installer not seeing Windows:


Thanks for your quick reply. The installer detects my Win10, but only gives me option to replace it. Only other option is advance partition adjustment.

Hopefully a simple chkdsk will fix it. I miss doing this like back in DOS days 30 years ago. LOL.


Possible causes:

  • Windows was hibernated rather then shut down.
  • Windows was not properly shut down. (Perhaps there was a power failure, or it bluescreened last time it ran?)
  • The Windows partition is damaged, and should be fixed with chkdsk in Windows.
  • The Windows partition is too full to be shrunk.
  • The Windows partition cannot be shrunk because the files in it are too badly fragmented, preventing them from being constrained to exist only within the new boundaries.
  • The Windows partition cannot be shrunk because of immovable files near the boundary.
  • The drive has been formatted as a "Windows Dynamic Disk" - Ubuntu can not be installed on a Dynamic Disk, you will need to convert the drive to a Basic Disk.
1 Like


I did the chkdsk in Windows and after reboot. There were filesystem issues and was fixed. Doing disk defrag in Windows and have been going on for hours. :rofl:

Seems after not using the laptop since 2011 and my recent uninstalling 60GB of software and deleting personal file, the drive was at 53% fragmentation after 10 passes. The drive is around 50% full now. Hopefully, the two operations will fix the installation issue.

I guess the laptop being an old 2008 model with Core 2 Duo T8100 Penryn with only 3GB DDR2 doesn't help with speed.

I'll let you know if it's resolved, asap.


Just to be sure, this is 64 bit, not 32bit architecture, right?

Need to be careful around the 686's, those are actually 32bit.

For that spec, you might be better off using XFCE desktop rather than GNOME. Zorin 16 Lite is not out yet, but there is Zorin 15.3 Lite which uses XFCE desktop.

1 Like

It is. It was before 64-bit became the new norm. At least Win10 is still in 32-bit.

But, according to the specs it's x86 with 64-bit support. Would it really matter much compared to a pure 64-bit CPU? I tried the OS16 using live boot on USB stick for an hour and seemed to work fine.

The 64-bit transition still confused me sometimes. I haven't followed computing as much as compared to when I was younger. I started back in the late 1980s to and stopped around 2003.

Understood. But, I like new things and bigger numbers. Lol. Would XFCE look much different than stock environment? I do like the look of GNOME. But, I haven't really played much with Linux in the past, so my mind might change in the future.

That's 686.
It has "support' for 64bit - this would take some in-depth explaining. But the short short version for this thread is - it is not really 64bit. You would need 32bit.

You would not see much difference in using a newer kernel for that vintage of architecture.
Also, when Zorin 16 Lite is out, there will be a upgrade path.

Oops, I messed that one.
Then OP needs other distro which still supports 32bit architecture in their latest offering - such as MXLinux.


Zorin 16 does not support 32bit arch. The only option is Zorin OS 15.3 lite 32bit.

Yup, I saw that and added some lines in the previous posting.

1 Like

I don't think ZorinOS Core/Pro 16 has 32-bit version, right? Maybe the future Lite version?

I guess the 32-bit CPU wouldn't be as efficient, or would the OS just not run?

No, Zorin is based on Ubuntu which dropped 32bit support.
So the Lite version will be 64bit only.

1 Like

Actually I had a close look at the CPU spec.
It says 64bit.
But its BIOS could be 32bit (yes, there is such chimeric system).

You could try booting from 64 bit live USB.
If it boots, then you are lucky.

If not, I can help you to convert 64 bit Ubuntu based OS to be installable on a 32bit BIOS.

1 Like

I tried the thumb drive live boot for an hour for both Core and Pro, and was stable.

Wow, you're amazing, if you're willing to help me with the conversion.

1 Like

Then congratulation :slight_smile: you do have a 64 bit system.

Since you have purchased Pro edition, you can ask for installation help directly from Zorin group. Just reply to the email you received after the payment and ask for help. Installation support is included in the price of the Zorin 16 Pro.

1 Like

Yay! :rofl: I need to celebrate.

Good idea. I forgot about the support. :grin: