Load that doggone Kernel

Folks, I've been using Zorin OS 16 for a while but yesterday my laptop decided to not fire up. Zorin is the only OS on the machine.
A straight startup brings this screen.

I thought, what the heck there is a new Zorin distro out there so I might as well download it onto my USB stick and give that a go. Cant hurt right?

The Lenovo laptop says this at startup having chosen the USB stick.

OK, to see if the USB Zorin Install stick is functioning, perhaps I try it on my Windows machine which has always worked before as the way to boot into Zorin on that machine.

Sadly my Win11 machine delivered this message. And BTW, I'm not sure I have a "Magic number" :slight_smile:

So, I look forward to hearing any suggestions which on the Laptop could be as simple as "it is fubared, so toss it" or, "get a new hard drive" or some such.

Meanwhile, I will try to create another "Zorin Install bootable" USB drive
a) to see if Win Machine will light up as it has before and
b) maybe it will then also work in the dead Lenovo.

All the best and TYVM for any words. PC

Have a look at this checklist, Before you install . Particularly do verify the SHA256 checksum of the downloaded .iso against the value published by the devs before creating a bootable USB with it.

There are two issues here. I recommend focusing on the first one.
Here is a guide:

Please remember that you are likely looking for the 5.15 kernel, not the 4.15 kernel. So be sure to follow step by step reaching the Grub Menu and Advanced Options for Zorin to ensure you are booting into the correct previously working kernel.

Folks, before I jumped into creating a new bootable USB, which I will still do and verify it works, I was intrigued with this Geeks Warrior guide forwarded by Aravisian and I'm here to say it worked.

As it was pointed out, my system is in the 5.15 dot something range. The first line I chose which was the first line that said Generic but as an earlier version did nothing and came back to the same Kernel issue. So what the heck, I went to the next and even earlier 5.15 version (so now the second oldest from the current one if that makes sense?) and chose its line ending in Repair.

That did the trick. I will now poke around following the suggestion that got me here to make any additional changes.

And because I'm crazy, I will then finally update to the latest Zorin release. In for a penny, in for a pound.

Thanks everyone and for now, lets called this FIXED (closed?) Stay well, PDC


Sorry it's a bit late, you can create a bootable USB using Rufus

Rufus is one of many tools you can use to create a bootable USB, so yes.
I myself prefer unetbootin.
Another is Balena Etcher, as suggested by the devs for that purpose, but that has a somewhat poor reputation with users here.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.