Logitech G600 causing lag spikes when using side buttons

So I finished setting up my logitech mouse software and load up minecraft and i realize every time I use one of the side buttons of Logitech G600 i see a very noticeable lag spike. I'm basically completely new to Linux and I'm not sure where to even start with this issue.
Im using Zorin OS 17.1 Pro, AMD Ryzen 9 3950x and my Graphics card is Geforce RTX 3080 Ti, any help would be greatly appreciated thank you

See if the solution with 34 votes helps:

Alternatively, try a newer kernel.

1 Like

This worked perfectly thank you!

1 Like

Glad it worked friend.

Could You please mark it as a Solution? Other Users could this help in the Future, too.

Done it via editing initial thread subject header.


I have marked Swarf's post as Solution for Tosh.


This is kinda embarssing but the issue returned/wasnt fixed in the end. I found out its actually reproducable on any softwaare i use, essentially when i use both the Keyboard and the mouse at the same time it lags my machine heavily and im not sure what causes it. Pressing keys on the keyboard and the mouse on firefox also produces the same result in the firefox address bar.

But this is specifically for keys that would also be on the keyboard, Mouse button 1 and Mouse button 2 do not cause this, only the numpad on the side of the mouse.

I believe the lag is only visual, the software still runs it just freezes the whole screen until the spamming stops

Removed "Solved"

Found: Delay when typing – Logitech Support + Download

and: https://www.reddit.com/r/LogitechG/comments/bw4810/seconds_of_input_lag_with_g600/

1 Like

I tried diffrent usb ports like the first article suggested and the issue persisted, the rest of the debugging steps were for wireless mouses which it is not. I confirmed on another computer that it was not a mouse issue. The Reddit post only suggested to reinstall logitech gaming software which does not exist for linux.

Do you have the Possibility to use a Windows PC? Maybe from a Friend or Neighbor? So, You could set up Your Mouse with the Software on that (I hope it will save the Settings on the Mouse) and then use it on Linux. I made it in the Past with Keyboard and Mouse, too. It is a bit annoying I must say. It would be easier when the Manufacturers would offer a .deb File. But it is how it is.

I have a laptop with windows and i tried installing the software and settting keybinds and such from there but it didnt fix the issue of Lag when using both the Keyboard and the mouse buttons at the same time

I made a youtube link demonstrating my issue

Thank You for the Video. It shows it good. So, the Problem is, that it lags when You click at the Side Buttons from the Mouse and at the same Time Buttons on Your Keyboard.

To ask that: You set it up on Windows with the Software. Then You wrote that it didn't fix the Issue. Do You have this Issue on Windows, too?

I would think that the Processing of both Inputs at the same Time is simply too much. So it can't handle this Input and it gives this Lag. You demonstrate it in Your Video: When You make it not at the same Time it works without Problems - even when You click it fast.

It does not occur on windows, I have used this mouse before no problem on windows for over a year now, it seems to be specific to Zorin so far, I have not tested on any other OS then Windows and Zorin.

Okay. Maybe it works on Windows because there is the Software that makes it workable. On Linux You don't have the Software, so it could be that this kind of Input cannot work properly. That would be my Theory.

You could test it with other Linux Systems in Live Mode if You have the Problem there, too. Because then You could specify if this is a more common Linux Problem or a Distro Problem.

I have used the mouse before on windows without the software, IE Logitech Gaming Software Or LGHUB (Logitech Gaming Hub). and it worked fine if that tells anything. I dont see why a mouse with Buttons on the side would just be unusable on linux.

Found a third party solution:

via this old askubuntu thread:

Unfortunately did not work, tried installing and enabling then restart the computer just to be sure but did not work .