Mac Mini 2010 NVIDIA GeForce 320M

        `osssssssssssssssssssso`           russ@Macmini-2010 
       .osssssssssssssssssssssso.          ----------------- 
      .+oooooooooooooooooooooooo+.         OS: Zorin OS 16.2 x86_64 
                                           Host: Macmini4,1 1.0 
                                           Kernel: 5.15.0-53-generic 
  `::::::::::::::::::::::.         .:`     Uptime: 17 hours, 29 mins 
 `+ssssssssssssssssss+:.`     `.:+ssso`    Packages: 2063 (dpkg), 68 (flatpak) 
.ossssssssssssssso/.       `-+ossssssso.   Shell: bash 5.0.17 
ssssssssssssso/-`      `-/osssssssssssss   Resolution: 1920x1080 
.ossssssso/-`      .-/ossssssssssssssso.   DE: GNOME 
 `+sss+:.      `.:+ssssssssssssssssss+`    WM: Mutter 
  `:.         .::::::::::::::::::::::`     WM Theme: ZorinBlue-Dark 
                                           Theme: ZorinBlue-Dark [GTK2/3] 
                                           Icons: ZorinBlue-Dark [GTK2/3] 
      .+oooooooooooooooooooooooo+.         Terminal: gnome-terminal 
       -osssssssssssssssssssssso-          CPU: Intel Core 2 Duo P8600 (2) @ 2. 
        `osssssssssssssssssssso`           GPU: NVIDIA GeForce 320M 
                                           Memory: 5329MiB / 7692MiB 

I enabled the proprietary driver via the Additional Drivers tab of Software & Updates.

Now, whenever I install software with "sudo apt install", I get the following (along with whatever I'm installing):

Setting up nvidia-340 (340.108-0ubuntu5.20.04.2) ...
dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-340
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Removing old nvidia-340-340.108 DKMS files...

Deleting module version: 340.108
completely from the DKMS tree.
Loading new nvidia-340-340.108 DKMS files...
Building for 5.15.0-53-generic
Building for architecture x86_64
Building initial module for 5.15.0-53-generic
Error! Bad return status for module build on kernel: 5.15.0-53-generic (x86_64)
Consult /var/lib/dkms/nvidia-340/340.108/build/make.log for more information.
dpkg: error processing package nvidia-340 (--configure):
 installed nvidia-340 package post-installation script subprocess returned error
 exit status 10

Is there a way to get the proprietary Nvidia drivers to work with this machine where it won't be trying to unsuccessfully build a kernel module each time I install software?

Thanks in advance for any helpful answers.

You need to install a lower kernel (5.4.0.x) to get that nvidia card to work.

1 Like

Good to know.

I had to reboot and was stuck at the "white screen of death", had to switch to tty and login and purge nvidia-* in order to be able to get back to the desktop.

I then tried (cause I hadn't seen your reply yet) to install the proprietary driver via the Additional Drivers tab again.

This time, I noted the error that it gives:

Error while applying changes

pk-client-error-quark: Error while installing package: installed nvidia-340
package post-installation script subprocess returned error exit status 10 (313)

So, I reverted back to the open source driver.

So, now my questions are:

  • Is it possible to downgrade to a compatible kernel? If so, how is this done?
  • Even if that works, is it worth it? As in, how much better will the proprietary driver perform over the Nouveaux driver?

Thanks again for helpful replies.

Yes, you can install the 5.4 kernel:

sudo apt install linux-headers-5.4.0-81-generic linux-modules-5.4.0-81-generic linux-modules-extra-5.4.0-81-generic linux-image-5.4.0-81-generic

You can use this method to lock the kernel in:

It's hard to say. But testing out both is reasonable and safe.
You can install the 5.4 kernel and test out how things work.
Then test Nvidia vs. Nouveau and decide which works better for you.
If you see no appreciable change, just stick with the current kernel.
If you do see one, lock in the older kernel.

Thanks. I can't figure out how to get a grub menu in order to be able to select the newly installed older kernel.

I edited /etc/default/grub and made the following changes:


And, of course, I ran "sudo update-grub"

But, I see no grub menu when booting this Mac Mini.

I also tried modifying /etc/default/grub with:

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

And, again updated grub but, still no grub menu is displayed.

I've tried hitting esc and tab while booting but those just seem to make this little Mac sit there with a black screen and a single cursor in the upper left hand quarter of the screen (not the upper left hand corner, more like 3" - 4" down and to the right of the top corner).

Thanks again for all the info and does anyone know how to get the grub menu to display on a Mac Mini?

Ok, I got the grub menu to appear and I was able to boot from the 5.4.0-81-generic kernel.

(To get grub to show, I had to uncomment the GRUB_TERMINAL=console line in /etc/default/grub)

Sadly, when I try to switch to the proprietary Nvidia driver in Additional Drivers, I'm getting the exact same error I quoted above. :frowning:

Any other ideas?

Thanks again.

If you're not a gamer, there's no advantage to switch to restricted driver. If everything work as it should you should be happy :wink:

1 Like

I may have picked a too new 5.4 kernel lol...
I opted for the latest 5.4.0-81 rather than base 5.4
But I doubt it would make any difference. If it was me, I would have started the attempt on 5.8 and worked back to 5.4
If you are restricted to the 340 driver - it may be a card Nvidia has dropped support for and ... as Storm just said above...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.