Macbook 2008 Black Keyboard only numbers

Hi All, when trying to install Zorin Lite on my Macbook 2008, only a few keys work, and they only give me numbers. I do see an old thread here but no resolution.

Anyone know why this is happening? i don’t have this issue with Lubuntu and i much prefer having zorin on it.

Thank you!

What are your current Language settings?
Goto XFCE->Settings Manager-> Language Support.

Hey there! It does say English currently.

Thank you

Ok, what happens with your keyboard if you paste this into a terminal and enter it:

setxkbmap en

1 Like

Error loading new keyboard description

Btw I’m still in the liveusb

Ah, I see:

If you choose to install Zorin, you would have full control over that. But in the Demo, you can get bitten by a bug.
This occurs either when a person is using multiple languages… Or Mac.
Installation on Mac requires a couple more steps than on most other PC’s.

I’m gonna try installing it and see where this goes! Il be back shortly

Yeah, what have you got to lose.

That is what I would do. Once installed and you have gone through all your language setup during the installation, it should be fine. But if not- come whack us upside the head.

1 Like

So sadly the issue is still persisting even after running all the updates and such

What happens if you double tap fn+F6?

@Snazzle Are you still running Zorin off Live USB?
If you want to do this and save settings then create a Live USB with persistence e.g. use Unetbootin to create boot USB with some persistence memory. Live USB will run slow compared with a proper install.

i will have to do further testing as i dont have that machine at reach all the time. but il try that!

hi, sorry to hijack the thread but i seem to be having the exact same problem and with the same model of macbook. Im currently on the live usb as well but i added some persistence memory as sugested using Unetbootin. No luck there.

The keyboard reacts but only a few keys and they are mismatched, like, some letters become numbers and some simbols become other simbols and most keys do nothing. At first i even tough it was the ribbon cable that was damaged or misaligned so checked that. nope, cable is fine.

I do note that the capslock key is always lit and not changing…

This post referred to PC (not Mac), so don’t know if it would be helpful to you or not: Laptop keyboard map change - #57 by Bicyu

1 Like

gonna test it out, it kinda makes sense if numlock would be locked on

Hi All!

I have some good news, i have discovered that the numlock was forcefully on.

i opened terminal and typed:

numlockx off

that seemed to have done the trick, i then added it on the startup tab and it seems to work, but:

This does not seem to action on the login screen, only after. Any clues on how to action it on the login screen?