Macbook pro change to nomodeset

Appears that my GPU finally byte the dust. I boot from usb Kubuntu with safe graphic and runs ok, but I can not boot installed Zorin 16 Pro. Will not load the screen. I need to change the kernel parameters and add nomodeset. How do I doit on installed system. I know that I can do it from usb, but do not know what I have to edit

reboot and when GRUB appears, choose Zorin if Kubuntu is first distro by down arrow then press TAB to enter into editing GRUB. Go to the line that begins: 'vmlinuz' and add a space at the end and enter nomodeset, then exit and reboot.

1 Like

Can not get to Grub from installed system. I can boot from usb and then get edit the config file, but forgot where and the command. I did that before, but my memory is getting weak(old age)

janusz, if I'm right, I think you mean the grub file from /etc folder

If you can reach by usb then you can add the nomodeset to the line;

1 Like

I edited the grub.cfg at line 238 but that did not work well. At least I saw Zorin and then

In /etc/grub.d what file do I need to edit. Guite a few of them

No not the grub.d folder or the grub.cfg file. Btw if you changed the grub.cfg file, do change it back. The line should not be there.

But it is;
the grub file in the folder /etc - there you wil find the file and try to find the line GRUB_CMDLINE_LINUX_DEFAULT=

You can add " nomodeset" to the line. If that is the solution for your problem.

There is not grub file in /etc only 2 group

Excuse me janusz, my bad, I meant

/etc/default/ folder.

Its been a while for me too, using that file.

grub.cfg is actually in /boot/grub/ as in screenshot.

/home/swarfendor437/Pictures/edit grub.cfg.jpg

Edit line 201 at end - it is in read only mode so you would need to open a terminal and enter:

cd ..
cd ..
cd boot
cd grub
sudo chown [your username] grub.cfg 

then whilst still in terminal:

sudo nano grub.cfg

and edit the line around 201 that starts vmlinuz - it might wrap round to next physical line - add 'nomodeset' at the end then Crtl+ O to write changes - save as grub.cfg and tell it to overwrite existing file, then Ctrl+ X to exit out of nano.

That did not work. Will try edit the grubcfg in boot/grub folder

I am booting from usb (Kubuntu) then I can access the file. Added at the end on 201 and reboot. Screen mess up. Kubuntu boot in safe graphic and display work. Should be somewhere in Zorin to edit for boot in safe graphic.

Do I put before "quie splash" or after. I put after and display mess up

"nomodeset quiet splash"

That did not work - black screen

Hi janusz,

Could we have some specs of the machine please? Especially the Graphics Card/chipset. Make and model of machine would also help whether Desktop or Notebook (I refuse to use the misnomer of 'laptop' as it engenders improper use of such devices.)

2011 Macbook Pro with intel and Radeon graphic. I believe that Radeon byte the dust. Kubuntu boot from usb in safe graphic mode. Should be able to edit Zorin for safe graphic mode or do I have to reinstall. I hate to do it, but if that is the only way.

How did you install Zorin? Balena Etcher?

I did create an install guide for Mac courtesy of a Magazine article here:

Also see here:

Yes. Rufus would not make it

I isntalled about 3 weeks ago and was working fine. I did some customizatio, added vmware with win10 in it. All was working great untill today.

I have Zurin Pro and Zorin lite, none of them give to me kernel option at boot. All other dis6tros do give to me that option