Manually installed wi-fi driver gone after restarting

Hello everyone,

I just purchased Zorin OS Pro and was eager to set everything up. So I have a TP-Link USB device - TL-WN823N to be exact.

The standard wifi driver that comes with apparently every Linux distribution I tried gave me horrendous speeds which is why I sought out a different driver that worked perfectly for me on both Solus and Ubuntu Budgie, which I was using previously.

For both of these distros I just installed the driver rtl8192eu which worked much better, albeit not perfectly. The driver also kept working after restarting. Not so for Zorin OS. I immediately replaced the original driver as I did on Solus and Ubuntu, via this command sh ./ (in accordance with the readme provided) and the driver was working normally until I restarted because of updates and changing the Nvidia driver. Now I have no more wifi drivers apparently and my computer doesn't even seem to recognize the device. I also cannot reinstall the driver anymore. I am not a complete Linux beginner but this error is beyond my knowledge.

Here's the output from terminal when trying to do a new installation (had to take a photo from my iPhone, I couldn't get the screenshot of the PC).

When I run "lshw -C network", it just shows me the Ethernet controller.

Could anybody help me fix this issue? I cannot use an ethernet cable since the computer is in the opposite corner of the room from the router.
I would also like to add "dkms status" tells me "rtl8192eu, 1.0: added" while modprobing the driver says it's not found in directory /lib/modules/5.13.0-23-generic.

Thanks in advance!

The trouble stems from Zorin OS using a different kernel than the DKMS module support for that driver recognizes.

If you can use your Phones Wifi Hotspot to connect Zorin To, to access the web, this can easily be fixed by installing a kernel that includes modules that the driver needs.
The easiest way to start this is... Do you recall the kernel you were running on Solus?
OR at least when you were running Solus should get us to the ballpark.

I have tried connecting my iPhone for the last 5 minutes and Zorin just won't accept any connection from it despite it being connected via USB and my Personal Hotspot being turned on. I don't see a USB tethering option like on Android.

As for Solus, that was a while ago - about a month. But Ubuntu Budgie I was using just two days ago with that exact driver.

EDIT: I should mention the phone is recognized for data transfer TO Zorin. I can't transfer files to the phone, though. Not sure if that says anything about why I can't use my iPhone's internet connection.

EDIT 2: When I go into the lib/modules/ folder I can see a folder with the exact numbers that dkms throws out in the error.

Was it the latest Ubuntu Budgie? 21.04? Or an earlier release - that you happen to be using recently?

Your connection...
Transferring it From Phone To Computer is possible, but a bit space-heavy.

I am not completely sure, but I usually aimed for the LTS releases, so it was likely 20.04.

In that case, I will take a guess at 5.8 kernel.
Please grab these packages and transfer them to the computer:

Move them to a folder in your Home Folder named kernel
Cd into it:

cd ~/kernel

Run the installation of all:

sudo dpkg -i *.deb

Reboot, then test installing your wifi driver with DKMS

Unfortunately it failed since it was not the kernel it expected. It seems to expect Kernel

I just tried installing a different driver for another device of mine. That one seems to have several issues but also throws the same DKMS error.

I now tried to attach my girlfriend's Android to get an internet connection and it didn't work. It's as if it's all completely broken and now I'm just wondering how I will be able to properly use either of the two wifi devices on Zorin. Right now, I will reinstall then update everything first and only THEN will I try to reinstall the driver. Hope that will work.

1 Like

Did you reboot and boot into the 5.8 kernel, first? :neutral_face:

I did restart the computer into Zorin before I tried installing the driver. Should I do something else still?

You need to be sure to boot into the 5.8 kernel, not the 5.13 kernel - otherwise, you will just have the same problem.
Tap esc or tab from your motherboard splash screen to pull up Advanced Options for Zorin and arrow key to Zorin on the 5.8.0-67 kernel. Hit enter to select and boot from that entry.

I can see that all the other Kernel folders in /lib/modules/ have a build subfolder. The 5.13.0-35-generic folder does not. The installer refers to this build folder saying

"Your kernel headers for kernel 5.13.0-35-generic cannot be found at /lib/modules/5.13.0-35-generic/build or /lib/modules/5.13.0-35-generic/source".

Maybe that's the problem? I tried finding the same Ubuntu archive links for that Linux kernel number but was unable to.

I just tried restarting and hitting Tab on the splash screen but it didn't do anything. When I hit ESC I just reached saw a verbose boot black screen I believe. In either case, it just brings me directly back to the login screen.

Yes, you can source the directory - that is a bit more complex. The method we are using is a bit simpler, is all.

Can you please open terminal...

sudo nano /etc/default/grub

Ensure that grub timout is set to 10 not to 0 or a lower number...
ctrl+x to exit, then y key to say yes to save, then the enter key to save and exit. The terminal will revert to normal.
No run

sudo update-grub

You should notice the 5.8 kernel noticed and listed.
Reboot and try the esc key again, tapping it like you are trying to win at Mortal Kombat.

I managed to reach it. My motherboards shows the splash screen twice. Once shortly in the beginning, then once it starts loading Zorin OS. I had to hit ESC on the first, not the second screen.

Managed to log back in, now the errors have completely changed. I think this will be more of an issue with the installer script now.

Apart from this, I just ran dkms status. And it shows me both drivers I attempted to install as "added".

rtl8192eu, 1.0: added
rtl8814au, added

The Nvidia driver is also listed there, but as "installed".

sudo modprobe 8192eu does not activate the driver.

mv: cannot stat ./blacklist-rtl8xxxu.conf: No such file or directory

Can you try the following:

sudo depmod -a

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

It outputs "cp: cannot stat './rtl8192cu-fixes/blacklist-native-rtl8192.conf': No such file or directory.

I expected that as likely - Ok, let's change to using a different make of the same driver that has it:

You'll need to do some Transferring with the phone again. You can try it staying on the 5.8 kernel for now.

Tried it, but I'm getting an error on the "make" command. "Makefile: No such file or directory."
"***No rule to make target 'Makefile'. Stop."

make: *** Makefile:1828: modules Error 2

I did move to the main directory of the driver, of course.

Did the headers get installed when you did the kernel install earlier?

I haven't seen any evidence to the contrary. From what I can see the header errors completely disappeared.