Maximum Volume is low in comparison to Windows 10?, VivoBook_ASUSLaptop X515EP

Hi All,

I've noticed that the maximum volume output when I'm using my Sony WH1000XM4's is considerably lower than what it was on Windows 10. (My previous OS before making the switch to Zorin Pro OS.) The built-in speakers of my laptop seem to not have been affected, having full access to it's true maximum volume capacity. The Bluetooth headset however, despite having the volume slider on maximum across the system settings and the Spotify app, I'd estimate it is half of what Windows 10 enabled the headset to do.

I've tried using volume amplification to go above 100%, however this was not a viable solution as it worsened the audio quality, without much improvement to the true maximum volume capability of the headset. Again, back on Windows 10, the headset could go well above in volume than the amplified volume of Zorin OS without any detriment to the audio quality.

Looking for solutions or other troubleshooting steps to diagnose and resolve this issue.

Thank you.

GDay @Saxon410
Welcome to the community.

Open pulse audio controller>output>increase boost DB.
this will/may overdrive/distort the audio but will increase the volume.
As you have tried.
Is this a separate audio card or onboard audio?
Hope this helps.


Alternatively try the same process with alsamixer. try this link for futher instructions

Just in case.
To open alsamixer first open the terminal
then type in " alsamixer ".
next press F6 & select your card.. Then F5 to show all...
Adjust PCM to suit.
You will need to use the arrow keys to make changes.


Currently this is what I'm working with,


This is the output for my Pulse audio Controller, increasing the DB did make some improvement, however the distortion does become prevalent after around 130%. is there anything else I can try?

You might try adding the grub parameter snd_hda_intel.dmic_detect=0

Grab the SOF binary file:

git clone

cd sof-bin

sudo mv /lib/firmware/intel/sof* /lib/firmware/intel/sof-backup

sudo mv /usr/local/bin/sof-* /usr/local/bin/sof-backup

sudo ./ v2.2.x/v2.2

Reboot and In your BIOS Settings, ensure that Fast BIOS or Fast Boot is disabled, if you have the option in your BIOS Settings.
Boot into Zorin OS and test.

Trying this-

Here's where I'm up to:

Upon trying this command:

sudo mv /lib/firmware/intel/sof* /lib/firmware/intel/sof-backup

I received this error:

mv: target '/lib/firmware/intel/sof-backup' is not a directory

I attempted to resolve this by using the following:

sudo mkdir -p /lib/firmware/intel/sof-backup
sudo mkdir -p /usr/local/bin/sof-backup

Afterwards, I tried this once more.

sudo mv /lib/firmware/intel/sof* /lib/firmware/intel/sof-backup

A new error was produced:

mv: cannot move '/lib/firmware/intel/sof-backup' to a subdirectory of itself, '/lib/firmware/intel/sof-backup/sof-backup'

What troubleshooting can I do?

The trouble here is the wildcard symbol of *
Since the command is looking to move all instances of sof using *, it includes sof-backup.
Sorry about that. I get in too much of a hurry sometimes.
Change the directory names you made:

to something like




Making the backups is just in case the procedure fails and we need to restore your original files.

Could you please tell us the brand & model of your pc?
also could you show us the results for this command.

sudo lshw -C sound

1 Like

-Facepalm- I must be confusing threads! I had it my mind the O.P. of this thread had done this already. Thanks for asking this Ocka.

Brand and Model of PC:

System Information
Product Name: VivoBook_ASUSLaptop X515EP_X515EP
Version: 1.0
Serial Number: M9N0CV02417935D
UUID: 05dc0a11-0573-8e47-b1a6-e2c0bb068f56
Wake-up Type: Power Switch
SKU Number:
Family: ASUSLaptop

Output for This command:

sudo lshw -C sound

drivers for audio look ok..
i assume the usb audio device is your Sony music player...
have you tried loading a music file directly into your home directory (Music) & see if it's louder via the home directory?
As i dont know the Sony player it may need another driver.
try the above & see if you get a difference in volume.

Also while i'm here.please open BIOS & run an update on the firmware..
Bios>Advanced>EZ updater.. or EZ utility's

This might increase the difficulty of the solution, The audio device I'm looking to improve the audio volume for is a Sony WH1000-XM4 headset. The connection would be via Bluetooth so I think it'd be unlikely that it would appear in the list, or it might be related to the *-multimedia entry.

Upon playing an .mp3 file of some music and opening it via VLC media player, I can confirm that the issue persists. bear in mind that I tried this after having entered BIOS and disabling Fast boot because I had installed Sound Open Firmware using command:

    sudo ./ v2.2.x/v2.2

as per Aravisian's recommendation.

Ok, Sorry seeing the docking station with audio made me also think you were using an external music device.
I assume the Sony headset is connected into the dock?
Can you see if connecting to the pc's usb port makes a difference?
Also do you have another headset with 3.5 plugs to test with? if so please rely the results.


To be honest, I'm not exactly sure what it was that I did, but after having implemented the recommendation of Aravisian, turning off Fast Boot and implementing that Sound open Firmware application, and after much fiddling around with Pulse audio control, and experiencing no difference- here's the takeaway:

After I went away and connected my Headset to my Iphone running the latest version of ios and having run an application called "Sony Headphones Connect" and successfully connecting my headset to this application, playing some music via Spotify on my iphone afterwards, then reconnecting to my PC, the issue was miraculously gone.

All I can put it down to is that there may have been some kind of driver or software update for the headset that occurred in the background when I connected it to the ios app, solving the issue.

Thank you guys for your persist support, I cannot thank you enough for your patience, your dedication to Zorin OS users has solidified my trust in this Linux distribution. Thank you.


That is a common outcome of sound issues. They require a multiplicity of fiddling and tinkering so when it suddenly comes good, you have no idea what part or parts of the remedial actions waere responsible. It is an art not a science.

PS: Note your alsamixer image in post #4 is incomplete. Can you see that stacked column of arrows on the right edge? that indicates more channels overspilled the window on the right. If you present an alsamixer screenshot again for any reason, please extend the window to show all your channels.

1 Like

I agree that Pulseaudio is not scientific; but I would not call it art, either. :smiley:

1 Like

True, just need a :man_mage:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.