Microphone Acces Error with Matrix Clients

Unfortunately I cannot further edit my original post regarding this topic because it reached its 90-days-limit and has been automatically closed.

But as I today (actually) solved the problem I like to link it hereby so others experiencing similar problems might save some time :slight_smile:

The solution is documented at MacOS: Unable to access microphone when try to call 路 Issue #1130 路 vector-im/element-desktop 路 GitHub since I experienced the problem finally also with MacOS.

tl;dr Turns out that it wasn't a client side problem at all! The absolutely misleading error message about a non-accessible microphone was due to a misconfiguration of the turnserver settings of my matrix homeserver. Or precisely: Obviously they implemented a stricter interpretation of those values from version 1.11.13 on and the newer clients stopped working. The web clients didn't because I use Firefox and the desktop clients are chromium based and those browsers behave differently regarding turnservers.

1 Like

Well, thank you so much for taking the time and report back about this issue! Are you able to flag this post as solved as well? Just for housekeeping, although I'm not sure if the very first post can be marked as such.

1 Like

It can't :slight_smile: But the I just take this or your answer :person_shrugging:

1 Like

Added a redirect to this thread in the Original Post of your Original thread.

2 Likes