Microphone not detected by pipewire

Hello. My microphone is recognized but not hearing my voice when i using a discord.

Have you tested mic in Settings and/or other software?
Does mic not work only on discord?
If only not working on discord, how did you install discord?

My microphone is usb port.


There were 2 more questions for you.

Well propably working before but now stop working.
Discord you can installing also if you don't have a microphone.
Microphone working on windows.

I see from your other thread (What I can remove from Zorin? - #11 by Bourne) you have been removing software. If your mic worked with discord before you removed stuff then that would be where I would be looking.

So you want told me this is not problem hardware?

This isn't a problem because i using a pipewire and pipewire don't recognize a microphone?
I connect another microphone and i check if this working.

Discord should get the permission from the browser first as a pop up appears and also in the settings, the allow microphone usage should be enabled. The system setting should not block microphone usage by applications.

That is correct. If I connect any hardware discord recognize a hardware and asking if i want change a source input or output.
Propably because i using a pipewire and there i don't found settings microphone.
This is propably because linux don't know which source to use.
I tried in sound settings pavucontrol any source and not hearing microphone.
The linux seeing them. When i talking to microphone i seeing a volume line when i talking but not hearing. Tested on a couple microphones.
@zabadabadoo is wrong about remove something from linux we can installing things and delete them. The microphone doesn't have a connection with subject about what he linked what i removed but there was solution i fixed that.
So the microphone is recognized.
bourne@bourne-MS-7916:~$ sudo arecord -l
[sudo] password for bourne:
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC1150 Alt Analog [ALC1150 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 3: Debug [MV-AP82x Audio Effect Debug], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

I notice a lot of pulse audio issues there. Have you tried installing ALSA packages to see if microphone works better with that?

You mean that bug?

I notice in your picture that right mark in the corner not active, click on it to active it

1 Like

discord does not detect anything coming into your microphone, please check that the correct device is selected.
This is info from my discord on settings in discord.
bourne@bourne-MS-7916:~$ systemctl --user status pipewire-session-manager
● pipewire-session-manager.service
Loaded: masked (Reason: Unit pipewire-session-manager.service is masked.)
Active: inactive (dead)

1 Like

I think I tried pipewire a few months back. Total waste of space. ALSA 'til I die!

1 Like

My experience has been that while in an app that captures and sends audio, you will not hear yourself as you sound in the mic. That only occurs if you enter settings and speak into the mic. Ask any participants of the discord if you are heard. As you say that the mic indicator changes when you speak, then you are transmitting.

Why do you need to hear yourself speak through the speakers... like your voice?

1 Like

On discord when i talking then indicator is white and also in discord you have settings if microphone working then you hearing that. The output line coming to the dac and isn't connected with microphone. Microphone is connected with usb port. Checked also next with jack connection also not working. Well for gaming people discord is most popular. I don't know what it could be a problem. I gived up if i cannot use microphone then only using things for hearing. Something like a zorin working with a half brain. Maybe in settings is to many options to confuse which one is correct but i tried many options also searching on webside install and uninstall pipewire installing pulse audio. Propably microphone is masked or something or not i tried mostly all.

1 Like
pulseaudio --check
pulseaudio -D
1 Like

I had no problems setting these up. Has both bluetooth connector and phone jack cable.

1 Like

I don't know maybe only restart helped. I also used recovery to repair broken packages or check packages and then everything working.
bourne@bourne-MS-7916:~$ pactl info | grep "Server Name"
Server Name: PulseAudio (on PipeWire 0.3.56)
After restart my volume is grey server is not connected with audiopulse information.
Weird that linux on discord nothing in settings sound.

Spotify working.
Very weird then PulseAudio not working on Pipewire.
I will now uninstall pipewire and check if discord working.
After uninstalling pipewire discord working properly.
When restart nothing working - no volume control and no recognize audio peripherals.
Will working on it. So the pipewire could working. OMG linux is cool spend all day on terminal interesting.
I used that guide

[SOLVED]Can't unmask pulseaudio service with systemctl / Newbie Corner / Arch Linux Forums this helped
and this two commands

systemctl --user enable pulseaudio
systemctl --user start pulseaudio
and now microphone don't working.
So i am very confuse where is the problem trying everything.
1 Like