Microsoft Edge and other browsers

So I tried MSE and did not even run. popup from Zorin Connect let me know that it was running in the background but never worked. Shame, heard good things about it on the reviews out there. Wanted to give it a try.. Why? Well, we all know the issues with FF, especially but not as bad as others Hardware Acceleration. So, gave brave a try.. Love it.. and using Elvenar online was nice too.. however, it screws up most sites if HA is enabled. But elvenar works well when it is, too bad all the other websites out there white screen or jitter or fail to load image and content.

Does anything work?

I have never actually had a browser not work. Well... except Vivaldi of course...

You are also not the first person to note that a Chrome-based browser is not working properly recently.

Brave and MS Edge are both Chrome-based. I wonder if you tried Ungoogled Chromium what would happen...

Nope that does not work either and requires me to now reboot cause many messages about it running in the background are popping up even after I uninstalled it.. thanks for the suggestion though.. :slight_smile: much appreciated..

You might ensure that there are Zero left over config files from the previous installed Chrome based browser. That includes checking ~/.local/share and ~/.config

When you installed Zorin OS, did you check the box for "install 3rd party drivers?"

I unfortunately do not remember that option being offered.. sorry.. Is there a way to implement it now or will that just cause more problems?

Yes, you can and it should be fine.
Please open Software & Updates
The first tab Zorin Software, ensure that all four of the top boxes are checked. You can leave the last sources box unchecked.
Under Download from, ensure that you are set to "Main server".

Move to the Other software tab and check the box for Canonical Partners

Close Software & Updates and open a terminal and run

sudo apt update && sudo apt full-upgrade

I still recommend removing any config files from previous Chrome-based browsers before rebooting and testing a browser.

Sorry for butting in but sometimes I like to follow along with suggestions and advice and this thread is no exception .....

Although I don't have the OP's problem I did discover that the info you provided shows that Canonical Partners in my Software & Updates is not checked ..... should I check it and the one that follows also before proceeding to sudo apt update && sudo apt full-upgrade ....

Thanks ..... I now return you to our normally scheduled program ..... :grinning:

You can if you want to. If you are not seeing any driver issues or other problems, it may not affect your hardware.

1 Like

Only problem I am still having is with these stupid mice .... even the wired simple 2 button mouse is messing up .... today I must have reset it with ALT & F2 then r 20 times ..... some days maybe 1 or 2 ..... do you think maybe it would be worth a try ....

I know someone mentioned a mouse that is made for Linux but it also cost $74.00 and that is a little steep for me to just try .... darn strange that I was able to use my cordless gaming mouse for more than 6 months before it quite working ....

Any way let me know it could be worth a try .....

Oh, in that case, go for it.

1 Like

Well that didn't work either .... so I guess I'm stuck with a half functioning mouse .... oh well could be worse I guess ..... seeing as it effects my touch-pad also it must be a hardware driver thing and I guess Zorin will not except the newest drivers for my Asus laptop .... I updated all my drivers for Asus on Win 10 but I guess even with dual boot Zorin must be using it's own drivers ..... it seems to be worse when using the internet and the copy and past or downloading pictures from the right mouse menu .... in fact much worse ....

Maybe start a thread on this with your full machine specs. Maybe we can stumble into a solution.

1 Like