Missing virtio driver for attaching a file system in qemu for a vm

I have a fresh new installed ZorinOS 16.3 (because ZorinOS 17 can't handle my new NVMe SSD ..) on a new computer.

On my old pc I had the same ZorinOS 16.3 Version and it worked. The most important feature is transfering files between host and VM. It can not be configured, because it seems that I need this virtio driver.

I searched the whole web for a problem like this and couldn't find a solution. Even ChatGPT is drving me crazy, after an hour of try and error I have no solution.

The OS of the VM ist Debian 12.4 (shouldn't matter in my understanding)
Even the configuration settings for the filesystem-attachment of an older VM, used on my old pc (when everything worked well) doesn't seem to exist anymore in the virt-manager overview for the old VM.

The only options I have if I want to attach an filesystem to an VM are: Driver: "Handle", "Path", "Default"

I can not find any understandable information how to install this virtio drivers.

you are my last hope, it is really really frustrating.

I try to write down everything I did related (at the host machine!) to this qemu/VM topic:

after ZorinOS installation:

  • sudo apt install virt-manager qemu-kvm

todays try and error installations: (while reading tutorials and trying chatgpt advices)

  • lsmod | grep virtio --> no result
  • (sudo) modprobe --> no result
  • sudo apt install libvirt-daemon-driver-qemu libvirt-daemon-system libvirt-dev --> still no virtio driver
  • sudo apt install qemu-guest-agent --> this is more for the VM, but I also didn't helped
  • sudo apt install qemu-system-common qemu-kvm libvirt-daemon-system libvirt-clients bridge-utils --> still no virtio driver

I also installed the qemu-guest packages on the VM, but 1.) it also didn't helped and 2.) I don't know how this should even matter, if my host + qemu even don't want to display the damn virtio driver :frowning:

Do you mean that even the all-knowing ChatGPT doesn't know? I'm shocked :hushed:

According to the documentation, virtiofs is included from kernel 5.4+. You may try to update and try again:

I am kind of afraid changing anything with the Kernel :fearful:
Thats the reason why I choose 16.3 instead of 17 for my new computer. I thought about touching the kernel for better hardware support, but what I like most about zorin OS is, that everything works all together very well.

could you tell me more about your experience with upgrading the kernel of zorin OS? will it also be updated in the future or will I don't receive automatically updates as until now?

and while I'm at this point, I could try ZorinOS 17 and change there the kernel, so I could use it with my current hardware. I thought about installing it on my external ssd and boot from there, but the last time I did it, the grub was destroyed and I couldn't start from my internal NVMe my OS anymore.

I actually feel the same way as you do in regards to stability and never have tried to update the kernel myself. But there are others in this forum that have done so with great results. With ZorinOS 17 you would have kernel 6.2 which is enough to run virtiofs without any changes.

However, you can still share files through other means such as NFS. It's less optimal but will work nonetheless.

Zorin OS 16 is well beyond the 5.4 kernel as well.

As I Understand it, a user needs only install the VirtIO drivers if they are running the Qemu on WIndows.
Part of your troubles may stem from this X - Y problem.

Instead, can you relay what errors you are seeing or what symptoms you need to troubleshoot?

at this moment I have 5.15.0-91-generic kernel :slight_smile:

I don't know why this kernel/Zorin Version works better with my hardware (nvme ssd), otherwise I had chosen of corse zorin 17 :slight_smile:

maybe you are right, but it's indeed mysterious, that I can not select the VirtIO driver in qemu :frowning:

Instead, can you relay what errors you are seeing or what symptoms you need to troubleshoot?


in this menu there was always a virtio driver which is needed to use this mounting-filesystem feature.

If you are open to it, I am going to PM you a link invite to a discord server with the QEMU devs. Maybe they can provide more help and clarity on this issue.

wow, that is very nice, thank you! :slight_smile: Unfortunately I'm avoiding discord because of privacy reasons :frowning:

1 Like

No problem, here is their Github:

1 Like

If this is your goal, you can just connect to the host using SSH. No driver needed. When connected, you get a window open to the host file system.

You need to have openssh_server installed on the host. Files can do the connection setup working from the VM:

Other Locations > Connect to Server

Comments: On first connection, you are asked if you want to have Files remember the connection. I choose to have it remember the connection "forever". Then I browse the host file system and set bookmarks. Next boot up of the VM, I can click on a bookmarked host location and it's opened in a new window. Very easy access.


thanks reminding me about this possibility. somehow I tried to avoid to transfer via ssh, but you're right, for now this will be the best way. there are also many tutorials on the internet, so I'll do it that way. some day ZorinOS 17 will support the newest lexar nvme hardware, then I'll switch to 17 and hopefully it will work then with virtio. Anyway, thank you for the reminder! :slight_smile:

I thought it was suspiciously low... but I did check before posting and my install of ZorinOS 16.3 Core after running all updates remains at 5.15.0-91-generic as well.


1 Like

I just installed ZorinOS 16.3 Core on hardware and can confirm that virtiofs driver is not supported. However, this seems to be an issue due to the libvirt and qemu versions, which need to be at 6.2 and 5.0, respectively, but are only at 6.0.0 and 4.2.1 upon installation.

Some sources mention that it's the guest operating system that needs a kernel of 5.4 or higher, but I'm able to mount a file system no problem from Debian 12 (6.1.0-17-amd64) to ZorinOS 16 (5.15.0-92) so it's clear that it's on the host.

1 Like

So, this is embarrassing...

I was just going through some notes of mine about sharing directories with virtual machines, and remembered this thread. Going over it right now. I really don't understand how the ... did I confuse 5.4 with 5.40.

How come not one of you guys corrected me on this? :joy:

It makes us look more competent to let you look incompetent.

1 Like