Modern Nvidia Drivers

Thanks for the suggestion. How would I get into Bios settings on an iMac?

You do so, by doing the following...

From a full shutdown.......................


Press the power button to turn on computer


Hold down COMMAND and S same time until you see the black screen. You should now be in the BIOS.

Yes, after 20-years since I last used a MAC computer, I still remember a few of the commands, I know amazing right? LOL!

1 Like

I have tried that but cannot get into the Bios. I just get the black screen with one small dash in the middle as though I was going to start typing (but nothing happens).
The message I get when I boot up from Ubuntu USB boot drive is:
"Failed to set MokListRT: Invalid Parameter
Could not create MokListRT: Invalid Parameter
Importing MOK states has failed: import_mok_state{} failed
:Invalid Parameter
Continuing boot since secue mode is disabled_"

It then gives me the option to choose:
Ubuntu (safe graphics)
OEM install (for manufacturers)
Boot from next volume
UEFI Firmware settings

I have tried them all and just go to a black screen with the white dash, apart from the last one, which takes me to a screen that says:
"error: can't find command 'fwsetup'
Press any key to continue..._"

This takes me back up to the choices listed above.

I have checked back through what I did and think my fatal mistake was made when I had gone through the whole process of installing Ubuntu and everything looked promising. When I was told to restart I realised the USB stick was still in so pulled it out before restarting and now realise I should have left it in until prompted after the restart. Is that likely to be the cause of bricking the iMac?

It is possible that your BIOS is locked down by a security password. Back when I was still using MAC's, and learning them in School, we had to look in the computer's manual book, which usually contained the password somewhere.

I am guessing that you don't still have your manual after all these years, most people don't keep them. But it was our school policy to keep all books and material just incase.

I am just making one final attempt to boot from my El Capitan USB boot drive.

It has started the process but did this yesterday and then failed at the last minute. Will let you know if it works. If not I think I will cut my losses and go to a Windows PC I have with two drives on it. It was just that the display on the iMac would have been so much better for Linux. Having said that my Windows PC is newer and more powerful so should give decent results if that is what I end up doing.

The El Capitan Boot drive did not work. I am calling time on this iMac and my attempts to load Linux. Thanks all for your advice. I am pretty sure I screwed it up by pulling out that USB too soon. Hopefully I will get into Linux on one of my Lenovo dual drive mini pc's very soon. Can anyone recommend the best video to dual boot with Windows 10 on the C drive (240GB SSD) and Zorin on the D Drive (empty 240GB SSD)?

It is indeed possible that the USB drive is no longer any good. Many people forget that there is a write limit on those things. And yes, pulling a drive out, without properly ejecting it in software first, can damage them, or the files stored within them.

Perfect example, when I installed Zorin OS off of my USB SSD drive, I rebooted the computer, entered the BIOS right away to prevent loading off of USB yet again. I pulled the USB drive at this point, then I did CTRL ALT DEL to restart the computer once again.

When you get back into an operating system, I would plug that drive in and do a health scan on that drive. Also, in the future, please don't use the Balena Etcher to make your ISO burns. Yes, I know, its been classically recommended in the past, but its known to break USB drives just so you know.

For Windows users, we typically recommend Rufus, or Unetbootin. Some users have reported success with the Universal USB Installer/Burner APP. For already Linux users, I personally recommend Popsicle APP, as its the best.

Since I haven't used MAC in 20-years, I don't know what APPS are available to MAC owners for ISO burners. Which is why I am glad we have someone on here who is more of a modern day MAC expert you could say.

I thank you for trying, I strongly urge you to try again once of these days when you can find the time. Thank you for updating us on your situation as well, much appreciated!

1 Like

I have only burned a few iso files on USBs. I did try Unetbootin. However, I suspect user error was the source of the problems I had with it. With that said, on the iMac I have yet to encounter a problem with Balena Etcher. However I have an Apple SuperDrive hooked up and I have been burning iso files on DVDs using Brasero with no issues whatsoever. Been doing a lot of distro hopping. (but always returning home at night to Zorin).

Back to your issue with wanting to go back to MacOS, I tested it again today and in recovery mode via Command + R from restart, I was given the option to reboot to MacOS that shipped with my 2012 iMac. Maybe the 2009 model doesn't offer this.

It does offer this but the process does not complete. I suspect I got far enough into the failed installation of Ubuntu that I wiped this option from the iMac hard drive. Then, by pulling out the flash drive before the restart, rather than afterwards, I spoiled the whole thing.

OK, then there is no way around this then, to do this the old school way. I don't know if your MACBOOK is old enough to have a DVD drive, if it is, get yourself a copy of MAC OS, and install it the old school way.

If your MACBOOK is too new for optical drives, then your going to have to do the same thing, buy a copy of MAC OS for your system, burn it to USB, and install.

Great minds think alike!! I woke up this morning with a lightbulb moment and fished out an old Snow Leopard Installation disc. While I was waiting for the installation to progress I looked at this feed and saw your message, which gave me confidence that I was on the right track. I now know I have a way of restoring the iMac and also formatting the disc to get rid of any old partitions or failed attempts to install Linux. I am just creating a new Boot Drive for Zorin 16 to give it a go.

1 Like

Got as far as Try Zorin. I managed to get the wifi connected using the Broadcom drivers and then tried to open Firefox and everything froze. I have had this issue before. I may have to try Linux Mint or Ubuntu in the end if Zorin will not play nice on my iMac.

Don't you love it when that happens? HEHE. I am happy to hear that you had a disk on hand! I say this cause computers never come with their installation disks anymore, which I've always thought was odd since they started that business. My new computer from this year didn't come with any either, and neither did it come with a physical manual either!

Man, I still remember when computer's came with manuals the size of dictionaries. These days its like, computer users, you are on your own. We made the product for you, we don't have to support it or you. Isn't that sad? Another reason to switch to Linux IMO.

Anyways, hopefully you can install Zorin OS 16 at some point. I am not so sure of that USB drive, for the record, I never heard of that brand a day in my life. I recommend Sandisk drives.

Trying to avoid Balena Etcher now just in case. I am installing Linux Mint on a DVD to see if that works.

Linux Mint seems to work ok in Live USB mode. I am reluctant to give up on Zorin. Do you think it popssible that the freezing when I try and open Firefox on wifi could just be a Live USB restriction? I have 8GB DDR3 Ram and 2.66 Dual Core processor. Firefox opened up fine in Linux Mint Live USB and I was able to open several searches.

Well, did you double check the SHA256 checksum on the downloaded Zorin ISO? So many people forget to do that, and you may have a corrupted ISO. Because if you have confirmed the checksum and its passed the test, well........

The only other thing that I can think of is either two different things. Either they are different versions of Firefox, and one has an issue while the other version does not. Or maybe there is a lack of driver in the LIVE USB that Zorin uses, that Mint has.

I got the download from the Zorin OS - Make your computer better. website. I do not understand the checksums but assumed it would be Ok off the official Zorin website?

I would suggest pop os instead of linux mint.

Thanks. Any particular reason?


1 Like