Monitor(s) not going into sleep mode

Hey guys,

It's me again. I'm having another issue with Zorin 16 OS which appeared out of the blue and like 4-5 weeks ago without me changing anything.

I have 3 monitors and I have set in power settings, that they'll turn off after 8 minutes of inactivity. However, as I said, for the past 4-5 weeks they do not turn off anymore. At all. It can be 30 minutes, 12 hours or 9 minutes afk, the monitors are all still turned on.

How would you approach this problem? Is there anything I can do?

Best wishes,

A small addition to that is, that the lock screen doesn't appear either, even though I enabled it in order to confirm waking up the computer with a password, which simply doesn't show up :frowning_face:

Is Screensaver enabled?

Have you at any time, run xset dpms 0 0?

1 Like

Hey Aravisian, good to see you again!

No screensaver enabled (afaik). And no, I didn't run this command, should i?

1 Like

The screensaver is usually what handles the Lock Screen and Monitor power down, not the power settings.

And no, you should not run that command. I was checking if you had because it would disable the power manager or screensaver from turning off the monitors or enabling the screensaver lockscreen.

I see. I'm not sure if I've ever come across the option of a screensaver in the Zorin OS settings, where would I find them sir?

And no, I'm very sure I've never seen that command before

I cannot remember; are you using Core or Lite?

Neither, Pro haha. But this is basically the same as core without some additional features right?

Anything you have on your mind helps. The computer is running 24/7 and it sucks that all 3 monitors are as well :confused:

I use Zorin LIte... Which is XFCE. Not sure about Gnome (Core).
In your Zorin Settings > Power
What is displayed under
"Blank Screen"
"Automatic Suspend"

I fear that there's neither of those options in Gnome :confused:

Yes, there is, see > menu - System Tools - Settings - Power, both
Blank Screen and Automatic Suspend are available.


Oh, I'm sorry! If it's not too much to ask for, would you mind sending me a screenshot of this? I still cannot find it (Not sure how these settings are called in German)

EDIT: Got it

1 Like

I'm not sure what the German equivalent to "Blank screen" would be, but I suppose it's the time until the monitors shut down? This would be 1 minute. Automaitc Suspend is turned off now, but tried it with both, turned on and turned off which both didn't turn the monitors off

Acrunch, sorry; I was not clear. The questions I asked relate to Gnome.

I was merely pointing out that My Memory of Gnome may not be perfect.
But I did log in and check on Gnome- the settings are as described above.

Tried you settings, mine worked the screen went blank (black that is) but I'm using just 1 monitor.

Are you sure that you have not installed any extension(s) within the 4-5 week period, that are mouse or screen related and which could have override the settings?

1 Like

Mhhh well I installed imsettings to alter the mouse wheel speed on Zorin from a guide I found here. But I did this right when I installed Zorin in the first place like 3 months ago. But it could definitely be that I installed something like that but I'm not aware of :thinking: Is there not a way to check this?

The IMWheel package should not effect this... Or... hmmm... actually it is possible. I think you would have noticed it pretty quick.

Have you checked the Settings app from the Zorin Menu? Move to the Power tab on the left pane.
If you do not see it, check the Back Button on the very top left... The Settings remains on the last opened tab after closed.

Yeah, I checked the settings app and found the power option, but no combination of those settings bring the monitors to turn off, sadly.

I did fumble around back then with the mouse's cursor speed settings around that time I think :thinking: But I'm not sure at all if I could even recreate what I did there haha

Followed some guides that would alter the speed of the mouse cursor, let me see if I can find it

I followed this guide, but for the love of my Linux skills, please don't ask what exactly I did :smiley: