Multiple monitors with different resolutions cause problems in full screen

My main monitor has a UHD resolution. My second monitor only has a 1080p resolution. When I start a full-screen application on my main monitor, both screens sometimes go black and then show an image again, and the content jumps wildly from one screen to the other. On the 1080p monitor you can only see a section of an application and 3/4 of the monitor is just black. Sometimes everything constantly jumps back and forth and unfortunately the system is sometimes no longer usable. It looks like the entire user interface of Zorin OS is destroying itself.

I have fractional scaling turned on. Because I have set a 150% zoom factor on my UHD monitor. 200% is way too big and 100% is way too small. The 1080p monitor should not be scaled, otherwise everything there is huge.
If I turn off fractional scaling this doesn't seem to happen.

My GPU: Nvidia Geforce RTX 3060 Ti
CPU: AMD Ryzen 9 3900X
RAM: 64GB DDR4 RAM Corsair

Is there any way to fix the problem? I've never had a problem like this in Windows and I set it up exactly that way.

Fractional scaling is very likely the culprit.
It still needs further development in GnuLinux.

1 Like

Okay, then I guess I have no choice but to live with it and hope for updates that fix the problem in the future.

It may be. Which Nvidia driver are you using? I recommend the 525 (Proprietary) driver, not the 535.

What refresh rates are your display settings on for each?

1 Like

I use the driver which comes with zorin os installed (535 Proprietary).
Refresh Rates of both Displays are 60Hz. I will try the 525 now. Thanks.

Edit: I tried now a Fullscreen application after installing the 525. This weird issue is still present. Not fixed.

Are you set to Intel Prime or Nvidia Prime?

I have an AMD Ryzen 9 3900X. This CPU is no APU. The only Graphics Card in my PC is the Nvidia one.

1 Like

Ah, I see.
Does the issue persist without any fractional scaling?

Issue is not present with fractional scaling disabled.

It seems i finally fixed the issue. I installed this gnome extension and enabled it on firefox in gnome extensions:

Please add this solution to Zorin 17 per default or as option in settings gui. This would be awesome. Seems there are no more fullscreen issues even with fractional scaling enabled on 4K and 1080p multi monitor setup.

This Guy has the exact same multi monitor setup as mine and he has uploaded a gif which is showing the problems. These are exact as mine:

GIF:

1 Like

Wow, great find. I was still looking into possible solutions and lamenting that Fractional Scaling is such a beast.
Thanks for finding and posting the means of resolving this.

1 Like

I'm not sure what disadvantages this extension has because it disables something. I haven't noticed anything yet. But it would be interesting to know what exactly this function does that is disabled there.

Are you logging in on Wayland?

Not sure. How can i check this? I didnt changed something on the gnome side after zorin install.

You can check which (X11 or Wayland) you are logged in on with the terminal command

echo $XDG_SESSION_TYPE

Selection of the Display Protocol would be done when you reach the Login Screen and log in to your desktop. There should be a gear icon to click on. If you do not see the gear icon, select as though you want to log in on another user - this should make it appear. Once you finish making your selection, you can log in as normal.

~/.local/share/gnome-shell/extensions$ echo $XDG_SESSION_TYPE
x11

1 Like

Then you should have no unwanted effects.

full-screen surface unredirection to bypass compositing when running full-screen games and the like has just been merged into Mutter! Basically avoiding extra compositor work when an application/game is occupying the entire area of the desktop. This full-screen surface unredirection to bypass compositing with Mutter should be a measurable performance help for gamers

You can ignore the articles references to Wayland since you are not on Wayland and the unredirect was already supported in X11 at the time of writing.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.