Music Producer gone Zorin

I’d like to thank the tireless efforts of the ZorinOS team for making it damn-near seemles for us who wish to break the chains of a seamingly binary choice in OSs. You have also brought my i7 2011 Macbookpro (which has the legendary defective Nvidia GPU) back to like;problems face were on getting my two maybe 3 VSTs to install,let alone run via wine and the fact that I cannot use ASIO4ALL
FYI: I’m an FL-STUDIO (Fruity loops) power user
with the advantages I had with ASIO4ALL,I was able to route the inputs and outpouts to various places i.e controlroom(main studio external soundcard) headphones and/or near field speakers, recording room headphones/speakers(mbp’s onboard audio jack),talk loopback microphone(mbp’s onboarmic) so I can talk to the talent.
All the above cannot be done with pulseaudio.

To summarize my question(s);

  1. Is there a way I can use wineasio to pull off the same type of above riggin?
  2. The VSTs that do manage to ‘wine’-install can’t access the .DLL(s) needed, through FL-STUDIO daw

WOULD APPRECIATE THE ASSIST(s) as I’m currently on Zorin 15 Lite and once everything works software wise I can confidently go ‘Ultimate’

Are you using Jack?

I am not an expert on this by any means, so I did some web searching. Most sources seem to suggest that winetricks or PlayOn Linux must be installed, that core Microsoft fonts must be selected / installed using Winetricks or PlayonLinux, then FL Studio installed.
All these sources claim that FL Studio works flawlessly on Wine.
The reason I am not posting links is because each source gave instructions for Distros that use entirely different package managers and some were for distros that are Ubuntu Derivatives, but were for Ubuntu 16.04 and some o their instructions are out of date and would not work if run today- In short, I do not want to sow a bunch of confusion.

So what I suggest for now would be to install PlayonLinux

sudo apt install playonlinux

and winetricks

sudo apt install winetricks

Open PlayonLinux to open FL Studio.

1 Like

Regarding routing audio, JACK Audio is often used for Linux audio production workflows and is available in the Zorin OS repos.
Regarding VSTs, perhaps yabridge may help you to set them up:

2 Likes

Thanks for the quick response,yes omg FL-STUDIO works flawlessly indeed which prompted me wiping the SSD immediately and installing Zorin lol. But it’s the wineasio and the VSTs.
Sure I can go full native when creating music nowadays but some older projects used VSTs.
Also the wineasio is for plug and play,should I get into any physical studio for a recording session.but thanks anyhows I’ll try these options.im already actually sold with Zorin by the ways…

Also I’m not sure if wether or not I’m using ‘Jack’

Cheers!!how do I install and get it working?

You can install Jack with

sudo apt install jackd

As I said, I an not an expert. I have never done much work with music. I learned over time though, to be fearless in giving a reply because it helps a person to be heard. It is not unusual that I may say something that helps a person find the answer for themselves or gives a hint on the right search or a push in the right direction.

In searching I did find this:

The archive ending in -ubuntu-18.04.tar.gz is a compatibility release meant for older distros and is thus slightly larger in size. If you’re using Ubuntu 18.04, Linux Mint 19, debian 10, or any other distro that’s older than Ubuntu 20.04, then you should use this archive instead of the regular release. Yabridgectl will run on any distro.

It seems that it was originally compiled for Ubuntu 20.04. The developer needed to create a version for Ubuntu 18.04, upon which Zorin 15 is built. So Please Be Sure to get the correct version.

He also created a Discord page for help with setting up.

All of that said, I did sneak over to your page and listen to Gvenya

Very professional sounds. Any help we can offer to keep you working is a worthwhile effort. :smiley:

1 Like

That’s wussup!many thanks for the support both hear and listening to some of my work for reals,I’ll surely return the favour.will let you guys know how it goes,it’s late here in Uganda so good nite from me,stay healthy out there,peace

I am a strange one when it comes to music. While there is a great range of what I enjoy listening to, there is plenty I simply do not.
I enjoy 1950’s Doow0p, Classic Rock and Roll, Heavy Metal (Grew up a total Metal Head) and some of the amazing Alternative produced by groups like Linkin Park.
I enjoy Opera, classical Orchestra and even ska and swing sometimes. A great blend is Stray Cats - an eighties band that sounds straight outta 1938.

But it’s rare I like rap. Sometimes, I do but I usually don’t.
So, when I say I really liked Gvenya, it is more than just as compliment- Because I am a very hard audience to please.
Maybe it is in part because I could not understand the lyrics. Most often I listen to music that gives me energy while working, especially in the shop. Gvenya is filled with energy, to a beat that is strong. Even if I could not understand them, the lyrics were delivered with a lot of heart.
Yesterday was a hard day. The weather has cleared up here which led to a lot of catching up on work to do. The forum too, seemed like a day of failure as each problem, I seemed utterly unable to help with. It was late here, when I looked at your page and listened to the sample- it was just a soul-lifting that I needed.
Keep being great. :smiley:

1 Like

Word?!

Okay so I wanna get jack working so since everywhere on Zorin lite,it show jackd(qjackCtl) is already installed.however on wineconfig, I only see pulseaudio on the ‘Audio’ tab.
It’s there something I’m doing wrong?

I am not sure, I do not even use Wine.
This page may provide the answer- But choose Jack instead of Alsa (per the instructions on the page).

1 Like

okay so i got yabridge,installed it, now im asked to update my Wine(4.0.3).
after downloading the dependencies (Groovy Main), i get a 'E: Malformed entry 56 in list file /etc/apt/sources.list (Component)
E: The list of sources could not be read.

what do i do?

Right off the bat, your Wine repo should not be set to Groovy Main. It should be set to Bionic Main.

In terminal, enter

sudo nano /etc/apt/sources.list

Please maximize the Terminal Window and take a couple screenshots (one for the top portion and one for the bottom portion after Arrow Key toward the bottom of the list) to show your Sources List- and we can see what needs fixing.

1 Like

this one actually work!!!tank you!!

Glad to hear. But, you will still need to correct your sources.list, because it affects updates and upgrades.

1 Like

lemme know if that shot helps

1 Like

It does. You can see the two entries for Groovy Main WineHQ at the bottom in your screenshot. If you can arrow-key down to those, then you can just backspace all the way up to remove them both or hold shift and arrow key over each of those entries up to the bottom of the Bionic Main for WineHQ to highlight the lines, then backspace to remove them (But Not Including The Bionic Main- leave it not highlighted and do not remove it).
Then hit ctrl+x to exit, hit the y key to say yes to save, then hit the enter key to save the current file.
Your terminal will then revert to normal.

If those are not removed, they will cause the Malformed entry error as well as when you update, the updater will try to access them.

1 Like

done,but i still get a complaint when i run the ‘sudo apt install --install-recommends winehq-stable’ command;

Please run

sudo apt --fix-broken install

Then try the following and see what the terminal tells you:

sudo apt install -y zorin-windows-app-support

1 Like