My pc is stuck at GRUB, no detected keyboard and cant enter BIOS

So i updated to ZorinOS 16.3, but it rebooted into grub, i tried entering bios, unplugging the HDD, even used two keyboards but no luck. Please help!! (dualbooting with win 10 22h2)

Was that an update from Z15.3 Core to Z16.3 Core?
What do you see on grub screen? post a screenshot.

Have you tried running Boot Repair utility from a Zorin installation USB that you may have?

I cant boot into usbs as the bios is not letting me access it, its GNU Grub 2.06 Minimal Bash-Like editing screen. (updated from zorin 16)

@logan, can you please address these questions so that we know our starting point:

Would normally point to Secure Boot being enabled - can you check to see if Secure Boot is enabled or disabled in BIOS?

When you get to the Grub menu, the last option should be 'UEFI / Firmware Settings' which is an entry to enter the BIOS. You might have to use either F1, F2, F10, or the Del key to enter BIOS as well.

Last one - what machine are you running? There might be a different way to entering BIOS; like with HP and some others.

FYI. OP answered the updated from question in post #3

running a Asus motherboard, I tried F2 and del suggested by the post screen before grub shows and freezes my pc

Please follow this guide:

It sounds like a file corrupted during the upgrade of packages, required an fsck to FileSystemChecK the system.

That doesn't specify what make / model though. Just the OS.

i cant enter bios neither type in grub :confused:

BIOS access is part of the Motherboards operating system - separate from Zorin OS.
If using an SSD for Zorin OS, you may need to be very quick about bapping that F key to reach the BIOS EFI settings.

the thing is, im running windows on ssd and zorin on hdd, but i try and do the bios key spam and i still go to grub menu

btw i got no grub menu

Can you please clarify these two statements?

1 Like

oh sorry i got confused on their names, ill just call the screen im on bash-grub to make it clearer

btw heres what i see so its a little more simple to help
GNU GRUB version 2.06
Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

(btw i cant use typing)

1 Like

And you can't get into BIOS? It sounds like the first boot device is incorrectly set.. the bash-grub is normal when there's no boot device selected.

Your machine's make / model would pin down how to get into BIOS..

So its a prebuilt but by the boot logo its definitely a ASROCK-make (reason why i have a prebuilt is because it was a bday present a while back)

Do you have this screen at all on boot??

yup but it disappears in less than a second

That's likely due to the 'quick startup' option within BIOS being enabled - which makes it extremely difficult to get into BIOS..

As your machine is booting - hold down Del or F2 until you see a different screen. If one key doesn't work, try the other.