My software center no longer works

When I go into the software store, everything loads but when I go to install something, it doesn't install, it stays at 0% no matter how long I leave it.

See: Fixing the common problems of Software Center

Is it first time you running software center when it happens? If so the progress is not moving the first time installling things. It's a known bug.

1 Like

No, I have had Zorin install for 2 days. I have used the deb file provided by the website because nothing would install

Okay. Following the link I gave. If it doesn't solve the problem, it must be something else.

Sorry, I didn't notice the link before. I tried what they said and it seemed to have worked. Thank you! Linux maybe my full time PC with that out of the way!

2 Likes

I found it still doesn't work now. Same issue

Check which packages are showing this issue. Is the issue restricted to only Snap or Flatpak pacakges? Or are all packages affected?

If it is Snap or Flatpak, you can try

snap refresh

flatpak update

to see if you can get them going.

If all packages are affected, you might traceroute your internet signal and see if you showing packet loss or a drop in your connection.

Could you elaborate on the tracerouting? I am pretty new to linux

No problem, it is very similar to how it is run on Windows OS if not using the GUI application or a website to perform it:

Ok, I just did one with google.com
Is there one I need to do for the software store?

(Can't paste the output as new users can only put up to 5 links)

No since the internet routing is going to be consistent across all traffic, there is no need to try to specify a single application. The purpose is to test if the net is dropping, causing loss of connection when trying to install software.

If your net connection is solid, then there may be an issue with your Regional Server. You might try launching Software & Updates and in the Download From drop down menu, setting to Main Server.
Reboot.
Then run

killall gnome-software

rm -rf ~/.cache/gnome-software

Then launch Software Store and test.

1 Like

It seems to be working for now. Hopefully it stays working. Thanks!

1 Like