My version of Nemo File manager is 5.8.4, where is it's github like page? where an issue can be filed?

is this it?
https://github.com/linuxmint/nemo

This has 6.2.1.
Is 6.2.1 available for zorin?

No, because Zorin is a LTS Distro (Ubuntu-based). If You want the up-to-date Nemo, You should use Limux Mint. This has an Ubuntu LTS Base, too. But the Mint Team delivers an up-to-date Cinnamon Desktop (there are developing them).

1 Like

Whats the most current version of nemo available for Zorin?

That should be Version 5.2.4:
Bildschirmfoto vom 2024-06-24 12-44-58

If its 5.2.4, then how is it possible for me to have 5.8.4 on Zorin?

Nemo 5.2.4 is the latest in the Jammy Repository, however if a user adds the LinuxMint Teams Repository, they can install a later version (which you may have done.)

If you have installed the LinuxMint repo, you should remove that repository after installing your desired software. Failure to remove it can cause package dependency issues, breakage and conflicts with other packages due to you using a system that relies on Jammy, but having a repository that includes other packages (including essential system packages).
This is as true as using the POP_OS repo to add a specific POP_OS package or using the Zorin Repo when using a different OS. If you temporarily add a repo in order to obtain a specific package, remove the repo once you have that package so that it does not conflict your general Packaging.

1 Like

Hmm ... a good Question. Did You add any Repo's in the Past like @Aravisian wrote? How did You installed Nemo?

1 Like

@Aravisian , How do I remove the 5.2.4 nemo version?

2.) "Did You add any Repo's in the Past like @Aravisian wrote? How did You installed Nemo?"

--I dont think i did, other than using sudo apt-get update, maybe thats how i managed to do it.

The sudo apt update command updates the sources, it does not upgrade the packages.

You can check using the Software & Updates app to look if you have the MintDailyBuilds repository added.

sudo apt remove --purge nemo

2 Likes

@Aravisian , I purged it, that worked, but now I cant reinstall it. And now i dont have nemo at all.

1.) I tried to reinstall it via terminal and this is what I get:

Err:2 http://ppa.launchpad.net/linuxmint-daily-build-team/daily-builds/ubuntu focal/main amd64 nemo amd64 5.8.4-unstable-202308021446~ubuntu20.04.1
  403  Forbidden [IP: 2620:2d:4000:1::81 80]
Fetched 7,100 B in 0s (17.9 kB/s)                         
E: Failed to fetch http://ppa.launchpad.net/linuxmint-daily-build-team/daily-builds/ubuntu/pool/main/n/nemo/nemo_5.8.4-unstable-202308021446~ubuntu20.04.1_amd64.deb  403  Forbidden [IP: 2620:2d:4000:1::81 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

2.) I tried to install "5.8.4-unstable-202308021446~ubuntu20.04.1" using the software store, and i get this error,

Ah, Yes. This is exactly what was the Point: You add the linuxmint-daily-build-team PPA. That is the Reason why You had installed Nemo 5.8.4. But this PPA is for ubuntu focal - that is Ubuntu 20.04, the Base from Zorin 16. That will not work on Zorin 17 because it has Ubuntu 22.04 (jammy) as Base.

You should delete this PPA. To do that start the Software Updater and click on stop and when it stops click on Settings. Then You should get this Window:

Don't bother about the Language on the Picture; it is german. When You are on this Window, go to the Other Software Tab. And in the List search for the PPA and then delete it. After this open the Terminal and type sudo apt update

1 Like

Hold on, before we continue, I need to say that I am using Zorin 16.3, not 17. Does that change any of what you advised?

1 Like

Yes, that is important. Good, that you wrote it. So, theoretically it is the right Repo for the Zorin 16 Base. But it looks like that it doesn't run properly anymore. Maybe there have changed something on it.

What You could try first before You delete the PPA is that You take a Look in the List (what I describted) and take out the Marker:


So, look in the List for this linuxmint-daily-build-team PPA and take out the Marker.

After that make type in the Terminal sudo apt update and look if the PPA is no longer in the shown Source List. and then type apt list nemo -a to control what Nemo Version is available for You. Because when you are on an older Zorin Version the Nemo version could be older too.

1 Like

I really need your guys help. I removed Nemo completely and now I cant re-install it. @Aravisian my day to day tasks strongly involve using Nemo.
Nautilus works okay, but wont show my trash can. And Thunar constantly froze when I tried to use it today.

Did You have removed or turned off the PPA? When You type in the Terminal sudo apt install nemo what Output do You get?

Nemo is in the Universe repo, so even with the Mint repo removed, you should be able to install Nemo.
In Software & Updates, ensure that these options are checked:

  • Canonical-supported free and open source (main)
  • Community-maintained free and open source (universe)
  • Proprietary drivers for devices
  • Software restricted by copyright or legal issues (multiverse)

Navigate to Download From and set this to "Main Server"

With all of this done, in terminal, run

sudo apt update

sudo apt install nemo

1 Like

@Aravisian , @Ponce-De-Leon ,

Nemo 4.4.2 is giving me problems, and 5.8.4 gave me problems. Why dont we try 5.2.4.

How do I install Nemo 5.2.4,the latest Jammy Repository version?

@Jessie your question has been answered in this thread in which not only how to install is covered, but also included are clear warnings about package conflicts that can result from using another Distros Repository and that the File Manager is an integral part of Desktop management.
You seem intent on trying out many different versions in spite of the evidence that the problems you cite appear on older or newer versions.
This is indicative that the issue is not the versions, but some other configuration, extension or file that is interfering with the proper execution of Nemo (e.g. Python).

You wrote that You use Zorin 16. When You install Zorin 17, You can install Nemo with a simple sudo apt install nemo Command from the Jammy Repo (Zorin 17 is based on Ubuntu Jammy).

I hope You don't think that I'm rude when I say this: In Your Case with Your problematic Sources I would suggest that You save Your personal Data on a USB Stick and make a fresh Install of Zorin 17 and don't use the Upgrade Tool for upgrading Your Zorin 16 System to 17. I think with the Tool it could give Problems.

2 Likes