Natural scrolling does not work

I am on Zorin Core 17.1, and natural scrolling was working fine, but I had a freezing problem.

I installed Zorin Lite desktop and then got into other problems, incl. a touchpad issue, whereby either nat. scrolling works or touchpad tapping works, but not both.

I have now reverted back to Core, enabled nat. scrolling in the Settings, but nat. scrolling still does not work.

Did You tried it with a Reboot after You enabled it?

Yep, for various reasons I have rebooted several times.

Did You checked if it runs with Xorg?

I am on Xorg all the time because of KeePassXC.

So, with Wayland You didn't tried it?

Nope, I did not do so specifically. However, when I 1st started with Zorin, I was on Wayland, and nat. scrolling was working.

I switched to Xorg because KeepassXC's autotyping was not working. When I changed to Xorg, nat. scrolling was still working.

It was working until I changed to the Zorin Lite desktop and back to Core.

Hmm ... maybe in Your whole Freezing Issue Situation something got wrong with that. Could You try to go to Wayland to control if it work there now?

On Wayland nat. scrolling is not working either. I'll go a step further: I have installed Gnome Boxes and even the distros in there are affected by this. In other words, even if I set the distro in GB to nat. scrolling it does not work.

Hmm ... maybe another more experienced User can give You better Advices. The only thing I would say is: After Your Issues-Tour it could be good to make a new fresh Installation of Zorin.

Yes, you are right.

1 Like