Zorin freezes from time to time

I have looked on the forum for solutions to this problem, which others have experienced too in the past, but none work for me.

Here is info about my computer:

  Host: laptop Kernel: 6.5.0-35-generic x86_64 bits: 64 Desktop: GNOME 43.9
    Distro: Zorin OS 17.1
  Type: Laptop System: LENOVO product: 81FL v: Lenovo ideapad 330-17ICH
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN
    serial: <superuser required> UEFI: LENOVO v: 7ZCN29WW date: 10/24/2018
  ID-1: BAT0 charge: 32.7 Wh (92.1%) condition: 35.5/45.0 Wh (78.8%)
  Info: 6-core model: Intel Core i7-8750H bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 800 min/max: 800/4100 cores: 1: 800 2: 800 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: Acer EasyCamera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Sound Server-1: ALSA v: k6.5.0-35-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
  IF: wlp0s20f3 state: up mac: 48:f1:7f:42:6a:9e
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp7s0 state: down mac: e8:6a:64:b3:24:45
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb
  Report: hciconfig ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: 48:F1:7F:42:6A:A2
  Local Storage: total: 1.03 TiB used: 25.73 GiB (2.4%)
  ID-1: /dev/nvme0n1 vendor: Lenovo O.E.M. model: RPFTJ128PDD2EWX
    size: 119.24 GiB
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  ID-1: / size: 116.32 GiB used: 25.73 GiB (22.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 43.0 C pch: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 383 Uptime: 14m Memory: 7.62 GiB used: 4.28 GiB (56.1%)
  Shell: Bash inxi: 3.3.13

Welcome to the Forum!

Could You maybe describe a bit more how these Freezes are happen or what You do before?

They happen randomly, not often, perhaps 1x/4weeks.
Last time, yesterday, I was on a webpage with an embedded video, and when I clicked to watch it the system froze.

This is not the way it happens every time, sometimes I am just reading a webpage and the system freezes.

1 Like

Try switch browser for a week and see if the freeze stops or continue.

Like I said, the freeze happens about 1x/4 weeks, so I'd have to use another browser for longer than a week.

Furthermore, I am using Brave browser, which never gave me any problems on other distros nor on MacOS.

Can you summarise what you have tried, to avoid us suggesting the same things again. e.g. have you tried switching from Wayland to X11 at the login screen gear icon?


I would actually recommend using other browser if you wouldn't mind.
Chrome , Microsoft Edge , Firefox or any other browser.

I am a bit surprised by this recommendation. Are you saying that Zorin cannot handle the Brave browser? That is a serious question.

I didn't see anyone say that.

What people have suggested is try a different browser (or two), to see if the problem still occurs or not. If not then you can consider the problem is confined to Brave browser and can then proceed to troubleshoot on that basis.

If you persist with Brave, you will simply go on persisting with the freezing issue without simply eliminating the first potential cause. First rule of troubleshooting elimiate possible causes one-by-one.


It's to eleminate which can cause the freeze, by taking the browser out of the equation.

If Brave should have (I don't use Brave, so I don't know) something called Hardware Acceleration You could play with this Setting and turn it off test it a while and then turn it on again. That would be an Idea for the Browser itself.

In common I would ask if You already tried to change between Xorg and Wayland?

Another Thing could be if You use Fractional Scaling or how Your Refresh Rate is set up.


Thank you, I like those suggestions.

I have turned off graphics acceleration.

Later edit: I found this comment on Make Use OF (MOU):

in Google Chrome, hardware acceleration can sometimes cause issues like crashing or freezing in Chrome and to fix these issues, you may need to disable hardware acceleration.

So, this supports your suggestion to disable GPU acceleration in Brave. I will report back.

Re Xorg and Wayland: I originally started on Wayland and the problem arose too, iirc. I changed to Xorg, not because of that but because the autotype feature of KeePassXC does not work under Wayland. Under Xorg, which I am still using, the freeze issue remained.

I have had fractional scaling disabled ever since I installed Zorin. I do, however, increase text size with CTRL-Shift-+ : is that relevant to your remark?

My refresh rate is at 60 Hz.

1 Like

Okay, take Your time to test.

No, I meant only the Fractional Scaling for the Display.

1 Like

1st positive step: I went back to the last webpage where the problem occurred, but this time, of course, hardware acceleration was switched off.

I clicked on the embedded YouTube video that caused the issue, but this time it went without a hitch :+1:

I'll carry on for a few more weeks then report back, or before if the issue recurs.

1 Like

I saw this topic Browser don't work - #6 by Guillaume and tried launch Brave from the terminal. This is what I got:

user1@laptop:~$ flatpak run com.brave.Browser
Gtk-Message: 18:44:46.884: Failed to load module "canberra-gtk-module"
Gtk-Message: 18:44:46.889: Failed to load module "canberra-gtk-module"
Assertion 'p' failed at src/libsystemd/sd-event/sd-event.c:178, function event_origin_changed(). Aborting.

Could the canberra-gtk-module have anything to do with my issue? If so, should I install it? If so, is the best way to that sudo apt install canberra-gtk-module?

This canberra-gtk-module is - as fas as I understand this - for some kind of Sound Stuff for a Program; for Signal Tones. Stuff like that.

But I see that You use the Flatpak Version of Brave. Maybe this could be the Reason. You could test if the .deb Version (I guess available from the Developer?) runs better.

Or You make first that what You wrote and test it with disabled Hardware Acceleration.

1 Like

Re the canberra stuff, that is reassuring.
Re the .deb version, this is what it says on the Installing Brave on Linux | Brave page:

Brave is available as a Flatpak package from Flathub. While it is maintained by Brave Software, it is not yet working as well as our native packages. We currently recommend that users who are able to use our official package repositories do so instead of using the Flatpak.

So, your comment makes sense, and I will have to make the switch.

As a general question, does that mean I have to uninstall the flatpak version first or is the fact that the flatpak version is containerized and self-sufficient for all the elements, dependencies, etc., there is no risk to install the .deb version in parallel?

The reason I ask is because I want to try to copy the flatpak profile to the deb version profile. If it does not work — I believe there is that risk, unlike with Firefox — then at least I still have the flatpak version I can look at and make changes manually in the deb version.

1 Like

I can only speak for Firefox because I had the Flatpak and the .deb Version at the same Time installed and that makes no Problems for me. When You want to go the safeist Way, it would be better to uninstall the Flatpak Version. But that You can do after You have added the Brave Repository.

Because of the Profile: Is there any Setting to export Your Brave Profile? If yes, You could do this and after the Installation of the .deb Version You could import this Profile.

1 Like

Unfortunately there is not. I have an indication of where the config folder is — there is a lot in there and I am not sure it really the equivalent of the "profile" folder. I can try and if it does not work I'll have to do everything from scratch again.

After I will have done all these acrobatics, I'll monitor .deb Brave for a while longer and will report back. Judging from Brave's own comment I quoted above, your suggestion may well be the solution, in which case I will mark it as such.

1 Like

Update: I did that parallel install, then managed to copy the folder over, it went without a hitch !!

For others who might come across this:
the flatpak folder is at ~/.var/app/com.brave.Browser/BraveSoftware, so it is the BraveSoftware folder that needs to be copied to ~/.config/

I tried the 2 problem-causing web pages in the .deb Brave browser, and there weren't any problems. Let's see what happens in coming time. I will update here.

1 Like