[NEED HELP] Zorin 16 pro loop crashing

Hi everyone,

So I'm kind of a new user (I already tried some distros real fast, included the 15 pro lite recently) and I really planned to leave Windows and stick with Zorin... but it didn't go well...

Zorin 16 was really sluggish on my laptop and ultimately crashed everytime, I needed to turn my laptop off and on again. I thought my configuration might be in cause since outdated (intel core duo, 4 gb ram...) but system monitor showed me zorin only uses max. 50% of my cpu and ram. Usually less. Besides sometimes it was real fast (thanks to the new ssd?) and the freezes were totally random.

Sadly when I tried to change the wallpaper there was an ultimate crash and now I keep getting the error "Oh no! Something has gone wrong." Again...and again... and again...

I can't access to my system anymore.
I hope someone will be able to find the answer.

Thank you for reading.


P.S: Some Pics:

For this, I would actually recommend Zorin 15.3 Lite.

You tried it out- how did that go?

Zorin 16 Lite will be released within some timeframe (A couple months, maybe?)
But it actually would afford you some Growing time to use 15 Lite for now (It is still supported until April 2023) even if you want to go for Zorin 16 Lite when it is released.

In the meantime... Can you boot the machine and start tapping the left shift key like you are midmatch Mortal Kombat to pull up the Recovery Menu.
You will see a Grub Menu with Advanced Options For Zorin OS - choose that.
Once there, arrow key down to Enable Networking.
Once networking is enabled, bump back up to the Recovery Menu.
Now, arrow key down to "Drop To Prompt." Hit Enter.
input the following (no typoes allowed) into the prompt:

sudo apt update && sudo apt full-upgrade

sudo dpkg --configure -a

sudo apt clean && sudo apt autoremove

sudo reboot

Please relay your results here.

By the way, that last screenshot is awesome. I started wanting to dig PacMan out of the drawer.

Thank you so much for your really quick reply!

I tried to do as you said, but it just says "Grubs loading..." and then the black and white picture comes back.
The only difference is when I press Enter to logout it shows some log files.

As for Zorin 15.3 lite it ran perfectly, just like Windows. but to be honest the 16 pro is such a pretty beast... I really hoped I could use it. Besides as I said my configuration looks fine, even the system monitoring said it wasn't using much of my cpu nor ram.

Well if there's no other choice I thought about going back to 15.3 lite as well... hoping 16 pro lite will be released soon.

Anyway thank you so much for your help!

Did you install as legacy or as EFI?

I think as legacy? I just used the basics settings on rufus (MBR + BIOS or UEFI) since balenaEtcher didn't work (making 2 of my usb sticks useless in the process...)

EDIT: Oh by the way for the last pic in black and white it was shown for 1 second every time I used to boot 15.3 lite... didn't bother me much but it might be a hint?

This is why I almost always recommend Rufus or Unetbootin... BalenaEtcher is notorious for that. (It is usually possible to salvage the USB sticks by the way with a vigorous reformatting).

Well, given that Grub has failed along with your graphics and gnome-shell; we could try repairing each but given that it is a Fresh Install - I would recommend Reinstalling.
Once installed, please reboot, ensure you are connected to the net, then open terminal with ctrl+alt+t and enter in:

sudo apt update && sudo apt full-upgrade

Thanks again for your reply and sorry for this late one. It took some time to reinstall zorin.

Anyway I did what you said, and it worked fine at first until it crashed once more... but before the crash there was a message "new drivers available" but after rebooting I don't see any driver update available, only softwares. And I can choose Nvidia or Nouveau driver for the graphic card too.

But I still feel like it's better than before, I can now open Firefox which was impossible in my previous installation attempts.

What model is your Nvidia card?

Apparently it's a Nvidia GeForce Go 8400M GS GPU.

does running

sudo nvidia-bug-report.sh

yield anything?

No, it says command not found.

Given the age of that card, that may be why - not available in the driver.
What is the output of

uname -a

Here is the result:

Ok, what about


It says not found, but can be installed with (and many choices).

EDIT: 20210821-014521 — ImgBB

Ok, that may be a good thing - I was thinking along the lines that the Nvidia Driver (Proprietary) for that card may not be supported in the 5.11 kernel.
But if "not found", that implies that you are using the Nouveau driver.

I am honestly not sure what is going on - but i need to go away from the computer for a few hours.

I see, thank you for your help.
I think I will try some stuff on my own and report back if there is any change.

Or maybe just seatback to not mess with anything...

I think I will go away from my computer for a few hours as well.

Just wanted to report that since I have switched from Mozilla to Brave it kinda works now...

I think the only big freeze I had (which forced me to reboot my laptop manually) is, again, when I tried to change the wallpaper... I guess there's some hint there (?)

But honestly what drives me crazy is the randomness of the problem... I mean sometimes it runs smooth (tried to navigate and play a 720p local video with vlc and it works with no lag) and the "explorer" (not sure if that's the term on linux sorry) runs really fast but sometimes I just have a tab open on my web browser or try to change to change the wallpaper and it goes boom...

Anyway I will try a bit harder and report back if I have any problem, especially since it could help someone with the same problem later on.

So... after a few hours there is still no big crash nor loop anymore.

It's a bit unstable tho, sometimes the system freezes (it happens a lot) and it can happen when I have nothing opened while sometimes it runs really smoothly with like 5 apps + a 1080p video playing... it's kinda weird.

Now everytime the system freezes I wait for 10mn and it goes back to normal.

Also I checked the system monitoring again during a crash... memory 50% and cpu... about 10%! (even if it quickly went to 20-30 haha).

Still if someone can find a solution it would be very welcome. Right now I really have no idea if I should downgrade to zorin 15.3 lite, because it worked but I love 16 pro SO much more...

You could also run

sudo apt install xfce4

And once set up and complete, log out, then in on the xfce session.
You would need to open Settings > Appearance and enable the Zorin OS themes (they are already installed) and change wallpaper...
You can install the zorinmenu with

sudo apt install xfce4-zorinmenulite-plugin

Then test the performance on the Lite(er) xfce desktop.