New Lenovo laptop with Zorin 16 can't drive a printer

Greetings -
I bought a Canon PIXMA TR 152 and having a hard time getting my printer to work with Zorin 16. Is there a compatible driver that comes with the printer (Windows, MAC)? Does Linux provide one? There's a long list but not one that's labeled Canon PIXMA TR150. Is that something I can access via "Terminal"?

I get the "Can not start the printer" "Check printer configuration" when trying to print.

There seem to be two printers I can load from the software - 1) CUPS-BRF-printer and 2) TR150. I can't get either to work - with a USB cable or WiFi.

Do you have any ideas? The manual that came with the printer doesn't explain much.

If you could give me instructions used for Terminal, that would be helpful. I'm not that handy with Linux but I can cut and paste terminal commands.

Jesse

Welcome! :smile:

Well, that isn't fun.. With the printer plugged into USB, what does lsusb yield in terminal?

I tried looking up some stuff on Ubuntu drivers - didn't get much in return though. But, installing libusb-dev might help. I've solved a lot of USB issues with installing that: sudo apt install libusb-dev.

And just to cover bases - you are using this cable, USB A to B:

Yes?

Thanks for responding. When I call up the lsub, it recognizes a Canon, Inc TR 150 series.

I'll try downloading libusb-dev and report back. And yes, my cable's USB side look's just like the left plug above. Where it plugs into the printer however, is more like a cell phone charger plug - thinner than the plug above on the right.

1 Like

So I managed to get three printers to show up in Settings-Printers: CUPS-BFR printer, TR150, and TR150 series. (CUPS-BFR appeared when I was working on getting the WiFi to work the printer) All are ready, the TR150 is set to default but I can't print a Libre document.

I can print the test page in Settings-Printers. When I try printing the Libre document, I get a "Cannot start printer. Check configuration of the printer". The manual that came with the printer isn't that instructive but I've been through the prompts on the printer screen and I think everything is turned on.

1 Like

Hi jesselashcraft, I have always had Canon Printers and no other, be it Windows or GNU/Linux. What the modern kernel does is identify the printer/s correctly (not just Canon) but does not include a driver. You need to go to the Canon Website, specifically:

The download is a .tar.gz file - you need to extract the .deb by using Ark and will be the first option open to you upon right-clicking it. Extract it within the Downloads folder:

After you have downloaded the .deb package, open a terminal and enter:

sudo apt install gdebi

This installs the Gnome deb installer and will need a reboot of the system. Launch Gdebi and then select File and browse to the downloaded .deb file in your downloads. Open the root .deb folder and you will see 3 more folders - the one you need to open is the Packages folder and select the amd64.deb package. Once selected Gdebi will state whether all dependencies are in your system. Once this has been confirmed, select the install button - you will be prompted for your login password to continue as all package installations need 'root' privileges.

image

Then from a terminal (Ctrl+ Alt+ T t launch terminal):

sudo system-config-printer

It will bring up the same interface as 'Printers' from Settings, but will ensure a better installation of your printer (I speak from experience!)

Click on 'Add Printer':

Choose 'AppSocket/HP JetDirect and enter the following information in the fields:

Then select 'Forward' button, bottom right which brings up:

Select Canon and Forward again, this comes up:

Now scroll down until you reach TR 150:

Thought I had missed a step, but I had failed to do was install the .deb package! D'OH!

Even though it is a Pixma the newly installed driver comes at the bottom of the list - note it lists all the other TR Printers supported by the IJ Package - and why is it at the end and not under the Pixma Section? Remember, Canon does not work for Canonical, or GNU/Linux!

2 Likes

If selecting the printer in Libre doesn't work, you may need to run the IJ printer driver setup as outlined. If it's being hosted by CUPS, that would need configuring on the server side, as CUPS holds / provides the driver.

That is why I suggested the AppSocket HP JetDirect option. CUPS runs on port 631 with the server being the host machine 127.0.0.1. Have spotted duplicate image in my previous post. Will correct later.

Thanks for the journey. I was barely able to keep up with you but I must have hit every switch because I can print Libre documents with the UBS cord. Now my Settings>Printers looks like this:

Will I need the CUPS or Generic CUPS to operate the WiFi signal to the printer?

1 Like

I would remove / uninstall all the ones added that don't work and start fresh..

But:

Are you directly-connecting through WiFi - i.e., printer is hosting a hotspot 'network' and then connecting to that through your WiFi settings - or - are you using it on USB hosted through another computer / device to host the printer over LAN via CUPS?

Usually printers have a Direct WiFi connection option, or connecting to your WiFi through your router, then hosting itself through LAN.. It can get pretty dag-on complicated pretty quick - make a decision on if you're going to use locally attached to the computer you're using; or hosted through LAN / net-printing for all LAN users. That will be a little easier than trying a bunch of different stuff at once :smirk:

Also - make sure your system is all up-to-date: sudo apt update && sudo apt full-upgrade in terminal - or running Software Updater.

1 Like

OK. Everything is up to date and Settings>Printers is cleaned out. So I thought this Lenovo laptop with Zorin 16 and a Canon PIXMA TR 152 could talk to each other without anything else. Are you saying we have to tap into an existing WiFi signal to have this computer work the printer wirelessly? From here out, you should assume I'm in way over my head.

Not exactly - it may or may not have a WiFi-direct connection option, if not - then you would connect the printer to your home WiFi like you would a phone, laptop, etc. That does work in most situations but not all, as it goes.. WiFi-direct would be a little different - you would see a new network pop up in your available WiFi networks, probably named 'canon-something-or-the-other' which then you would connect to from your device (phone, tablet, laptop, etc.), then that would host the printer over its own WiFi signal.

The way mine is setup is hosted through a Raspberry Pi device, then CUPS handles the printing; which also holds the driver / configuration to share amongst other users when connecting and adding the printer. That's just me though - there are many different ways to achieve LAN printing. Wouldn't worry about that too much though; gotta figure out what's going on, why the printer isn't 'talking' with your computer :thinking:..

So - now that you've got it kinda all reset: with just the USB cable, plug that into your PC and take a look in Settings under 'Printing', add that printer again - but before doing anything further, after you add the printer, do you have this? (replace the HP with your Canon):

Do you have any options when selecting 'Additional Printer Settings' at the bottom? That should show something like:

Screenshot from 2023-11-30 15-44-33

If so, right click your Canon - select 'Properties' at the top, and you should get:

Screenshot from 2023-11-30 15-46-06

Something like that - what I'm interested in seeing is what's ~midway through for 'Make and Model', and if not correctly set - click 'Change...' and find the printer in the list. After setting that, if available - try some test pages and something from Libre or Firefox, just something other than the test pages from the printer itself. Might also want to do a reboot on the computer side after setting the driver if need be.

When I click on Additional Printer Settings then Properties then change as in your last picture, things freeze up. I have to force quit but the name in there already (TR150series) is OK so perhaps no need to go there.

We're so close to getting this to work. In the printer under LAN settings, the switch for wireless direct is on and I'm seeing the printer represented in the WiFi list as Direct_TR150series.

But I'm still unable to send WiFi print jobs to the printer.

Hm, that's weird with the freezing - not sure what would cause that. It may still be loading a long list; could be USB / WiFi conflicting can't be sure though..

So, going back to USB - try installing libusb-dev, sudo apt install libusb-dev, reboot, plug the printer in USB, and test again - not quite sure which one that would be in the list though lol libusb-dev helps with USB connections; wouldn't explain the WiFi-direct part. WiFi-direct printing may need an application to work. I've honestly never really used it but maybe twice in Win; needed an app..

What were the results of installing the IJ printing stuff - did any errors get spit out?

A long time ago on a Windows machine I was rebuilding, had an HP wireless printer, but you had to connect it by USB cable first to setup IP address on the printer. What does the Canon manual say about setting up wireless connection? Having just looked at Video on Canon USA site it looks like it needs a button to be pressed on the printer case to set up wireless connection before anything else. What happens when you do that? Another possibility is if your router has a USB port/s you could attach your printer that way.

1 Like

What were the results of installing the IJ printing stuff - did any errors get spit out?

Are you talking about information on the test pages? Under Network Diagnositics>Results it says: "There is no problem." That's the only information I understand on these pages.

I installed the libusb-dev and I can print documents from Libre now on the UBS cord. With the Wireless direct turned on in the printer and the WiFi set to the computer/printer signal, it still won't print from Libre or test pages. Yeah, when I get to "Additional printer settings" and "Properties>Change" it freezes up every time. Don't think it's still loading. It's hard locked. I have to force quit to regain control every time.

1 Like

The steps that @swarfendor437 posted, downloading from the Canon site and all - that was the Canon IJ print driver. That's the one I was asking if there were any errors on install. Which, seems to also be a packaged scanning app for the Canon printer stuff.

That's good though, but with WiFi printing I'm not sure, yet - could be a CUPS config issue / driver in CUPS.. Have you checked? Go to 127.0.0.1:631 and see if your Canon is there under 'Printers' at the top; then you can open the Modify Printer drop down option (where 'Administration' is) to see driver info. Just for the WiFi one, if USB is going good now that should be fine. The CUPS web GUI:

Then, after a few option windows:

The above post from Swarf - were there any extra steps to get connected to the printer? Just not familiar with those - well I had one, but long ago. The freezing, still not sure - I was able to find this though:
Screenshot from 2023-12-02 21-50-58

That's a Canon backend for their IP printing services - that may be needed for your WiFi printing. Could be the 'key' to it all lol

When you say go to 127.0.0.1:631, how do I get there? Is that in terminal?

Firefox / web browser

I've had some success but I don't know why. Printed a Libre document and a page off the internet with the WiFi signal.

I'll be trying over the next few days to see if printing becomes intuitive and reasonable.

It still totally freezes up when I tried the pull down menu under Additional printer settings>Printers local host>properties>Make and Model. Have to force quit every time. Would there be a Terminal command to erase all the printer drivers I must have downloaded the last two days so I can start over fresh?

To get to the 'modify printer' option:

On the main screen, click the printer in the list - mine's 'office printer cups', then:

and then the two drop down menus - use the right one and then click 'modify printer':
Screenshot at 2023-12-04 22-10-17

You'll be asked for your user / pass - use your current credentials for your login; that's for local CUPS config. If it were a server linked one on another machine, you'd enter that machine's IP:631 and then use the other machine's credentials for CUPS to do the rest.

Which:
Screenshot at 2023-12-04 22-27-58

Screenshot at 2023-12-04 22-28-13

There will be some other things before getting to the driver selection.