New MSI Win 11 Laptop (i7 1280P, 16GB ram, RTX 3060 GPU) won't load Zorin- suggestions appreciated

Hi all.
I've had Zorin on my 7or 8 yr old desktop for over a year and love it. Everything works and Big Brother is watching me just a little bit less (at least it feels that way). I have Firefox hardened and I sign in to nothing and up for nothing (with the rare exception of this forum). My paranoia (or advanced sense of humanistic individuality) means I only operate via VPNs through Switzerland or Germany and my phone is a decent spec Moto G7 running Lineage OS with zero google apps. I watch YouTube through alternative front ends like invidious and I use Protonmail and TOR whenever searching revealing political issues.

Recently (October 5) I decided to get the aforementioned new laptop with the intention to primarily run Zorin and perhaps run Windows 10 on a virtual machine for toying around with a hobbyists version of Solidworks or other CAD software (hence the high powered gaming spec machine).

The issue is I can't even load Zorin from a USB drive, the logo launches and the checks proceed but it freezes there.

Neither Try nor Install options work (with advanced NVidia drivers option ticked) and I suspect this may be due to one or more causes which I have struggled to fix. First suspect is the Secure Boot UEFI TPM environment forced on me by MSI and Bill Gates. A brilliant rant video (windows 11 must be stopped- Jody Bruchon Tech) alerted me to these issues. He predicted that soon there would be hard secured/locked down computers (like our phones and tablets) and I fear I might have been a $2000 victim of an early one of these. The MSI BIOS (they call it click BIOS) interface greys out the option to disable Secure Boot amongst many other greyed out "options". Even trying to boot an ISO of Windows 10 into a Virtualbox machine enters a death loop although I'm trying to install that without the compulsory Google A/C. Bizarrely, I managed to circumvent this mandatory Google Account sign up when activating the pre-installed Win 11 by utilizing a basic trick widely demonstrated on video sharing sites- however a shiver ran down my spine when an email arrived in my Protonmail from Google to say the Geo-region for my account had been changed. This spooked me as a> I thought I had successfully closed my Google account and the hotmail account ages ago and b> I most certainly never gave them my new email address. Yet now they mysteriously have it and have set me up an account by all reckonings. And they wonder why people are going all Ted Kaczynski and heading for the hills.

I don't like Windows 11. Even if the interface is pleasing from a design aesthetic point of view the total NSA/ Microsoft compulsory 24/7 surveillance is a chilling prospect- albeit one I was willing to suffer in a strictly limited way in order to use Solidworks. I live in Australia, btw and we've had our share of foundation shaking authoritarianism lately. Fair to say we most certainly didn't get the Sweden version of 'how to deal with C****d'. The spineless sheeple rolled over and threw away a giant portion of what remained of their (and, by defaut, MY) autonomy and freedom in exchange for safety (or the illusion of safety anyway). Aussies are gutless cattle stampeding to the new Techno-feudal prison state. Full convict circle in only 6 -7 generations. Nice one Australia.

Enough ranting. Second suspect issue could be around the graphics card.

A drastic solution might be to totally wipe the SSD, reformat the Disk to MDR and the Boot Loader to legacy BIOS then try loading Zorin, although I don't think this is necessarily addressing the probable cause which I'm sure is around the UEFI, boot loader, Zorin public key, TPM or some similar issue outside my knowledge base. Perhaps MSI's proprietary "click BIOS" interface is just too new to have been fully explored by many tech people out there. I'll look in to their Forum if they have one.

Monday, I'll make a call to the local MSI team although they'll probably either fob me off or tell me to send it in so they can turn off secure boot (they're not likely to disclose the way to do this to Joe public are they). If they want their expensive brick back then I'll be wanting my money back.

Thank you all (anyone??) who got this far, and thanks in advance for your advice and ideas.

Full machine specs: MSI Stealth 15M B12UE running 12th Gen Intel Core i7-1280P 2.00GHz, 16.0 GB Ram, 64 bit, NVIDIA GeForce RTX 3060 Laptop GPU

I will recommend you to follow this guide, this may help you to clear some windows settings that stays even after removing windows and causes ubuntu(Zorin) boot failure.

I would first make sure the boot medium is created in UEFI . Some USB creation software will give you this option when you make the USB. I built an MSI Win 11 dual boot Desktop last fall and if you plan to dual boot you need to research , UEFI , Secure Boot, Mok Utilities, and TPM. I have all these enabled on my system.

While you don't need secure boot enabled if you choose to dual boot you may need mok for the Nvidia driver update on the Zorin side. TPM will also need to be enabled. MSI boards have a legacy mode called csm if plan to run a Zorin only machine. I did a lot of research and watched many MSI bios videos when preparing for installing the operating systems.


Thank you very much for your answer.
It is truly great that you did this on your machine- Since you have achieved this I trust your advice as far as I can understand it.
Unfortunately I don't have the luxury of being able to commit hundreds of hours towards research- I'm not studying for a computer sciences degree- I'm just a trial and error guy with about 5% of the knowledge I should have for what I am trying to achieve.
Nevertheless I have taken your advice (esp "make sure the boot medium is created in UEFI") and tried the following:

I've made Secure Boot and TPM enabled again in MSI click BIOS
I've made another USB boot drive with the Zorin ISO this time I've used Rufus (instead of Balenor Etcher) and I've toggled the options in Rufus as follows: Partition Scheme to GPT (Not MBR), Target System to UEFI (Not BIOS) and I've tried the partition format as NTFS (not the default Fat32). Perhaps you have some knowledge as to whether these steps are appropriate.

When restarting with the boot option obviously set to go first to USB (not Win11 on the SSD) Zorin will not start and I get a screen in the Grub Terminal (or it looks like it). I will reburn the Boot ISO USB with a FAT32 file system (not NTFS) in case I toggled the wrong option there.

In any case, should I be looking to understand how to use a utility software to insert the Nvidia RTX3060 driver module into the bootloader and then how to sign a key to enable this driver to be trusted (a steep learning curve for me).
If I'm on the right path do you have some insight for a beginner. I'm happy for any leads even if you read this and your assessment is that I'm probably way out of my league.
I mean, if you yourself have done it on an MSI device, would you perhaps be able to find the time to list here even just a few of the steps you took and some of the learning resources you availed yourself of, for the benefit of the community and (rather embarrassingly selfishly of course) for myself?

Thank you very much for your time my good Wing-ed friend.

10 minutes of work, Hope it helps !

MSI Bios General Overview

CSM/Legacy mode No Dual Boot

Dual Boot windows 11 Guide GPT UEFI


Thank you for this- I truly understand how generous it is.
Unfortunately I'm still struggling to get the dual boot up and running.

My progress so far:
I am now quite familiar with the MSI 'click' BIOS including the Leftcontrol-shift-alt-F2 trick to bring up advanced BIOS options. My version of MSI BIOS looks different to the older red one all the YouTube videos seem to showcase yet its essentially the same.

I can burn an ISO image onto a USB drive, boot from it and set to install Zorin which I believe it proceeds to do onto a partition I created by shrinking the main volume in diskmgmt.msc Win utility.

I have been able to restart and bring up the main Grub menu with 4 options namely: Run Zorin, Go to advanced options for Zorin, Boot Win11 or UEFI firmware settings (BIOS menu). I can only get to here after disabling Secure Boot.
After selecting Boot Zorin I get held up with a terminal like cursor screen that indicates issues and failures. Bluetooth and USB drives seem to be mentioned across 20 or so lines of faults/issues. Then a blinking cursor with the only way out being a hard restart (power key for twenty seconds).

Alternatively I can get Zorin to boot in recovery mode (at Grub menu hit advanced options for Zorin and at the next screen select recovery mode). Although a big step it is only recovery mode and there's no WiFi- its only recovery.
At the previous screen I had the option to hit C which brings up the Grub terminal- however I have zero knowledge of what instructions to enter in Grub.

The second line of your answer draws my attention to the Dynamic Kernel Module Support and how the modules must be configured to work with secure boot.
Two of the three methods involve simply disabling secure boot which I am willing to do (at least until I learn more) and I have done this with method 3 (in the BIOS settings).
Do you think my boot issues are due to not having the full drivers for my GPU? If so do I need to download these from Nvidia to a USB drive, boot Zorin in Recovery mode and then run these in Terminal or the Grub shell terminal? When I installed Zorin I elected the option with Nvidia drivers which surely must cover the fairly common RTX3060 set?

I have some hope I will get this dual boot running but if I'm still lost in a few weeks time I might take drastic action and wipe the disk and install a Zorin-only system, however what I have experienced so far gives me no confidence that even doing that will be successful- all I will have done is wipe the one and only system which is actually working (Win11). Ideally, eventually, I will get a machine that runs primarily Zorin with an option to dual boot Win11 and virtual machines in Zorin running Win10 which the Solidworks CAD software requires.

One thing I won't do is be forced to spend $AUD 1,950 for a machine that spies on every aspect of my life. This is the "locked in existence" that Jody Bruchon and others vent about. I don't subscribe to the "life as a service" dystopia we are rapidly closing in on. I will resist it whenever I come against it.
I would rather sell this brick on the second hand market and suck up the $2-300 loss.

There are several things that may cause this.
I am also using a Nvidia 3060 without trouble.
However, I use Zorin OS Lite, Not Gnome. Lite uses LightDM, rather than GDM.
Let's first see if upgrading your drivers and reconfiguring GDM helps you.
You are able to boot into Recovery - so enter the Recovery Menu from the Advanced Options for Zorin.
Arrow key down to enable networking. Once enabled, back out to the Recovery Menu and arrow key to the bottom to Drop To Prompt.
tap the enter key...
Now, run:

sudo dpkg --configure -a

sudo dpkg-reconfigure gdm3

sudo ubuntu-drivers install

sudo apt update && sudo apt upgrade

sudo reboot

Test booting up normally and see if you are able to enter the desktop environment.

In terms of USB formatting this should always be set to FAT32. I seem to remember that Windows removed this option as far back as Windows 7 so you can only format to FAT32 using Gnome partition editor (Gparted). I have a USB stick with both GNU/Linux isos and Hiren's Boot CD using MultiSystem which can only be installed on an existing GNU/Linux OS.
I posted the tar.gz file on the old forum here:

Tutorial video here:

Because Hiren's Boot CD image uses Win10 sideloading iso (forgotten the correct term) if I want to boot into Hiren's I have to choose the USB UEFI option in the BIOS. If I want to boot from MultiSystem, I just tell the BIOS to boot from 'normal' usb entry. In my case the BIOS shows:


If you have CSM in BIOS you need to allow both UEFI/Legacy to be enabled.

Hope this helps.

I personally would create backup medium of Win11 if you really need it.
I am beginning to wonder if mainstream hardware manufacturers are starting to hardcode the CoA of Windows onto the board/boot sector of SSD that can't be removed, preventing installation of any other system.

Thanks for looking at this Aravision.
So able to navigate to and update networking as described.
After that Im not sure how to "back out" other then to follow through and re-start.

Alternatively while still in the Recovery menu , I can "Drop to root shell prompt" which is next option below network

So, doing that, I'm at root@d-Stealth-15M-B12UE:~#

At the prompt sudo dpkg--configure -a brings up nothing but not challenged

next: sudo dpkg-reconfigure gdm3 .......brings up......

gdm.service is not active, cannot reload

sudo ubuntu-drivers install.............brings up....No drivers found for installation

So: latest update. Can get into Zorin recovery mode but

When booting into Zorin (not recovery mode) I get about twenty lines seemingly repeating the same namely:

Bluetooth: hci0: Reading Intel version information failed (-22)
Bluetooth: hci0: Intel Read version failed (-22)

and several similar like:

usb 1-10:device descriptor read/64, error -71
usb 1-10: device not accepting address16, error -71

with the blinking cursor of death.
Only a hard shut down seems to get me out.

Restarting would undo anything you have done.

That means it went through.

Hmmm, yes. I failed you on this one. That command should be run from the Desktop Environment... I guess running it prior to initialization cannot be done.
However, dpkg--configure -a is Configure All, so I think we can safely consider GDM reconfigured for now.

This may have happened if networking was not enabled.

These should not cause the issue unless you are using a USB attached Monitor...

From the Grub Menu, are you able to tap the e key to enter the Editor for Grub?
If so, that should bring up a screen that looks like this:

arrow key down to quiet splash and add the parameter nomodeset. There should be One tap of the space bar between the end of splash and nomodeset.
Once done, tap ctrl+F10 to proceed to boot and test.

Thank you for the valiant efforts in helping me. I feel quite inadequate RE my abilities to navigate this issue.
It seems with my MSI Stealth 15M they have made a laptop which is effectively, to everyone other than the most sophisticated computer literati, locked to Windows.

I went into the Editor (hit e at grub menu) but I didn't have the information as shown.
Essentially all I had inside the bordered box was:

setparams 'UEFI Firmware Settings'


Also, sorry to cause confusion- I realise now that when I installed Zorin from the USB ISO I probably didn't choose the option with advanced Nvidia graphics. I had been trying different combinations of approaches and found that loading 'with advanced graphics' had produced a stalled load (just the MSI logo and a glowing Zorin logo).

Loading without graphics at least got me as far as actually having a grub menu and a recovery mode- for what it has been worth!

Again. Thanks all for your time.

I will try ringing MSI Australia today and asking them directly how I can install an OS other than Win11 and if they brush me off I will list the book on Gumtree (Aussie site similar to Craigs List).
I paid AUD $1950 (approx USD $1227) but quite frankly I've gone to great lengths to rid my life of condescending and dystopian state and corporate intrusion that I will take whatever someone offers me for this horrible brick. US $1000 anyone?

I rang MSI today.
They deny they lock the machine to Windows and they claim that they are clear in their advertising that it has a Windows operating system and this is the only OS they will support.
At what point is the inability to change OS away from Windows considered a de-facto Windows lock-in?
I've tried and the community here have tried to help including extensive detailed instruction (thank you Aravision) yet it seems beyond possible.

So Locked/ Not locked- it's all semantics.

On an interesting aside vis a vis this sort of Orwellian doublespeak when ringing MSI they play a recorded message about privacy. The first sentence is something along the lines of "....we value your privacy and the security of your data...." yet straight after that they say words to the effect ".....we record this conversation for tracking purposes...".
So......statement... followed by immediate contradiction.

I'm just a humble middle aged blue collar worker- I can't fight this. Like all of us under this new world order I am trying to cope with declining living standards, increasing job insecurity and an ever heavier state intervention in my life.
If I can see what a horrible future we are in store for then I have to wonder- where are all the brilliant legal minds, the philosophers and the ethicists sounding the alarm and challenging this nonsense. They don't exist. Lonely voices are shouted down and attitudes and opinions are forcibly changed- usually before they are even mature enough to form a clear opinion on freedom and human autonomy.

Something else sinister and telling from my phone call to MSI- the tech guy stated that according to the serial number I am running a Stealth 15M. I had gone to great lengths NOT to disclose this at any point. I bought from a bricks and mortar retailer, walk in off the street, no phone number given, invoice made out to my company, no email addresses or registrations or such like ever entered.


Bet my little rant to them about commerce commission and newspapers and office of Fair Trading has landed me on a list somewhere.
What a disaster.

There are those that speak up. Some in powerful positions, too.
The reality is, no one, no matter how rich and powerful, no one can do it alone.
To protect or to evince change, one needs strong public support.
And part of the trouble is that the public... Well... I made a rant not long ago on this forum about it.
It's easier to not burden oneself with troubles you feel powerless about.
We live in an age that markets "easier" to us. "Ease" and "convenience."
As I am sure you know... To get more money, you need to take more control.

We can see this occurring now, in Linux. We can see it having been started years ago.
We can look at the past and see all the warning signs and red flags.
And... We can see the many, many people who spoke up in protest over the years.
Silenced not by the rich and powerful... But by time of their warnings falling on Deaf Ears.
As the general majority of users did not care about any of that, only about making things Easy on Themselves.
The years of Microsoft, Google, Facebook and the rest pushing the concept of easy on people... it worked. Like a charm.
We are naturally inclined to prefer the easy road. They just exploited it, is all.
No conspiracy needed. No grand plan. No careful manipulation... just base-level exploitation of Human Nature.

well... back on topic:

It's hard to say. The Safe Graphics option, if it was shown, would be the same as the e then nomodeset parameter.

I did try searching using a large variety of search terms when I found this little post:

However, I can now happily report that I finally managed to get the system to boot without any problems and run smoothly. The problem seems to have been that the graphics card was plugged into a PCIe slot that MSI calls “PCIe Steel Armor” (also described as “Lightning Gen 4 PCIe” ): At first I didn’t even recognize this as a PCIe slot, as it seems to have a silver cover. However, as soon as I had switched the card to a “normal” PCIe slot, all problems were gone immediately - even those that didn’t seem to have anything to do with the graphics card (I was even able to plug my tablet back into the USB 2.0 slot.)

Maybe this might help you? I have no idea. It would go hand in hand with the Manufacturer usurping control in order to prioritize a hardware benefit for Microsoft Winders.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.