No audio from internal speaker (HP Elitebook 860)

Struggling to get audio from internal speaker but ... no sound :frowning:

Some info ...

Operating System: Zorin OS 16.2
Kernel: Linux 5.15.0-58-generic
Architecture: x86-64

sudo lshw -C sound
*-usb:0
description: Video
product: HP 5MP Camera
vendor: Chicony Electronics Co.,Ltd.
physical id: 1
bus info: usb@3:1
version: 0.09
serial: 0001
capabilities: usb-2.01
configuration: driver=usbhid maxpower=500mA speed=480Mbit/s
*-multimedia
description: Multimedia audio controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_hda_intel latency=64
resources: iomemory:600-5ff iomemory:600-5ff irq:147 memory:603d1c8000-603d1cbfff memory:603d000000-603d0fffff

uname -a
Linux elitebenz 5.15.0-58-generic #64~20.04.1-Ubuntu SMP Fri Jan 6 16:42:31 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

With external headphone, no problem :slight_smile:
thx!

Bennolo

See if comment at end of this post helps:

or this one:

thx for your reply, done that but ... no, still no audio from internal speakers

If you're getting audio output on external headphones, your sound card is working... it could be that the headphone jack isn't reconnecting the speaker when it's unplugged.

Older jacks had a little switch that was pushed aside (just a metal strip) that disconnected the internal speaker. Newer ones do it digitally. If you have an older jack, you might try spraying a Q-Tip with contact cleaner and swabbing inside the jack.

If it's a newer one that connects / disconnects the speakers digitally, I'm not sure how to proceed, but there's a command that'll do it. You'll have to peruse the developer's manuals for your sound card or computer.

It could also be that your internal speaker has died (either the coil is shorted or open-circuit, or the driver magnet has rusted in its tube and cannot move, or there's so much dust at the back of the speaker that it's impeded in movement)... if you can, take the machine apart, disconnect the speaker leads if you can (there should be a tiny plug you can unplug, or the speaker will have spade connectors), get a 1.5 V AA battery and some test leads, and repeatedly connect/disconnect the battery to the speaker terminals... if you hear it clicking as you do so, the speaker's still good.

Before erasing windows, internal speakers worked (in winz) so I think it's some kind of weird driver issue, beyond my knowledge :expressionless:

Gday @Bennolo ,
Yes with a clean install it may take a few updates/ adjustments.

Without headset plugged in,

Try running the software & updater, click " settings" at the bottom & select the Additional Drivers 'Tab',
After update, Reboot pc.

Then try installing ' pulseaudio volume control ' from the 'software store' app.

Open pulse,
In the output 'Tab" , make your internal speakers " set as fallback'.
In the config 'Tab' make the profile set to " Analogue stereo Duplex".
Reboot & try,
Other thing's,
New app's installed,
Open ' Startup applications', & disable thing's like " Zoom" or Messenger app's etc.
Let us know how it goes. :+1:

Try hdajackretask.
Its in Zorin software. Also helps if you have a headphone jack stuck in the port. Like me....

done all ... no difference :confused:

1 Like

installed hdajackretask but need some hint on how to use it ... gonna study doc

Try:
pactl set-sink-volume 0 +20dB

If that doesn't work, try:
amixer -D pulse sset Master 10%+

It might be that your speakers are just turned down, and the GUI isn't changing their volume.

still no sound :expressionless:

If you type alsamixer, do you get an interface where you can alter sound settings? Mine doesn't have anything that can be changed, but yours might.

Also pactl list sinks might reveal something.

yes, i get the interface and i'm able to change values ... but still no sound

Ok, we'll check the hdajackretask route. I assume you've already got alsa-tools-gui installed?

sudo apt install alsa-tools-gui

hdajackretask

Ensure your sound card is selected, then toggle the speaker to 'Unconnected', then 'Show unconnected pins' and select one of those pins as the speaker output (override), then click 'Apply' and try it, ensuring your speaker volume is up. If that's not the right pin, try again with another.

Might be a good idea to have a movie or music playing the whole while you're doing the above... as soon as you get it right, you'll hear your speakers.

If all else fails, toggle your headphones to 'Unconnected', then connect the speakers to that now-unconnected pin.

In alsamixer have you tried unmuting, by typing "M" at channels marked [MM].
Also if Auto-Mute is set "Enabled" try changing that to "Disabled"

Override the internal speaker to internal speaker and the headphone to not connected.