No Audio on the speakers!

My machine is HP Pavilion 27-ca1701ng, Intel 12th Generation, i7 12700T, soundcard detected, HDA-Intel HDA-Intel PCH, Realtek ALC 274 and there is no sound on the build in B&O speakers.
Bluetooth Headphone are still in function and O.K.!
I tried pavucontrol, after that alsamixer and hdajackretask, no success.
Over the headphone jack i can only hear, with a normal headphone, a very,very low and crackle signal.
After all i tried the command: echo "options snd-hda-intel model=dell-headset-multi" | sudo tee /etc/modprobe.d/headset-jack-microphone-fix.conf, but also no success!
Any help are welcome!

Nice greetings from Cologne, Germany,
Achim

1 Like

I know it is a different model but see if any of the suggestions in this Linux Mint thread helps:

https://forums.linuxmint.com/viewtopic.php?t=329074

What did you see when you opened alsamixer in terminal?
Can you do that again, hit [F5] to show all channels and post a screenshot of that display so we can spot anything from that for you.

Note, as you have ZorinOS Pro edition, you are entitled to support from the Zorin devs. However, as there are just the 2 of them, they may take some time to respond. You are probably better seeking help here from other users here on the forum.

I assume you have seen this "Help" page: Set Up Sound - Zorin Help

Hello zabadabadoo,

i wrote to the support and get some answers, but no success, they can't help me this time, because they have no solution for my problem!
Here you can see the screenshot after i start alsamixer.

Nothing obvious wrong with your alsamixer.
Maybe just have a play around with those channels showing as "MM" = muted e.g. Headphone. Unmute them (by selecting then type "M") one at a time just to see if anything happens.
Sometimes random/illogical changes in sound settings produces good result out of the blue.

Only other thing I would ask is. Hit [F6] to show sound cards. Do you have more than one listed?

Hi,
here are the actual settings, they are all unmuted!
You can see, there is only one Soundcard.

Sorry, forgot the screenshot...

Did you take a look at the link Swarf gave you in post #8 No Audio on the speakers! - #2 by swarfendor437

Yes, i did, but no success.

Since your computer is pretty new i would suggest a live test with pop os. Pop os uses a higher kernel (6.0.12) and might have support for your sound. If that did not work you might try manjaro live or endeavour os. I believe arch based distros are on kernel 6.1

Happy new year to all of you,
i tried Pop OS: no success.
i tried Manjaro OS: no success.
i tried Endeavour OS: no success.

But i found something on 216139 – No sound from built-in speakers HP Pavilion All-in-One Desktop 27-ca1xxx (ALC274)
So i think, i have still waiting for solution to resolve this problem!

Thanks a lot for the help,
nice Greetings from Cologne, Germany,
Achim

I think the reason for this problem are the built-in speakers from B&O, something with the drivers (maybe the speakers need there own drivers?), or the handling between the Sound Card and the speakers, or the AMI Bios!