No desired screen resolution

Hi. I have a 1280x1024 resolution monitor. After installing the driver for my Nvidia GeForce 9500GT graphics card Nvidia 340.108, this resolution is not available in the settings. The closest I can get is 1280x800. How can this problem be solved?

Can you please post the output for



sudo lshw -C video


Tue Jan 2 21:15:56 2024
| NVIDIA-SMI 340.108 Driver Version: 340.108 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce 9500 GT Off | 0000:02:00.0 N/A | N/A |
| N/A 39C P0 N/A / N/A | 302MiB / 1023MiB | N/A Default |

| Compute processes: GPU Memory |
| GPU PID Process name Usage |
| 0 Not Supported |

description: VGA compatible controller
product: G96C [GeForce 9500 GT]
manufacturer: NVIDIA Corporation
physical ID: 0
bus information: pci@0000:02:00.0
version: a1
bit: 64 bits
frequency: 33MHz
features: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: IRQ:25 memory:df000000-dfffffffff memory:c0000000-cfffffffff memory:dc000000-ddffffffff ioport:ec00(size=128) memory:c0000-dffffffff

(Translated into English through a translator)

1 Like

If you tap alt+F2 and run nvidia-settings
In the Settings Window under the X server Display Configuration are you able to set your resolution from the drop down menu?

Are you using Intel Integrated Graphics alongside or is it solely running on the Nvidia card?

No, i can't

No, only Nvidia card

In terminal, run


Get your Display I.D. For example:

DP-0 connected primary...

In my case, DP0 is my monitor.
Use newmode and addmode (you can use 75 Hz if that works better)

xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode DP0 1280x1024_60.00

Once done, try adjusting the resolution from the app menu > Display application.

When I type "xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync" an error occurs:
X Failed request error: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Failed request minor opcode: 16 (RRCreateMode)
Serial number of failed request: 29
Current serial number in the output stream: 29

While the 340 seems to be the supported driver on that card, it looks like it lacks full support.
Just in case that newmode is already added, try running the xrandr --addmode DP0 1280x1024_60.00 command... it won't hurt anything to try running it.

X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 29
Current serial number in output stream: 30


Are you on Zorin OS 17 or Zorin OS 16?

If on 16:
Let's try manually adding it...

sudo touch /etc/X11/10-monitor.conf

sudo nano

Copy the below and paste it into the file accessed above:

Section "Monitor"
    Identifier "Monitor0"
    Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1280x1024_60.00"

Tap ctl+o to overwrite, then enter to save configuration. Tap ctl+xto exit the editor. Reboot. Upon reaching the desktop, openDisplays` and see if you are able to select your preferred resolution from the drop down menu.

It's not working

I fear that graphics card may be too old... But let's look into this further in case we can still find a solution.

Maybe this will help in some way, but on HDMI this resolution is there. Only there is no way to use HDMI all the time

May I ask why this is? Is this a notebook computer - and the monitor is external?

monitor is external

I just need top clarify this...
If the External Monitor is connected using HDMI, the resolution is present;l but not present if it is connected by VGA or DP?
The resolution is there on the external monitor with HDMI, but not present on the Notebook computer built in screen?

If the desired resolution is present on the monitor with HDMI, this means that the drivers and software are working properly.

I have an ordinary PC without a built-in monitor. It turns out that if the monitor is connected via HDMI, the resolution is present, if it is connected via VGA, it is not. There is no DP on the video card. There is DVI, but I can't say anything about it.

Very strange behavior of VGA, although everything works fine on Windows

1 Like

I see. It may be the cable... But that the HDMI is working tells us that the drivers are working.

You may need to invest in an HDMI cable for regular use.

1 Like

Already ordered an HDMI to VGA adapter. There's no other way to do it.

Thanks a lot for your help

Ah... Yes my old monitor was VGA only and I needed to use an adapter (VGA > HDMI) for a while.
It worked, except that i ran into a very strange issue that if I ran a theme that used the color #555 in a background color, the monitor would blink when moved a window onto or off of it.
VGA monitors - they can be finicky.

1 Like