No Grub, unexpected issue using boot repair

Greetings, Happy New Year.
Helping a friend with Zorin 15.3 single linux O/s (not win dual) lost grub.
Boot repair's request to add commands to Terminal resulted in this:


@zorin:~$ sudo dpkg --configure -a
zorin@zorin:~$ sudo chroot "/mnt" dpkg --configure -a
zorin@zorin:~$ sudo chroot "/mnt" apt-get install -fy
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
grub-efi-amd64-bin grub-pc-bin grub-theme-zorin
linux-hwe-5.4-headers-5.4.0-90 linux-hwe-5.4-headers-5.4.0-91
linux-modules-5.4.0-90-generic linux-modules-5.4.0-91-generic shim
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
zorin@zorin:~$ sudo chroot "/mnt" apt-get install -y grub-efi-amd64-signed shim-signed linux-headers-generic linux-signed-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-generic is already the newest version (
linux-headers-generic set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
shim-signed : Depends: grub-efi-amd64-signed (>= 1.167~) but 1.93.24+zorin3+2.02-2ubuntu8.21 is to be installed or
grub-efi-arm64-signed (>= 1.167~) but it is not installable
Depends: grub2-common (>= 2.02-2ubuntu8.23)
E: Unable to correct problems, you have held broken packages.

Have briefly surfed for solutions but am reluctant to go adding various commands when i am not sure what I am doing.

Thanks for anyone who can dig me out!

1 Like

Have you tried booting into LiveUSB and using Grub Repair?


Sorry, my fault, I AM using live disk and , did you mean boot repair?
Might try the terminal method that article suggests though, so cheers for that.

Boot Repair and Grub repair are the same exact thing. Crawdad, crayfish...

1 Like

Watz crawdad!

Anyway, nope, the terminal link was a no starter.
Exactly the same result as one I tried earlier.
The ref to i386 pc confuses me.

zorin@zorin:~$ sudo mkdir /mnt/ubuntu
zorin@zorin:~$ sudo mount /dev/sda2 /mnt/ubuntu
zorin@zorin:~$ sudo grub-install --boot-directory=/mnt/ubuntu/boot /dev/sda2
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.

1 Like

Ha Ha.
crawdad = crayfish.

Just Aravisian's way of illustrating
grub = boot.
same same.

Are you using ext2 filesystem and why?

1 Like

Well now, you ask an exceedingly good question!
Seems so- according to boot repair!
But in reality is was loaded as ext 4 and, funny enough DISKS - system tools, - shows it as that
So that also confused me, along with i386 system when it is a 63bit set up.

1 Like

How can I cleanly and safely remove partition 3?

SORRY: A better question would be can I use Gparted to delete it?


1 Like

Yes, you can select the partition you wish to remove as long as that partition is unmounted, in gparted, then click the (-) delete button.

1 Like

just looking for a sounding board - unlike my own system this has an efi partition. As I understand it, this is for bootloader? Yes?
So would grub go there?
If so, would I need to reflag it?
Currently it is set as boot and esp.
Should it be set to grub bios?

No hurry, somehow I have crashed my own sytem trying to do this so I need to leave here and try get that back up and out of eternal emergency mode.
Not my best day today.

1 Like


No, grub goes in /boot

The rest of your questions are more dependent and I either have forgotten or do not know the answers to some details; dual boot - what with if so...
However, using the Boot Repair Utility is much Safer than trying to manually configure. Do you mind if I ask why the utility is not an option for you?

1 Like

it's not dual boot, pure Zorin.
I have been at this all year so,a picture is worth 1k words:

Ahh, sorry, is on my own machine whihc I can't access now.
So, hopefully in less than 1k words -

Boot repair requests 3 commands via terminal, the last fails with a series of statements ending in holding broken packages.

Boot repair responds with something about grub still not present, try again, we can play this game for hours.
Screen shot soon.

1 Like

1 Like

The repair utility saves a log file that you can link to here or with pastebin

1 Like

sorry @Aravisian I am so way out of my depth here.
Can I ask please; the efi file is marked FAT 32, /mnt boot, flagged as boot and esp.
1/ should I remove that flag?
2/ Should I reflag sda2 as boot grub - it is, despite what boot repair says, marked ext4, /mnt boot.

1 Like

Yes, but as the tool closes it seems no file is made.
I will check it again.

1 Like

This isn't enough information to know how to answer for me... What is on sda2?
And Secure Boot is disabled in BIOS Settings, right?
Did you install Zorin as Legacy?

1 Like

here is the link: Ubuntu Pastebin

Zorin 15.3 is on sda2

I believe secure boot is disabled, I need to close down the live disk to check now

and I also believe it was installed as legacy.

It was originally Win 7 one of our team machines, I wiped the disk and installed Zorin shortly before Win 7 became unsupported.

1 Like

You can check this in BIOS Settings while checking Secure Boot. The computer may be EFI capable, but if you installed as Legacy, MBR, not EFI, will manage boot.

1 Like

It gets worse.
Attempting to access BIOS fails.
It used to be either F2 or F12.

Start up begins with the ACER logo, then, no mater how fast I am we get:
error: file "/boot/grub/x86_64- efi/normal .mod" not found.
Entering rescue mode
grub rescue> -

I am very confused right now, but I can't help feeling that if I can install grub 2 into (where) sda2) - then boot repair will work. Currently it seems there is no grub to repair?

Also, unless I dreamed it I am certain sure that using the live disk set up here used to have "system set up" as an option to the test, install Zorin etc- THAT used to lead to BIOS.

Unfortunately my own desk top is now in emergency mode- I don't have time to deal with that yet so I can't look and see what that set up was. Although a totally different machine so probably apples and oranges~

1 Like