No hibernation for me?

I followed two guides about hibernation I found here ([HOW TO] Enable hyberneation in Zorin and [HOW TO] Enable Hibernate Option on ZorinOS 16 or other Gnome distros), my swap should be enough (25GB for 16GB RAM) but hibernation does not work for me. It does not appear in the Power Button Behavior options and while it does appear among the options in the "Simpler Off Menu" extension, it does nothing. Running pm-hibernate also does nothing.

Does this mean my system is not capable on hibernating from Zorin?

Please double check the step here:
"resume=UUID=<your_swap_UUID>"
This is the most likely cause.

Your hardware very likely supports hibernate.

Well, you were right that that line was not correct, it was missing the =UUID part, but even after adding that and doing sudo update-grub the Hibernate option and pm-hibernate still do nothing and I still don't have the Hibernate option in Power settings.
Now that resume line is like this (and, as far as I can see the guide, it should be correct)...
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=2682c5fa-0d8b-4a82-b3e0-d1d57207bc6d"
...and that UUID is that of the swap partition.
Screenshot from 2022-06-24 12-46-49

Please check the status of swap; that it is enabled and in use:

swapon -s

Did you enable hibernation policy?

Swapon shows this.
Screenshot from 2022-06-25 11-39-00

By enabling hibernation policy, do you mean creating and populating the file /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla ? I did that as part of following boldos' guide. Or is there something further to be done with that?

Hmmm...

Neither of the above mention the step number 5 (creating the file /etc/initramfs-tools/conf.d/resume) mentioned here:

Now I also followed that guide, but when I do, as the guide says, sudo systemctl hibernate, I get the error "Failed to hibernate system via logind: Sleep verb "hibernate" not supported".

Do you have Secure Boot enabled in your BIOS settings? :neutral_face:

Yes, I do (I'm dual booting Win11, so that's required).

I ask because Secure Boot may be the cause of Hibernate not working.

Oh, I see... it's a shame, but it is what it is, then. Thanks for trying to help.