No internet (LAN) on wake - didn't used to occur

Hello

Recently, my Zorin OS 16.2, has no internet connection when I wake it from sleep.

This has started happening as of the last week. I haven't made any hardware changes, nor anything significant software-wise.

I can't find a way to fix this when it happens, so I have to restart. When I do this, it works again.

Can anyone help me please?

Thanks a lot.

Can you run

sudo lshw -C network

in the terminal and return the results?

Here you go:

*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 0c
serial: 40:8d:5c:7f:17:fe
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.15.0-53-generic duplex=full firmware=rtl8168g-2_0.0.1 02/06/13 ip=192.168.0.15 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:31 ioport:d000(size=256) memory:fe900000-fe900fff memory:d0000000-d0003fff

Can you please run:

sudo apt install --reinstall r8168-dkms

This may be all you need to do. If not working, please relay the results.

Further reading:

That hasn't worked unfortunately. As soon as I put my computer to sleep (straight after doing this procedure), it woke back up to no connection.

I'm not sure if this may be helpful; these are the results when trying to ping Google:

Screenshot-20221203195456-582x164

Whilst I have you, I noticed that you linked me to an Ubuntu site. When searching issues, am I best searching for Ubuntu e.g. "no network on Ubuntu"? I usually search for Zorin-related articles. I'm not too clued up on all this, but I think Ubuntu is a broader pool of users isn't it?

Thank you!

Zorin OS 16 is based on Ubuntu 20.04. It can be very helpful to broaden your search to Ubuntu 20.04.
There are some pretty big differences... For example Zorin OS uses some packaging and a much higher kernel than 20.04. But for most things, the search should be just fine.

There are times that you can also spread that search to Debian, as well.
At first, you might feel like you have no idea which would apply. Don't sweat it... As you become more familiar with which packages came from where, it becomes easy and straightforward to broaden or narrow a search.


Are you using any VPN or Proxy for your connection?

Did you have this issue previously or did it only begin to be an issue after a kernel upgrade?

Thanks for that info. Can I just ask how you know (how I could check in future) which version of Ubuntu my version of Zorin is based on at any one time please?


Yes, I use Nord VPN.

This is a new issue. It started happening within the last week or so I think. I'm not sure what you mean by Kernel upgrade, sorry. Apart from doing the software dates that pop up and sudo apt install / sudo apt upgrade, I haven't messed around with anything that I would image could affect my connection.

Zorin OS aims for stability so is always based on the Long Term Support (LTS) release. These are the even-number and .04 Ubuntu releases.
Zorin OS 12 was based on Ubuntu 16.04 Xenial.
Zorin OS 15 (13 and 14 were skipped in order to restore the numbering system due to two separate Interim releases Zorin OS had long ago) was based on Ubuntu 18.04 Bionic.
Zorin OS 16 is based on Ubuntu 20.04 Focal.
Zorin OS 17 (Not yet released) will be based on Ubuntu 22.04 Jammy.


Please see here;

The drivers for Networking are not (always) included in the kernel. This means that the module for controlling that driver must be enabled to the kernel you are using.
In order to solve that, we use DKMS (Dynamic Kernel Module Support) so that upgrading the kernel does not require changing out the driver every time you get a new kernel.
A new kernel could be included periodically in the Zorin OS Upgrades... You won't necessarily notice or actively upgrade the kernel itself.

If your networking stopped working, rolling back to a previous known working kernel may solve the issue.
I think yours is working, since it only fails after wake from sleep... But it may not be fully working - I suggest checking the issues with NordVPN, first. We have not verified a kernel change at the time this problem began.

Thanks. I don't have the killswitch enabled (I disabled it a while back, as it caused me issues that I forget now, but basically it made it a hassle to log into it when I had to, due to aforementioned issue).

Do you have any more tricks up your sleeve please?

What have you tried so far? I mentioned several things in the previous post. I also do not know if you have current NordVPN installed and running - or if removing some of its blocks

has been or needed to be done.

Hello

I've tried everything you've said so far. I did reply, saying I have Nord VPN running, but you may not have seen it.

I've ran the last command that you recommended, but the result doesn't look like it's managed to achieve anything:

image

Thanks a lot.

There are so many threads and posts that i often feel like a head running around with my chicken chopped off.

ProtonVPN is known for a variety of configuration files are actions that can affect Wifi Performance and function.
This is almost necessary, since much of the process is automated.

What you have before you becomes a topic of

  • Should the user have to make a choice in order to use what they want to use?
  • When helping a user try to resolve issues; is it "ok" to recommend them using what they want to use?

These are really tricky questions.
My own personal stance is: I do not use VPN's. They do very little in regards to protection of privacy in reality since your ISP can still see you just fine.
The reality is that Google, Facebook and your ISP are the actual Primary Concern when it comes to privacy. Everyone else is negligible.
And VPN's do pretty much nothing to stop those three.

The concept of Privacy and Online Protection has become marketable and a strong method of boosting sales and profits. Even an illusory shield seems preferable to no shield at all.

VPN's can be very useful in certain countries that have restrictive internet access. I will not name those nations; those that live there usually know fully well they are in one.
If you are not in one of those - it leads to the question of: Should you use a VPN at all?
If it works and it gives you peace of mind in some way, then sure. Why not.

But if it just is not working or is causing you headaches, then is it worth it?
Probably not.

These are questions that only you can answer. You know where you are and what your needs are. One option would be to fully remove the ProtonVPN application and its configuration and restore your wifi performance - even if temporarily while exploring your options.

Hello again

It's not Proton, it's Nord VPN. Everything I've read about VPN's says that they do encrypt data, so your ISP cannot see any of it. I use the VPN for a variety of reasons and wish to continue with it.

Regardless:

  • This is a new issue (I have always had the VPN on and it worked fine up until the other month)
  • I have completely disabled the VPN, but the problem still occurs post-sleep.

I spoke to Nord VPN support; it worked!

"The issue you are experiencing is currently known to our developers and should be fixed with a later release, for the time being, please use this version of the application:"

sudo apt autoremove nordvpn
sudo apt install nordvpn=3.15.0