No Internet

Hello I have had Zorin OS 16 pro for a few months and had no issues. Today I ran an update and I now have no Internet. Either WiFi or wired through a cable. It is not my home internet as my phone works fine using my home WiFi. Can anyone help?

First thing I would try is your previous kernel.
From grub menu select Zorin Additional Options and choose previous kernel (generic) and see if internet is back.

1 Like

3 posts were split to a new topic: Internet stopped working after updates

Mikhee, I see you are on 5.13.0-44; Have you tested @zabadabadoo 's suggestion of testing an earlier kernel?


I cannot open grub on my PC. I have tried pressing the left shift key on boot for an hour yesterday but no avail!

Left shift key is for Legacy (MBR) boot.
Try tapping the esc key or the tab key (Probably is the esc key) when you see the motherboard and the Grub Menu should appear pretty easily.

Hi none of those buttons seem to work. I can boot into Bios if I press f2 (Toshiba satellite). It boots UEFI.

Can you check your grub file:

cat /etc/default/grub

And check this line: GRUB_TIMEOUT=15
What is your timeout set to?

Mine is set to 0

This should not be set to "0". And you have just discovered why.
When you need to access the grub menu, it timesout far faster than you can reach it.
Please set it to "10".
Once done, ctrl+x to exit, then the y key and then enter key.
Run sudo update-grub to make the changes take affect.
Then try rebooting and testing reaching the grub menu using the esc key.

Ok all done and chosen the previous kernel. I still don't have Internet sadly

Is this a Notebook computer? Some of them have a Physical Switch on the case of the computer that disables the internet. Can you please check this?

Hi no my laptop does not have a button for the Internet. It also does not work with a ethernet cable.

Product: RTL8111/8168/8411 driver=8169?
Can you try:

sudo apt remove --purge r8168-dkms

sudo apt update && sudo apt install r8168-dkms

sudo sh -c 'echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf'

Hi when I run it keeps trying to connect to However I have no Internet so it keeps trying but it can't connect

Can you use your Mobile Phone Hotspot?

Hi that doesn't work either. Is there a file I can download to another pc that I can transfer to mine?

Yes, you should be able to download the .deb file:

Then transfer to the pc you need to install on to.
Launch the .deb file to install.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.