No sound, AMD hp elitebook 845 G7, zorin os 16.3 core

I haven't been able to get any sound out of internal speakers for two or three days, when I connect to a tv through hdmi (which I use every day as a teacher) sound is fine, but nothing from the internal speakers. I have gone into the settings - tests show the audio is working, and looked through the forum, but have not found any solutions.

Uploading two photos from my terminal with commands I have seen others asked to run. I don't know what to do with the information these commands show.


This following thread has a user with the same issue on Zorin OS 16.3
If you are also on Zorin OS 16, can you follow the instructions in this post:

If you are on Zorin OS 17, instead run:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-6.6.5

@Aravisian See title: "No sound, AMD hp elitebook 845 G7, zorin os 16.3 core"

@Scotty_p Did the problem only occur after doing a software update. i.e. new linux kernel?
If true, try booting with the previous working kernel via Advanced Options menu item

I have already replied to those two pictures on another thread - the audio is 'unclaimed' which means there is no driver for it - the only OS that supports that hardware is Fedora 37 using Pulse Audio with Pipewire - it does not work on any other OS, not even Ubuntu 22.04 on which Zorin 17 is based. I am aware that you have stated in this thread it is Zorin 16.3, but the fact remains, youir Raven/Renoir sound chip only works with Fedora 37.

This is the 3rd thread concerning the same sound card in recent days. Here is the second, I will hunt for 1st. (EDIT. I have added that thread at bottom of my post)

This is Swarf's reply

I trawled the web for solutions and found none, except get a USB sound card as workround.

The other thread I was thinking of:

I get this after selecting 6.3.. upon reboot

I do not understand, sound was working two weeks ago, how can fedora 37 be the only OS available? I also tried booting in 5.15.0-89-generic and the sound did not work then either.

I also went through these threads and didn't find a solution - have never distro hopped but was thinking of trying fedora.. would rather have a solution inside zorin, however... planning on upgrading to 17.

Do you have Secure Boot enabled in BIOS settings; or are using the Unsigned 6.3 kernel?

I don't know, how can I check?

helpful?

You can check in your BIOS Settings under the security tab. Accessing the BIOS Settings depends on your manufacturer, but it is usually one of the F keys pressed at boot.

If you are not dual booting with Windows, you can disable Secure Boot in the BIOS Settings, then boot up Zorin OS and test.
You screenshot above also shows you have a firmware update available for the motherboard. Highly recommend you upgrade your motherboard firmware.
The below answer addresses this using a Dell computer, but the information on using fwupdmgr is the same:

Many people just use a LiveUSB of Windows OS to do it:

I disabled secure boot, booted with 6.3 kernel, still no sound, haven't done the HP BIOS update yet, will that affect sound?

Yes, a BIOS update can affect sound if your sound card is integrated with the motherboard. Most sound cards are integrated.

I cannot say whether the BIOS update will solve the sound issue. It very well might. But it should be done regardless, even if we are still troubleshooting sound afterward.