No sound from speakers on ASUS Zenbook 14 OLED

Hello Zorin Forum,

I'm hoping someone can help me with a sound issue I am experiencing on my new ASUS Zenbook 14 OLED laptop. I am not able to get sound to use the internal speakers. SOund works fine if I plug in earbuds into the headphone port and sound also works fine through the HDMI channel when connected to an external monitor with a speaker built into it. Also, sound works fine with bluetooth. The built in microphone also works fine. I just can't get sound to come out of the built in speakers.

I've worked with the Zorin support team and have gone through all of their steps to try to solve the problem but we haven't had any luck. FWIW, I had the same issue with sound on this same laptop with Fedora 36 and with Ubuntu 22.04 LTS. I am running Zorin 16 Pro and it is fully up to date.

Please, if you have ideas that can help me solve this issue, please share them.

thanks!

See if this Linux Mint thread helps:

https://forums.linuxmint.com/viewtopic.php?t=368741

Hi @swarfendor437 - thanks for the link. I've read through the whole thread. Not sure how to proceed. Are you thinking that if I install the UMKI it might fix my situation? I think I need to reread that thread a couple of times to fully discern what they did to solve the challenge of sound there.

The thread offers One Method of installing a higher Mainline kernel than what is vetted by the distro.

On Zorin OS, you also have many options, too.
I believe I wrote a tutorial on the forum that is similar to the method in the Mint Thread. Yep, found it:

Another method would be to use the TuxInvader repository and install the patched kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install -y linux-generic-5.19

And another method still: The Liqourix kernel:

sudo add-apt-repository ppa:damentz/liquorix -y

sudo apt update && sudo apt install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

Each of the methods above can help you to achieve the goal: Getting a higher linux kernel onto your build of Zorin OS than what is currently tested stable and vetted by Zorin.
Which means... It comes with risks.
It may solve your sound issue.
It may include regressions or instabilities present in a later kernel, which is why Zorin OS has not currently vetted it.
When using a higher kernel, always stay at-the-ready to reverse it by reverting back to the earlier working kernel and Back Up Personal Data first.

2 Likes

And it would be a good idea to turn off secure boot in the BIOS. @Aravisian and I already discussed this with a similar issue I'm currently working on. If secure boot is left on and a later kernel is installed, the PC would return 'invalid signature' and you won't be able to proceed when just powered on or restarted. I know from experience.

3 Likes

Can you open a terminal session and run alsamixer
Hit F5 to show 'All' your sound channels and post a screenshot.

I suspect if you have already spent time with Zorin support team on this problem, you may have already done this, but maybe a chance we can spot something from your screenshot.

Thank you for all of the information you shared. I will dig into it. I wonder though if a later kernel will fix the issue as I have the same situation when I used Ubuntu 22.04 LTS and with that I tried a later kernel that what was first installed. Same with Fedora 36.

It's just so puzzling that sound works fine when using the headphone jack and with bluetooth. I know mechanically the speakers work because I have Win11 dual boot and sound there is fine.

Did that work when you tried it?

here you go. Maybe you'll see something I didn't. (fingers-crossed)

thanks for helping. :slight_smile:

Sadly, no. Exact same situation on 22.04 LTS and Fedora 36... sound works fine with headphone jack and bluetooth but not with the internal speakers.

Thanks. Both Secure Boot and Fast Boot are off. I just double checked to ensure they are off but I appreciate the help.

1 Like

So we can accept that the latest kernel does not contain a fix...

You could try unmuting [Headphone]. Anything is worth a try.
Seems Realtek ALC294 is problematic on Ubuntu derivatives as I have found from doing websearch using: "realtek alc294 no sound ubuntu 20.04"

See if any of this helps:

Also but related to PopOS

This issue same happened with my gaming laptop

Unmuting the Microphone didn't help, but thanks for the suggestion. I'll look through the askubuntu links when I have more time. thanks again :slight_smile:

I tried one solution which involved editing the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common (with sudo), but to no avail. That may have just been suitable for folks experiencing either zero or max volume as opposed to no sound.

I assume you also checked out the associated links including this one:

If all else fails, you could get a low cost USB soundcard. Several mentions of those on the forum if you do a search of "USB soundcard" or similar.