No sound in MacBook Pro 2017

No sound is coming from my laptop. I can change the volume of the devices but nothing is happening. It also says I have Speakers and Headphones plugged in but I do not have headphone plugged into this laptop and I never did. Any help?

1 Like


Try with


in the terminal and check if something is muted or set very low.

It is set at 100.

What soundcard do you have?

In Alsamixer
is Automute set ON?
Is Loopback set ON?
A screenshot would be useful.

What does your Zorin>Settings>Sound page look like?

Did you check that you have selected a correct sound card in Alsamixer by pressing F6?

How do I check if Automute and Loopback are on?
Screenshot below.

1 Like

When I press F6 on my laptop it changes the brightness of the background light in my keyboard (MacOS). Is there a way to change this in Zorin OS settings?

Your keyboard is a so-called multimedia keyboard.
There is a way to make those function keys to work as regular function keys. But for the time being, please press fn key together with F6.
You have to do this in Alsamixer window.

1 Like

I already tried this.

1 Like

Ah, I remember that you are using Apple keyboard like myself. You can follow this tutorial I wrote for that purpose.


Thank you. I just checked and it is set to the correct sound card.

1 Like

Thank you for the tutorial.

I remember now.

When I was running macOS on PC, the most tricky part was a sound card. It is because real mac does not have a sound card. It is integrated in a circuit of the logic board. I solved that issue by using USB DAC.

Now the problem is in reverse direction.
Could you tell me how this "sound card" is displayed in Alsamixer?

I do not know how. It says the name of the sound card is 0 HDA Intel PCH.

Are there any other option?
When you press F6, there should be a list of available sound sources. Mine looks like this:

1 Like

Mine looks the same but without the available sources, only Master.

and that is set to 100% volume I suppose.
I wonder if you can give me the model name of your macbook.

They should appear in Alsamixerbut clearly if you only see "Master" then there is something wrong. I remember another user posting Alsamixer showing only that. I will try and search for that thread.
If you can post a screenshot of your Alsamixer that would help.

If you can provide that info then it will also help.

In the meantime see if this thread, and the link provided there, helps you at all:

1 Like

How do I find my model name of my MacBook.

I know how to find it in within macOS.

But if I remembered it correctly, you removed macOS completely, no?